×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Voip.ms - delayed inbound issue with DID
4

Voip.ms - delayed inbound issue with DID

Voip.ms - delayed inbound issue with DID

(OP)
Starting new thread

gberger (CrazyUser)(OP) 3 Nov 21 23:26

After a while when calling my did number(voip.ms) it does not reach the Bcm50 (looking in Bcm Monitor).
It will work only if i make a call from my softphone then i can call my DID and the softphone will ring.( like if the SIP trunks are not in an idle mode for incoming calls)
Could it be a Keepalive option? any clues?
---------------------------------------------------

notlarryormoe (InsaneUser)(OP) 4 Nov 21 12:45est

How are you calling from the softphone? out on another type of trunk or other?
-Did you see the status of registration in SIP Trunks/Accounts?
-Also do the alarms show any 51104 alarms?

I have been having some similar issue but it was with sub accounts while the main account was not registered.
My main account was set to Ring Group, which the subs are members of.
I had to call out as well (I forget method) but it was if I also woke it up.

At the moment (because of the same issue) I am trying to sort out how to call sub accounts into the BCM...such as dial 10X from a sofphone on a mobile to a sub account on the BCM.






________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: Voip.ms - delayed inbound issue with DID

See my answers below;

Not sure if it's caused by Voip.ms or the Bcm50.
I used that same account on a Cisco ATA for 5 years without any issue but since it's on the Bcm50 i have that issue where i need to make an outside call to wake up the SIP trunks in order to be able to receive inbound calls.

How are you calling from the softphone? out on another type of trunk or other? I tried copper line,SIP line and Cellular with the same results.
-Did you see the status of registration in SIP Trunks/Accounts? I allways shows "Registered" with montreal7.voip.ms
-Also do the alarms show any 51104 alarms? No alarms at all

RE: Voip.ms - delayed inbound issue with DID

Any taker?

RE: Voip.ms - delayed inbound issue with DID

2
The most likely cause is your router's implementation of NAT. After some period of time, the router closes the NAT session that it created for the communication between the BCM and VoIP.ms. With the session closed, packets from VoIP.ms cannot reach the BCM. When you make an outbound call, a packet to VoIP.ms opens a session and incoming calls work for a while again.

You have two options:
1. Configure the BCM to send keep alive messages to VoIP.ms
2. Configure port forwarding on your router to direct all packets received on the BCM's SIP port (usually 5060) to the BCM's IP address

RE: Voip.ms - delayed inbound issue with DID

2
An issue I suddenly had with calling certain numbers and getting nothing but 'dead air' might be related.

I've had my Flowroute SIP trunks for 5+ years, and they've worked well during that time. Suddenly a couple of months ago I couldn't call my brother in the Reno area. I'd dial his number and get 'dead air.'

I contacted Flowroute and they told me my BCM50 was sending the local LAN IP address instead of the public IP address. Due to some sort of compensation Flowroute told me they could usually still route the calls correctly. I thought this was weird as I'd had minimal issues with my SIP trunks during those 5+ years.

The Flowroute tech suggested I enable NAT traversal on my trunks. All I saw in the SIP settings under the advanced tab was a check box for NAT compensation, so I went ahead and enabled this in my BCM50. The system also made me enable media relay before I could enable NAT compensation.

After I made the above changes I made a test call to my brother and it went through. I had Flowroute look at their logs for the test call and they told me my BCM50 was now sending the public IP address as it should. I shrugged my shoulders and have left it that way ever since.

I've attached a screenshot of my current settings.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952

RE: Voip.ms - delayed inbound issue with DID

(OP)
Also at voip.ms under account settings you have:
A: Asterisk, IP PBX, Gateway or VoIP Switch
B: ATA Device, IP Phone or Softphone

Which one is yours set too? I have mine at ATA
I will test mine vigorously when time but a couple stars deserved.




=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: Voip.ms - delayed inbound issue with DID

In Voip.ms config i have it set for IP PBX because it would not work under ATA.
As exsmogger suggest i will try the "NAT compensation" and report back.
Also like ucxguy keepalive option so will try it if the first suggestion doesn't work.

RE: Voip.ms - delayed inbound issue with DID

(OP)
My issue appears to be fixed.

No inbound after little awhile, unless I kick start it with making an outbound call....much like gbergers issue.
For me the account on the BCM showed registered but showed unregistered at voip.ms portal
Playing with some settings also kick started....or made it worse.

I noticed in exsmogger's screen shot he has ITSP association method set to: From header proxy address match.
Even though Wiki Voip.ms with BCM states "From header domain match" I thought I would try it anyway and that is what fixed my issue.

My settings for Voip.ms are attached in the link below in PDF format.

Thanks for the tip guys.







=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: Voip.ms - delayed inbound issue with DID

(OP)
"i have it set for IP PBX because it would not work under ATA."

I actually had it set to that too, but in testing the other day it was left at ATA, it only works once for me then the portal shows it as deregistered right after the test call, so I put it back to PBX today.



=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: Voip.ms - delayed inbound issue with DID

Curlycord,

A knowledgeable Flowroute tech told me the correct ITSP association method for their service was From header proxy address match a couple of years ago. This seems to be a setting many of the SIP providers don't advertise.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952

RE: Voip.ms - delayed inbound issue with DID

(OP)
Good tip indeed, thanks!



=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: Voip.ms - delayed inbound issue with DID

**FIXED**

Enabling "NAT compensation and Media Relay" didn't fix it so i forwarded port 5060 to the Bcm50 Ip adress and it works like a charm!
ucxguy have a star!

RE: Voip.ms - delayed inbound issue with DID

(OP)
I agree, try to avoid that.
Try the one that fixed it for me, but disable that port forward on 5060 first.
And/Or you should always disable any SIP ALG settings on the router, the hinder, not help.



=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: Voip.ms - delayed inbound issue with DID


I noticed that after an hour all 12 SIP trunks were in use showing "alerting" in Bcm Monitor...

I fixed it by allowing only incoming connection from VoipMS on port 5060, no more issue to report.

RE: Voip.ms - delayed inbound issue with DID

(OP)
Did you try the other fixes?
-disable any SIP ALG
-use: From header proxy address match

If we do not have 5060 forwarded then you shouldn't either.



=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: Voip.ms - delayed inbound issue with DID


I disabled SIP ALG and used: "From header proxy address match" but it's a no go, not sure why but by allowing only VoipMS requests on port 5060 works so i guess i will leave it like that for now.

Thanks for your help curlycord!

RE: Voip.ms - delayed inbound issue with DID

Yes it does, Asus RT-AC1900P that i got used for $100.00,i really like Asus routers.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close