×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Sidekick won't save toolbar changes -- pt deux

Sidekick won't save toolbar changes -- pt deux

Sidekick won't save toolbar changes -- pt deux

(OP)
thread807-1801625: SKW 98 - won't save Toolbar changes

I got a new computer and have installed SK successfully...but for one thing. I can't get the tool bar settings to persist from one session to the next. That is, I set up the toolbar as pleases me, but the next time I boot up SK, it has reverted to default.

@James33 suggested uninstalling and then reinstalling. That's not worked. I've done multiple un-installations and re-installations. I've even done so on multiple drives, first the d:\ drive where I have oodles of space, and then the c:\ drive which is more limited in space, but which is the boot drive. Everything works except the toolbar.

@james33 suggested copying a layout file from a working installation to the new one. I'm not sure what the layout file is, but I assumed it might be sklayout.skw. If so, that doesn't work either. I'm currently running two computers, the old one I got in 2013 and the new one from this past July, 2021. The layout persists fine on the old computer. But, if the file in question is sklayout.skw, then replacing the file on my new computer with the one on the old computer doesn't work.

Anyone have any other ideas?

RE: Sidekick won't save toolbar changes -- pt deux

Igpiper as an experiment I changed my toolbar and saved. Then looking in Sidekick programme files there were several changes in addition to sklayout.skw. Under "data" changes were saved in btbbar.bar , clocks.dat, CNFONT.DAT and CRDINFO3.dat. From these I would assume btbbar.bar is relevant.
Within "userdata" changes occurred in btcoINIT.SKW, btcoMAST.SKW and btcoTASK.SKW.
No other files were changed elsewhere so I think btbbar.bar might be a good starting point to copy over from the old computer in case your "new" one is corrupted.

RE: Sidekick won't save toolbar changes -- pt deux

(OP)
Well, this is truly weird, and I'm not sure what happened. I seriously doubt that I can provide a coherent narrative of my SK adventures over the past couple of weeks. So, please bear with me.

First of all, as to the toolbar files. SK has multiple toolbars, there is the one in question for this thread, i.e. that which appears in the calendar view. But, there are also tool bars for other views, e.g. contacts and expenses. So, I fiddled those toolbars a bit, and, like the one in calendar view, they all reverted to default when I started SK up again, after having turned it off.

So, when I'd try to change toolbars and save them, I would get updates to the files in \data: glcfont and btb_ct.bar; and updates in \userdata: lgpcsca, lgpinit, and lgpmast. So, I would guess that the changes should have been saved in some combination of these files, but they were not. Copying those files from my old computer, where the tool bar persisted, to the new one didn't help.

But, then my new computer got weird and crashed (actually, it's done this a lot, but only the latest crash changed things. Bummer I can't send it back.) and I couldn't get SK to start up at all. I got a little pop-up that said something about "/cityinfo.dat". When I clicked "ok" I got another pop up telling me I had a runtime error and that I had abnormal program termination. So, of course, I tried uninstalling SK and reinstalling it again, but every time I did this, I got the same behavior. This was not the case initially. Initially, I would install SK and it would boot up directly, albeit without the proper tool bar that I'd reset the previous time SK had been running. By the way, I've gotten really good at resetting the tool bar. I've also become adept at installing SK. Gah!

Anyway, I found it strange that SK would just boot up the first few times that I reinstalled it on my new computer. On my old computer(s), when I'd try to boot up SK I would get a pop up asking if I wanted "to let an app from an unknown publisher make changes to my device". Naturally, I said "ok", and was good to go. The tool bar persisted and so forth. But with the new computer, I didn't get said pop up and the toolbar did not persist after changes. But, other than the toolbar, and the fact that I lost my ToDo list for a time, the rest of SK worked fine.

But, after the last crash and reinstallation, I couldn't get SK to run at all. So, eventually, I tried something different. I right clicked the shortcut icon for running SK and changed the icon's properties to have me run the program as administrator (advanced properties). When I did that, I started getting the pop up asking me if I wanted "to let an app from an unknown publisher make changes to my device". Low and behold, when I clicked "ok", SK started up like a champ.

And, the wonderful thing is, for some weird reason, my toolbars are persisting again! So, I guess one could say I've solved the problem, but I'm not sure what changed to allow that. Or perhaps what I'm not sure of is what changed initially on the new computer to prevent things working properly.

Anyway, it would seem that ensuring one is running SK as "administrator" is what was needed.

RE: Sidekick won't save toolbar changes -- pt deux

Igpiper, if you had read previous submissions to this site you would have ascertained that it is ALWAYS necessary to install Sidekick as an "administrator".
See Rich224422 of 15th Jan 2020 and associated from James33.
KaraChow

RE: Sidekick won't save toolbar changes -- pt deux

(OP)
I always thought I had done so, previously. But something changed when I got this stupid new computer. Oh well, it's all fixed for the moment.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close