×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

SIP phones not automatically logging back in after patching.

SIP phones not automatically logging back in after patching.

SIP phones not automatically logging back in after patching.

(OP)
We have a few dozen remote SIP phones of various models J169, J179, 9608 registering through an SBC. Everything is 8.1. We recently patched the SM and SBC after hours. Since it was after hours, we weren't too concerned with outage time or trying to juggle swapping primary/secondary SBC's, etc. All patching went fine however once completed, only 3 phones reregistered. The rest came up with a login prompt. The phones could then be logged in fine but why did they "forget" their extensions? About half of the phones are dummy SIP remote extensions with a bridged appearance of the user's "real number" so these user's aren't even necessarily aware what their dummy SIP extension is to log it back in. Any info is appreciated. We do not have any phones registered directly to SM so I'm not sure if this is specific to SBC or not.

-CL

RE: SIP phones not automatically logging back in after patching.

It happens to me too and not even patching related. I’m on a lower version of both sbc/sm. If they normally reboot they come back online. Other times the user is sitting at a login prompt.

RE: SIP phones not automatically logging back in after patching.

I'll bet they got some bad SIP response code while the machines were in the process. Did you down the outside interface before patching?

RE: SIP phones not automatically logging back in after patching.

(OP)
hmmm... I did not down the interface. Is downing the interface a normal procedure when patching sbc/sm or are you just suggesting it as a possible prevention in the future?

-CL

RE: SIP phones not automatically logging back in after patching.

Oh yeah. If there were no SBC and it was straight to SM and you didn't deny service and you did an initTM -f, there'd be some point where the database would be pretty bare and could answer with a 404. I'll tell you that a SIP phone getting a 404 will drop to a login screen - either it's logging into the wrong server or it's logging in to the right server and it didn't know about him - in either case, the password is useless and shouldn't be retained for security purposes.

Same if you put the BSM in the 46xxsettings file for site 101 and you work at site 102 but you visited site 101 and logged in. Regardless of PPM, the phone will send a periodic register to every item in the 46xxsettings SIP_CONTROLLER_LIST and because your phone from site 102 doesn't have a "Survivable Server" of BSM-SITE-101, you'll send a register to him in about an hour, get a 404 and logout.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close