×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

AVAYA J179 phone Windows DHCP Voice VLAN and option

AVAYA J179 phone Windows DHCP Voice VLAN and option

AVAYA J179 phone Windows DHCP Voice VLAN and option

(OP)
Hello,

we are moving to IP telephony.
We install J179 phone anf IP office.
In some of the offices, computers and telephones each have their own outlet.
In other offices, we don't have enough sockets so I want to plug the PC and the phone into the same socket

We have vlan for data and vlan for telephony. The DHCP server is Windows. On this server, we have created different scopes. On those dedicated to telephony, we have added option 242.
We have also set up filtering by mac address on the DHCP server. The mac address equipment are well on the scopes.

We also have access-lists on our Cisco switches.
When I plug a phone alone into its dedicated socket, it works.
But when I want to plug a computer and a phone into the same outlet, it doesn't work. The PC gets its Ip and works. But the phone displays "waiting for dhcp"

I have configured the test ports like this when there is only one socket with a pc and a phone.

Switch(config-if)#switchport mode access
Switch(config-if)#spanning-tree portfast
Switch(config-if)#switchport access vlan 230 ( data vlan)
Switch(config-if)#switchport voice vlan 235 ( voice vlan)

All vlans are declared on our core switch, with ip helper address

LLDP is enabled on all the switch.

and as i say when i put a single phone on its port, with only the vlan 235 configured, it works.I get an ip from the good vlan

Something is missing, but I don't know what?

RE: AVAYA J179 phone Windows DHCP Voice VLAN and option

Do you have option 242 configured in the data vlan to tell the phone what VLAN to boot into? the phone will boot to the data vlan first. then 242 will tell it boot to this VLAN. i think it was a string like this

l2Q=1,L2QVLAN-xxx replace xxx with the correct VLAN id for the phones.

Kevin Wing
ACSS Small and Medium Enterprise (SME) Communications
ACS- Implement IP Office
ACA- Implement IP Office
Vive Communications

RE: AVAYA J179 phone Windows DHCP Voice VLAN and option

(OP)
Hello,

I added option 242 on the scope of the VLAN DATA

like this : l2Q=1,L2QVLAN=235 ( 235 = voice vlan)

option 242 on the DHCP for voice vlan is :

TLSSRVR=10.xxx,MCPORT=1719,MCIPADD=10.xxx,L2QVLAN=235,HTTPSRVR=10.xxx,TFTPSRVR=10.xxx,VLANTEST=1

i am not getting ip on the phone. But if I force fixed IP on the phone, it works.



RE: AVAYA J179 phone Windows DHCP Voice VLAN and option

Hi Abtt,

Are you sure the Phone is starting up in VLAN 235? You can see it in the display when the phone is starting i believe. It is also possible that your switch is using LLDP or CDP. This will overrule the DHCP option you have in your Data VLAN scope.

RE: AVAYA J179 phone Windows DHCP Voice VLAN and option

(OP)
Hi Tavayas,

yes, when the phone booted up i go to setup i can see vlan id and it shows 235 (the correct vlan). But when I look at the IP assigned to it, it is an IP from the vlan 230 subnet, not 235.
LLDP is enabled.

#sh lldp neigbours
CR-XXXX.Gi2/0/49 120 B,R Gi1/0/21
CR-XXXXXX.XXX.Gi1/0/49 120 B,R Gi2/0/21
AVXB3D635 Gi2/0/14 120 B,T c81f.eab3.d635
AVXB3D5FD Gi5/0/2 120 B,T c81f.eab3.d5fd
AVX878B31 Gi3/0/2 120 B,T c81f.ea87.8b31


I can see the 3 avaya phone.



RE: AVAYA J179 phone Windows DHCP Voice VLAN and option

You shouldn't have a L2QVLAN=235 in the option settings of the voice LAN. An L2QVLAN value is basically an instruction to go to another network (its doesn't matter that the phone is already on that right network, it just sees a loops around requesting option values from 235 again and eventually gives up and falls back to that last full set of values it had (those from your data LAN 230).

Stuck in a never ending cycle of file copying.

RE: AVAYA J179 phone Windows DHCP Voice VLAN and option

Hi abtt,

You can use LLDP (voice VLAN) to put the phones in VLAN 235. Than you don't need to put option 242 in your DHCP scope of the Data VLAN. When you achieve this you can simplify the option 242 in your voice DHCP scope to something like:

TLSSRVR=10.xxx,MCPORT=1719,MCIPADD=10.xxx,HTTPSRVR=10.xxx,TFTPSRVR=10.xxx,VLANTEST=10

RE: AVAYA J179 phone Windows DHCP Voice VLAN and option

(OP)
Hello,

my configuration on the switches:

#switchport mode access
#switchport access vlan 230
#switchport voice vlan 235

On the windows DHCp scope ( voice ) :

TLSSRVR=10.xxx,MCPORT=1719,MCIPADD=10.xxx,HTTPSRVR=10.xxx,TFTPSRVR=10.xxx,VLANTEST=1

But I don't get an Ip address from the voice vlan, the phone takes an Ip from the DATA vlan. the computer obtains an Ip from DATA vlan.

On the phone, if I turn off DHCp and manually enter an Ip from the voice vlan, it works.





RE: AVAYA J179 phone Windows DHCP Voice VLAN and option

Hi Abtt,

I have used this config in the past and works as you need it i think:

interface GigabitEthernet1/0/xx
description ### IP Phone - AVAYA ###
switchport access vlan 230
switchport mode access
switchport nonegotiate
switchport voice vlan 235
power inline auto
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
no shut

Hope this will work for you.

RE: AVAYA J179 phone Windows DHCP Voice VLAN and option

Quote (abtt)

VLANTEST=1

Why is VLANTEST set to 1? It is not a toggle 0 off 1 on it is the number of seconds before the phone gives up on the VLAN you specified... The default value is 60 seconds.

The truth is just an excuse for lack of imagination.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close