×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Program runs OK in W10 Pro but not in Home

Program runs OK in W10 Pro but not in Home

Program runs OK in W10 Pro but not in Home

(OP)
I created a few programs using gfortran in Windows 10 Pro, where they work well, but when I transferred the .exe files to my W10 Home laptop they all failed to start. I've tried a few ideas, such as compatibility with earlier Windows versions, but no success.

When I tried to run one of my programs (Chat.exe) the following message appeaared:

Chat.exe - Application Error
The application was unable to start correctly (0xc000007b).
Click OK to close the application.

I had no option but to comply!

I opened the Event Viewer (I had to Google how to do it) but I didn't understand what I saw. However, I right-clicked the most recent entry in the list and found the following information:

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
{C2F03A33-21F5-47FA-B4BB-156362A2F239} and APPID{316CDED5-E4AE-4B15-9113-7055D84DCC97} to the user DESKTOP-71CBE0F\alant SID (S-1-5-21-3699571922-1049258911-776565558-1001) from address LocalHost (Using LRPC) running in the application container Microsoft.Windows.ShellExperienceHost_10.0.19041.423_neutral_neutral_cw5n1h2txyewy SID (S-1-15-2-155514346-2573954481-755741238-1654018636-1233331829-3075935687-2861478708). This security permission can be modified using the Component Services administrative tool.

From this I think it is telling me that some aspect of my devcelopment machine is set to a value that makes it incompatible with my laptop, but maybe someone will tell me otherwise. If anyone needs more information, please give me detailed instructions as I am not too familiar with the inner workings of Windows.

The message mentions the Component Services administrative tool. How do I access that and how should I use it? Would I need to use it on my development machine or the laptop?

I'd appreciate whatever help someone could give me.

RE: Program runs OK in W10 Pro but not in Home

Are both machines the same architecture - both 32 or 64 bit.

Does it use any DLLs? On your source machine, pop up a cmd prompt and unset the path

set path=

Then run your program - does it work?
If it doesn't work, pop up another cmd prompt and see what is on your path - is it pointing to any gnu libraries.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close