×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Certificates and TLS

Certificates and TLS

Certificates and TLS

(OP)
Hello all,

I am still working on getting the correct certificates to where they need to go. My iPhone is complain about an issue with the security certificate.

I am running on an IPO 500v2 and VM Pro Application Server.

I have created the Identity Certificate using my Application Server as follows:



I uploaded this cert to the IPO



I am getting an error about "The Intermediate CA Certificate must be placed in the Trusted Certificate Store" - I am not sure which certificate it is specifically looking for.

The WebRootCA.pem is my next issue and where to generate it from.

I can download it from my application server which brings up file: root-ca.pem that I renamed to WebRootCA.pem (this is the only cert I was able to get my iPhone to take and allow me to "Enable Full Trust for Root Certificates)



If I download the certificate from Web Manager and re-name it WebRootCA.pem it lets me install it on my iPhone and says it is Verified However does not list in the iPhones "Certificate Trust Settings" to "Enable Full Trust for this Root Certificate. So I am assuming the download from my application server is correct - however I am still getting the certificate error on my iPhone.



Thoughts?





ACSS

RE: Certificates and TLS

(OP)
derfloh: Does Nano get run directly from the Application Server? Can I use something like notepad++ to edit the gen_certs.sh file locally?

"Adjust that line to have default validity of 820 days:" Mine was default at 825 days, should this still be adjusted down to 820?

Also, mine I believe already has the "echo "extendedKeyUsage = serverAuth,clientAuth" >> $EXT_FILE"



ACSS

RE: Certificates and TLS

(OP)
derfloh - I sent you a message on your website.

ACSS

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close