×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

eMG80 does not show Caller Name from Internal System Speed Dial

eMG80 does not show Caller Name from Internal System Speed Dial

eMG80 does not show Caller Name from Internal System Speed Dial

(OP)
Hi,
i have a eMG80 with 10 LIP9010.
The eMG80 had a SIP Trunk for in/out Communication. The sip trunk does send the caller number, for example if i call from my cellphone i get +39 (Italy Prefix) + 3331234567
When someone call, an IVR start asking to select the correct Office, then a group of LIP ring (group H720 for example).
In PGM 213 Option CLI Name Display is ON for every station.

When someone call and press for example 1, my LIP start ringing showing only the Caller Number and the group Number (H720 in my case) but it doesn't show the associated caller name that i've added in the System Speed Dial. I've tried inserting the +393331234567 format in speed dial as also only the 3331234567 without the international prefix. The record is a "loop" type. I've tried also a COGroup Type (as we have our cellphones inserted as speed dial associated to some flexible buttons)

Any hint on where to look to resolve that issue? I would like to see the caller name from system speed dial instead of the nunber.

Thank you

RE: eMG80 does not show Caller Name from Internal System Speed Dial

Hi, is caller name service set to on in pgm133 option 5? If this is on then it won't pull from the speed dials.

RE: eMG80 does not show Caller Name from Internal System Speed Dial

(OP)
Hi Cody64
Thank you for the responde
The PGM133 Option 5 i set to "Use" for all the SIP CO lines.
I should select "Unused" instead on "Use" for the CO lines to get it work?

RE: eMG80 does not show Caller Name from Internal System Speed Dial

That is my understanding, if it is on then it will use the name passed from the carrier if this is supported, if it is off then it will look in the speed dials.

RE: eMG80 does not show Caller Name from Internal System Speed Dial

(OP)
Thank you it worked!!
so recap for the future: PGM 113 option 8 Caller Name Display ON and PGM 133 option 5 Caller Name Service on UNESED for all the SIP CO Lines.

Just another thing: i noticed that the ipecs shows the incoming number as 39 333 12345678 (we are in italy) but shoulden't the correct form with 00 or + before the international prefix?
If i enter the number 333 12345678 in the system speed dial it doesn't get recognized, but in the form of 39 333 12345678 does.

RE: eMG80 does not show Caller Name from Internal System Speed Dial

what are your settings in program 151?

RE: eMG80 does not show Caller Name from Internal System Speed Dial

(OP)
Sorry martinhodge, i read it now.
I've never touched program 151 (CID/CPN Attributes)

RE: eMG80 does not show Caller Name from Internal System Speed Dial

(OP)
Here The screenshot of the PGM151
Any help is very much appreciated.

RE: eMG80 does not show Caller Name from Internal System Speed Dial

i normally turn incoming prefix to on here in the the uk . and put a zero in my area prefix code . you can put things like international access code in as well .

RE: eMG80 does not show Caller Name from Internal System Speed Dial

(OP)
Thank you martinhodge, i've tried you advices but still receving on the station the number with 39xxxxxxxxxx and from the stations i cannot call back the number (as soon as i go to Received Call -> 39xxxxx and press ok i get busy tone and the message Normal call cleaning).

If i analyze the sip trace i've noticed that the sip provider send me the number as +39xxxxxxxxx

RE: eMG80 does not show Caller Name from Internal System Speed Dial

that will be the issue then . as they are sending the plus instead of 00 .

this is the issue with internet based services .

some platforms have different ways of sending things . no uniformed way . for instance on withheld calls . some say withheld in the trace some say somthign else lol .

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close