×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

REXX ISPF TBDISPL Panel shows blank rows

REXX ISPF TBDISPL Panel shows blank rows

REXX ISPF TBDISPL Panel shows blank rows

(OP)
I am using the %exec option of SDSF ST panel.
My call to the exec goes fine where I create a ISPF table and add rows to the tables. I can see that the rows are getting added to the table.
At end I call the TBDISPL with Panel and the Panel also is displayed.
However no data is shown on the panel. Only blank rows.
Note that the number of lines in the panel are coming correctly and matches the number of TBADD I do in the exec.
I call the same exec directly and not from the SDSF ST panel using %exec, everything looks fine.
It's only when I am coming from SDSF ST panel, the values in the target panel becomes all blank.

RE: REXX ISPF TBDISPL Panel shows blank rows

Please do not plaster your query over every forum that you find. Use only one. If no response after a few (like 7) days then post elsewhere. All other postings of this topic I will delete.


Nic

RE: REXX ISPF TBDISPL Panel shows blank rows

(OP)
I did some further investigating by saving the table.
What I observe is that when I run the rexx directly from command, the TBADD function adds the data and after TBSave I can see the data fine in the output table library.
However when I call the same exec from SDSF panel, the TBADD function executes with rc=0 , however it does not saves the values of the variables. It saves them all spaces. So when the TBDISPL panel is invoked, it also shows all blanks.
So I am not understanding why TBADD bevaiour differs when the same rexx code and data is executed from command prompt and when it is called from other panel like SDSF ST panel.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close