×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Micros 3700 RES-FOH Not starting

Micros 3700 RES-FOH Not starting

Micros 3700 RES-FOH Not starting

(OP)
Hey,
We are having an issue at one location where the FOH doesn't always start after out daily restart of the server. If I open the control panel and click FOH it works and the terminals come up, but they open for breakfast and this causes an issue. Below are the errors I am seeing in the 3700D.log. The version is 5.7.4.


RE: Micros 3700 RES-FOH Not starting

(OP)
******* 3700d Debug Messages
******* Thu Feb 20 05:31:34 2020
Local Timestamp | Machine | Process | Handle | String | Binary Data
Thu Feb 20 05:31:34 2020 | WGWBMICROS | 3700d | 610 | 3700d Version 5.7.0000.4800, built May 13 2018 05:39:39 [NTService] |
Thu Feb 20 05:31:34 2020 | WGWBMICROS | 3700d | 610 | Process control rules rebuilt for [Normal 3700 operations] |
Thu Feb 20 05:31:34 2020 | WGWBMICROS | 3700d | 610 | Changing autostart level from [0] to [3] |
Thu Feb 20 05:31:34 2020 | WGWBMICROS | 3700d | 610 | Automatically changing to level [3] at system startup |
Thu Feb 20 05:31:34 2020 | WGWBMICROS | 3700d | 610 | current working directory for process [runDBMS] [D:\MICROS\Common\Bin\RunDBMS.exe ] will be [D:\MICROS\Res\Pos\etc] |
Thu Feb 20 05:31:34 2020 | WGWBMICROS | 3700d | 610 | calling CreateProcess() for process [runDBMS] [D:\MICROS\Common\Bin\RunDBMS.exe ], dwCreateFlags 0x0000000C, startupInfo.dwFlags 0x00000001, startupInfo.wShowWindow 0x00000007 |
Thu Feb 20 05:31:34 2020 | WGWBMICROS | 3700d | 610 | using server node process startup logic |
Thu Feb 20 05:31:34 2020 | WGWBMICROS | 3700d | 610 | process [runDBMS] [D:\MICROS\Common\Bin\RunDBMS.exe ] [0x00000694] successfully created |
Thu Feb 20 05:31:34 2020 | WGWBMICROS | 3700d | 610 | process [runDBMS] [D:\MICROS\Common\Bin\RunDBMS.exe ] [0x00000694] successfully started |
Thu Feb 20 05:31:50 2020 | D200107 | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1031 |
Thu Feb 20 05:31:50 2020 | D200107 | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1031 |
Thu Feb 20 05:31:51 2020 | D200107 | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1032 |
Thu Feb 20 05:31:52 2020 | D200107 | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1031 |
Thu Feb 20 05:31:55 2020 | D200107 | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1032 |
Thu Feb 20 05:31:52 2020 | WGWBPCWS02 | MDSHTTPTransprt | 0 | ** ERROR ** : HttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1015 |
Thu Feb 20 05:31:52 2020 | WGWBPCWS02 | CTUtil | 0 | Could not connect to the server. |
Thu Feb 20 05:31:52 2020 | WGWBPCWS02 | MDSHTTPTransprt | 0 | ** ERROR ** : HttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 944 |
Thu Feb 20 05:31:53 2020 | WGWBPCWS02 | MDSHTTPTransprt | 0 | ** ERROR ** : HttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 956 |
Thu Feb 20 05:31:54 2020 | WGWBPCWS02 | MDSHTTPTransprt | 0 | ** ERROR ** : HttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 951 |
Thu Feb 20 05:31:54 2020 | WGWBPCWS02 | MDSHTTPTransprt | 0 | ** ERROR ** : HttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 913 |
Thu Feb 20 05:31:56 2020 | WGWBPCWS02 | MDSHTTPTransprt | 0 | ** ERROR ** : HttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1010 |
Thu Feb 20 05:31:56 2020 | WGWBPCWS02 | CTUtil | 0 | Could not connect to the server. |
Thu Feb 20 05:31:56 2020 | WGWBPCWS02 | MDSHTTPTransprt | 0 | ** ERROR ** : HttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1013 |
Thu Feb 20 05:31:51 2020 | WGWBPCWS01 | MDSHTTPTransprt | 0 | ** ERROR ** : HttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1016 |
Thu Feb 20 05:31:51 2020 | WGWBPCWS01 | CTUtil | 0 | Could not connect to the server. |
Thu Feb 20 05:31:52 2020 | WGWBPCWS01 | MDSHTTPTransprt | 0 | ** ERROR ** : HttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 944 |
Thu Feb 20 05:31:52 2020 | WGWBPCWS01 | MDSHTTPTransprt | 0 | ** ERROR ** : HttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 956 |
Thu Feb 20 05:31:53 2020 | WGWBPCWS01 | MDSHTTPTransprt | 0 | ** ERROR ** : HttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 951 |
Thu Feb 20 05:31:54 2020 | WGWBPCWS01 | MDSHTTPTransprt | 0 | ** ERROR ** : HttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 913 |
Thu Feb 20 05:31:55 2020 | WGWBPCWS01 | MDSHTTPTransprt | 0 | ** ERROR ** : HttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 992 |
Thu Feb 20 05:31:55 2020 | WGWBPCWS01 | CTUtil | 0 | Could not connect to the server. |
Thu Feb 20 05:31:56 2020 | WGWBPCWS01 | MDSHTTPTransprt | 0 | ** ERROR ** : HttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1014 |
Thu Feb 20 05:31:51 2020 | DSK04016 | MDSHTTPTransprt | 0 | DoRequest found node WGWBMICROS [10.6.47.70] not ping-able |
Thu Feb 20 05:31:52 2020 | DSK04016 | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1856 |
Thu Feb 20 05:31:53 2020 | DSK04016 | ILDS | 0 | Freeing PeriphsDll.dll and control.dll |
Thu Feb 20 05:31:54 2020 | DSK04016 | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 2028 |
Thu Feb 20 05:31:54 2020 | DSK04016 | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 2012 |
Thu Feb 20 05:31:53 2020 | WGWBPCWS03 | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1000 |
Thu Feb 20 05:31:53 2020 | WGWBPCWS03 | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1000 |
Thu Feb 20 05:31:54 2020 | WGWBPCWS03 | AppStarter | 0 | 'C:\MICROS\COMMON\BIN\WaitForHostsFile.exe' : Executed Successfully. Exit code = 0 |
Thu Feb 20 05:31:55 2020 | WGWBPCWS03 | CTUtil | 0 | Checking Client Trust... |
Thu Feb 20 05:31:55 2020 | WGWBPCWS03 | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1016 |
Thu Feb 20 05:31:55 2020 | WGWBPCWS03 | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 984 |
Thu Feb 20 05:31:56 2020 | WGWBPCWS03 | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1015 |
Thu Feb 20 05:31:56 2020 | WGWBPCWS03 | CTUtil | 0 | Verify client trust - communication error. |
Thu Feb 20 05:30:49 2020 | WGWBMICROS | DSM | 0 | Uploading File - $(MICROS_DIR_COMMON)\etc\PINpads.xml to host - machine name - WBMICROSBOH |
Thu Feb 20 05:31:33 2020 | WGWBMICROS | DbUpdateServer | 0 | Setting last valid version (Startup) to 1D5E7D8-EC34E7A0 |
Thu Feb 20 05:31:36 2020 | WGWBMICROS | AutoSeqServer | 0 | Autosequence Server Version 5.7.0000.4800: 05-14-2018 10:55 |
Thu Feb 20 05:31:36 2020 | WGWBMICROS | AutoSeqServer | 0 | Windows NT Version 6.1 (Build 7601:Service Pack 1) |
Thu Feb 20 05:31:36 2020 | WGWBMICROS | AutoSeqServer | 0 | Autosequence Server Is Starting Up. |
Thu Feb 20 05:31:37 2020 | WGWBMICROS | DSM | 0 | MICROS Distributed Service Manager Version 5.7.0000.4800, built May 13 2018 07:53:00 starting up |
Thu Feb 20 05:31:37 2020 | WGWBMICROS | DSM | 0 | Key server [5.7.0000.4800] started |
Thu Feb 20 05:31:37 2020 | WGWBMICROS | PeriphsDll | 0 | periphsdll.dll version 5.7.0100.4995 built Aug 30 2018 11:48:13 |
Thu Feb 20 05:31:37 2020 | WGWBMICROS | PeriphsDll | 0 | Verbosity initialized to 0 |
Thu Feb 20 05:31:37 2020 | WGWBMICROS | ILDS | 0 | Starting ILDS [Version 5.7.0100.4995] |
Thu Feb 20 05:31:37 2020 | WGWBMICROS | ILDS | 0 | No LDS configuration in registry |
Thu Feb 20 05:31:37 2020 | WGWBMICROS | ILDS | 0 | ILDS not configured in registry, exiting... |
Thu Feb 20 05:31:37 2020 | WGWBMICROS | IFS | 0 | Starting executable 'D:\Micros\Common\Bin\Ifs.exe' 5.7.0000.4800 Process Id '[pid 0x00000788]' |
Thu Feb 20 05:31:38 2020 | WGWBMICROS | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1092 |
Thu Feb 20 05:31:38 2020 | WGWBMICROS | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1029 |
Thu Feb 20 05:31:38 2020 | WGWBMICROS | runDBMS | 0 | Waiting 6 seconds before rechecking srvMDSHTTPService service state |
Thu Feb 20 05:31:38 2020 | WGWBMICROS | DSM | 0 | Key verbosity value changed to [1] |
Thu Feb 20 05:31:38 2020 | WGWBMICROS | DSM | 0 | Incorporates CLicense Version 5.7.0000.4800 |
Thu Feb 20 05:31:38 2020 | WGWBMICROS | MDSHTTPTransprt | 0 | ** ERROR ** : WinHttpSendRequest() FAILED : LastErr = 12029; Elapsed time = 1029 |
Thu Feb 20 05:31:38 2020 | WGWBMICROS | IFS | 0 | IFS version [5.7.0000.4800] checking registry |
Thu Feb 20 05:31:38 2020 | WGWBMICROS | IFS | 0 | Reading registry info for [PMS] |
Thu Feb 20 05:31:38 2020 | WGWBMICROS | IFS | 0 | Server is [Javaapp1] |
Thu Feb 20 05:31:38 2020 | WGWBMICROS | IFS | 0 | TCP port is [4444] |
Thu Feb 20 05:31:38 2020 | WGWBMICROS | IFS | 0 | Num ID digits is [9] |

RE: Micros 3700 RES-FOH Not starting

Do you have it set to start on FOH from POS Configurator - System - Restaurant?

RE: Micros 3700 RES-FOH Not starting

(OP)
Yes

RE: Micros 3700 RES-FOH Not starting

When you are having this issue, could you check services for Micros MDS HTTP Server.
It seems this service may be failing to start when you reboot your server.

RE: Micros 3700 RES-FOH Not starting

(OP)
@K Mos
Thanks. I'll check that.

RE: Micros 3700 RES-FOH Not starting

(OP)
I created a scheduled task to change the database to FOH just before they open and any time the server is restarted. Problem solved.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close