×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Please excuse me for posting this here but i need some sugestions

Please excuse me for posting this here but i need some sugestions

Please excuse me for posting this here but i need some sugestions

(OP)
Hi Everyone,
SBT PRO 5.0 was developed by a company using VFP 5.0

everything has been working fine in SBT PRO 5.0 under windows 10 pro 64 bit and Windows server 2016 but the last 3 days the app is not able to access a particular dbf file .

Detail Info:
Each workstation have under folder c:\windows\SYSWOW64 all the runtime libraries (.dll) as well a TMP folder on each c:\drive of a workstation, as well a defined TMP variable under" ADVANCE SYSTEM SETTINGS==> SYSTEM PROPERTIES==>ADVANCE TAB==>ENVIRONMENT VARIABLES" and correct pointing path where the tmp files should be created on each workstation.

now suddenly about 3 days ago, when users go into the REPORT WRITER==>REPORT MANAGER(an SBT option to run some custom reports) where they always had access to run the reports, now when they select the "REPORT MANAGER" they get the following error

"[ERROR 1705] fILE FFMSGVC.DBF is not available[exclusive use],user could be reindexing the file or closing a period, please wait until the process is finished."

I am writing this from home, that is why i don't recall the complete error but it is about that, so the
error 1705 is not allowing the "REPORT MANAGER" to open, as imply the above table is not available.

so this is what i did.

1- i open the sbt as administrator, no luck same error.
2- i have myself full access to all modules in SBT so i cannot even open the "REPORT MANAGER"
3- i went to the server and checked that the permissions for the folder PRO50 for the all the users that need to access and run "SBT" they have read, write, modify, so then i changed the shared folder where SBT resides under security,permission to "full access", even thou before i changed, to FULL access, they were able to run the the "REPORT MANAGER",so Full access still no allowing them or I to run "REPORT MANAGER" so still same error pop for each user, there is not problem with any other module, i have reindexed applications and files, no luck, i even opened in vfp 5.0 the "FFMSGVC.DBF" i cannot remember exactly the full name of the table but it is something like that name and i even reindex the table no problem, table has been reindexed, so also cleared all lock files and users using an option in SBT, still no luck.

****
4- i made a copy of the whole folder "Pro50" from the server and copied to a usb flash drive, then created a batch file where i am mapping to the mounted usb flash drive,then inserted this flash drive into my workstation so then from the same shortcut in my desktop from where i run/open the SBT application(initialled located in the server) now all of that is in the mounted USB FLASH DRIVE, so now i am able to access the sbt from the flash drive then i added full permission on that usb drive and i can run the "report manager"(so that was the reason i determined to went back to the server and added to the shared folder "accounting"(where the PRO50 folder is located) full access to the users that need to run "SBT pro 5.0", still the same problem on "REPORT MANAGER".
so i have to assume that has to be a "group policy" that do not allow the SBTUSERS GROUP to have full access to the shared folder "ACCOUNTING where folder PRO50 belongs)" so i manually went to the server and applied full access permission to the group that the SBT users belongs.

i don't have access as administrator to reach the group policy, as there is someone else managing the server as they are doing some work on it, even if i applied full access to those users that need to run the repots, if there is any GPO running each time the users logon to the domain and prohibit full access to that shared folder i beleive this GPO will overwrite the full permission i applied so could be that ?

Or can be a backup that maybe is running every two hours or so in the server, or an antivirus in the server running, can this be just locking that dbf file ?

Does anyone have any other suggestion that can help troubleshoot this please ?
Thanks so much in advanceNote:again sorry for posting here but just looking for some suggestions from the knowledge people
Ernesto

RE: Please excuse me for posting this here but i need some sugestions

Exclusive use excludes any other users, no matter if they have sufficient permissions. Therefore all your efforts to manage permissions or group policies are fruitless.

If the server file system thinks someone has an exclusive handle, that's blocking any other usage.

The easiest way to solve that is by restarting the server.

Such blocking exclusive file handles should disappear alone, even if the client having it crashed, but at times you can have an obstinate lock.

In general, you can see which files of a share have which handles given to which clients in the management console of the server. I'm not into the details, but that's one detail of server-side file share administration.

Bye, Olaf.

Olaf Doschke Software Engineering
https://www.doschke.name

RE: Please excuse me for posting this here but i need some sugestions

"...there is someone else managing the server as they are doing some work on it" - hmmmm.....

RE: Please excuse me for posting this here but i need some sugestions

(OP)
Hi Olaf,
Thanks a lot for the suggestions, great to know i have other directives
Ernesto

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close