×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects
2

Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

(OP)
All,

Having intermittent issues with my NexVortex SIP Trunk.

From what I can tell, this is only on Outbound calls. All testing is to the same outbound TN

Most of the time, when I place an outbound call, it connects right away as it should.

Other times, I will get "Waiting for Line" and the "Beep-Beep-Beep".

If I get the "Waiting for Line" and wait for: "Beep-Beep-Beep"-"Beep-Beep-Beep"...."Beep-Beep-Beep" and then it connects.

Thoughts?

I did not see anything much in SSA:

12651485mS SIP Rx: UDP 104.219.163.73:5060 -> 172.30.20.1:5060
SIP/2.0 407 Proxy Authentication Required

ACSS

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

We have a customer in the UK with the same problem at version 9 using SIP trunks. I was able to capture the error as in the attached file via System Status. I made over 200 calls and it happened only around 4 times. We tried changing the SIP setting in the user section where it shows the 3 extension number to have the main CLI instead as the error log showed extension 249 was the outgoing CLI.

My file shows one error and two successful calls to a mobile number that I was dialling. Needless to say, that the problem is still happening and we have no idea if the issue is Avaya related or with the internet supplier / SIP trunk provider.

Next steps will be to change out the router and upgrade the IPO.

When I had the problem, I got the 3 bleeps, My mobile was ringing but I couldn't answer the call.

Firebird Scrambler

Nortel & Avaya Meridian 1 / Succession & BCM / Norstar Programmer

Website = http://somertel.myfreesites.net
linkedin

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

(OP)
Derfloh: that is what I meant. Monitor trace didn’t show much. Are there specific trace options I should select other that the default ones?

ACSS

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

The default should show all needed information.

If you just want SIP messages, clear all filters and just enable SIP call rx/tx

IP Office remote service https://www.fwilke.com/home
Fixed price SIP trunk configuration: https://www.fwilke.com/en/ip-office-sip-trunk-en/
CLI based cale blocking: https://blog.fwilke.com/ip-office-block-calls-from...
SCN fallback over PSTN: https://blog.fwilke.com/ip-office-scn-fallback/

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

(OP)
I will do some more testing Monday and post the traces.

In the mean time, here is what NexVortex sent me from their end during testing:

Great speaking with you again! As we discussed, seems their is a delay with your outbound calls getting to us. We tested today with the below data:

12:40:38 pm ET...you pressed the last digit on your outbound call to 586488XXXX
12:40:47 pm ET...you hear the 'beep' on your side
12:40:52 pm ET or 17:40:52 GMT...we receive your initial invite, first packet received for the call
12:40:54 pm ET... I was able to grab the 183 Session Progress (ringing) that we sent back to you two seconds later...nice!

Call example:
27 Dec 2019 17:40:52 1586961XXXX 1586488XXXX

Your initial invite with time stamp:
2019-12-27 17:40:52 +0000 : 50.245.XXX.XXX:5060 -> 104.219.XXX.XXX:5060 INVITE sip:1586488XXXX@px1.nexvortex.com SIP/2.0
Call ID:
Call-ID: ce65c50f356e9a8b96221db54fe940ca
183 Session progress sent back to you two seconds later:
2019-12-27 17:40:54 +0000 : 104.219.XXX.XXX:5060 -> 50.245.XXX.XXX:5060 SIP/2.0 183 Session Progress

ACSS

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

(OP)
So I was able to do some testing this morning, and going through the monitor trace, only one thing really stuck out from the log (I can post the entire log if that may help)

I took about 20 successful test calls to get the issue to show.

Basically I will make the call, get "Waiting for Line", "Beep-Beep-Beep"-"Beep-Beep-Beep"...."Beep-Beep-Beep" and then it connects. While it is "Waiting for line", my phone is not ringing, Once it goes through the "Waiting for Line", "Beep-Beep-Beep"-"Beep-Beep-Beep"...."Beep-Beep-Beep" the call connects and my cell phone begins to ring.

Below is part of the trace that may be the issue:

261721133mS SIP Rx: UDP 104.219.XXX.XXX:5060 -> 172.30.20.1:5060
SIP/2.0 407 Proxy Authentication Required
Via: SIP/2.0/UDP 50.245.XXX.XXX:5060;received=50.245.XXX.XXX;rport=5060;branch=z9hG4bKa6e2adaaf8adb7c19536b2a87c24f294
From: "586961XXXX" <sip:586961XXXX@px1.nexvortex.com>;tag=f051663cdedb41ee
To: <sip:1586488XXXX@px1.nexvortex.com>;tag=09c5247e8a9116fcdc76c940611a16eb.b0a0
Call-ID: 00bb219e7357e8cf769faba0de4130bb
CSeq: 1132117291 INVITE
Proxy-Authenticate: Digest realm="nexvortex.com", nonce="XgoXvl4KFpJ6W8iI0kFBq60chXnyeSR/"
Content-Length: 0


Thoughts?




ACSS

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

That part is not unusual. IPO should send ACK and then another INVITE with an additional authentication header. We need a full trace and not only part of a trace.

IP Office remote service https://www.fwilke.com/home
Fixed price SIP trunk configuration: https://www.fwilke.com/en/ip-office-sip-trunk-en/
CLI based cale blocking: https://blog.fwilke.com/ip-office-block-calls-from...
SCN fallback over PSTN: https://blog.fwilke.com/ip-office-scn-fallback/

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

SIP Rx: UDP 104.219.163.73:5060 -> 172.30.20.1:5060
SIP/2.0 100 trying -- your call is important to us
Via: SIP/2.0/UDP 50.245.111.77:5060;rport=5060;branch=z9hG4bK2cc326eda2bc238f3a213e0c86494376;received=50.245.111.77
From: "5869616380" <sip:5869616380@px1.nexvortex.com>;tag=f051663cdedb41ee
To: <sip:15864885440@px1.nexvortex.com>
Call-ID: 00bb219e7357e8cf769faba0de4130bb
CSeq: 1132117292 INVITE
Content-Length: 0

This seems like the provider is sending you a "please continue to hold" message as the call is in transit. You got the above response 3 times during the course of your trace.

The truth is just an excuse for lack of imagination.

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

If it is getting that message then disable the PRACK option on the SIP trunk. I had this happen and could not call certain numbers and it was because of the PRACK from the provider. It is on the VOIP tab of the SIP trunk.
Mike

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

(OP)
Side note, on successful test calls, "SIP/2.0 100 trying -- your call is important to us" still shows up in the trace.

ACSS

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

do you have re-invite enabled?
Mike

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

(OP)
teletechman: yes I do

ACSS

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

(OP)
teletechman: Should I disable "Re-Invite" and test?

ACSS

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

you could try but I don't think that is the issue.
Mike

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

(OP)
I am not sure if this is a coincidence or not, however I was going through the document from NexVortex (although its done on R9.1 and I am on R11) and I noticed a few things that were not done or removed during the months I have been testing with NexVortex.

Either way I enabled "Caller ID from From Header" and I was able to make 100 successful outbound calls without getting any "Waiting for Line" issues.

I also noticed that I either never added or removed at some point:

Calls Route via Registrar: Disable (Mine is checked)
Separate Registrar: reg.nexvortex.com

I have not done the above yet, thoughts?

ACSS

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

Maybe not related, but I recently started having similar issues with my outbound DIDWW Trunks. They just started hanging forever and eventually timing out.
I found out by accident how to fix it for me. In the user, go to sip tab, and make sure that SIP Name and Contact fields have actual 7 10 or 11 digit phone numbers in there and not just the extension.

Fixed the issue for me.


Travis

RE: Issues with SIP Trunk on R11.0.4.1.0, "Waiting for Line" and then Connects

That all depends on how you have the SIP URI setup. If you have use internal data then yes you need the SIP tab filled out for users. If you just put the main callerID in under the SIP URI it will present that number for everyone and the SIP tab doesn't need filled out (shouldn't even open). If you use * or auto for both in and out you "should" be able to use a shortcode to set the outbound callerID like PRI... but I have had issues with some US providers making that work.

The truth is just an excuse for lack of imagination.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close