×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

I've been creating printer document

I've been creating printer document

I've been creating printer document

(OP)
I've been creating printer documents that contain a duplex and simplex page. I've been adding a blank page to the back of the simplex page to make it appear as a duplex page and simplex page, but actually is duplex for the entire document, which as been controlled at the printer. It is also being pulled from 2 trays and stapled. The code worked fine, but now I need to actually make the document toggle between duplex and simplex. Not that familiar with postscript. Just takes a lot of experimentation to get things to work.

The working code, before needing to specify duplex/simplex is -
"<</MediaColor (pink)>> setpagedevice << /Staple 0 >> setpagedevice << /Staple 3 /StapleDetails <</Type 1 /StapleLocation (SinglePortrait) >> >> setpagedevice"

I tried -
"<</MediaColor (pink)>> setpagedevice << /Staple 0 >> setpagedevice << /Staple 3 /StapleDetails <</Type 1 /StapleLocation (SinglePortrait) >> >> setpagedevice <</Duplex true/Tumble false>> setpagdevice", but not only does it not print, it fails to generate as a pdf file. It does as a postscript, but that file can't be distilled.

The error I get for pdf generation is PDF creation failed.
Log file error message:
%%[ Warning: Empty job. No PDF file produced. ] %% Normalizer 8.0 UsePrologue is false. %%[ Error: undefined; OffendingCommand: setpagdevice ]%% Stack: -dict- %%[ Flushing: rest of job (to end-of-file) will be ignored ]%% ExternalCommand on page 1 :F %%[ Warning: PostScript error. No PDF file produced. ] %% Normalizer job 1 failed (2) -- aborting 5472256 bytes read from file \\WEB2PRINT1\Xmpie\XMPieOutput\7\720534\PDF2132simplexduplex_sjw2.txt_1.ps: FAILED Done

Any thoughts? Definitely need it to generate both a ps and pdf. I'll try printing the postscript to see if that works, but doubt it.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close