×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

voicemail to email not working

voicemail to email not working

voicemail to email not working

(OP)
not sure what happened over the past couple of weeks, but the voicemail to email option is no longer working! we have the Nortel BCM50 and a Nortel Contivity 1010 device and while the phones and vmail work, the option where you get an email notification after receiving a vmail no longer works. I've confirmed nothing is wrong with the software side in CallPilot Manager in terms of the settings so that leads me to suspect the hardware. I don't really have much information on this as this system was put into place before me and my knowledge of the system is basic at best. can anyone help me troubleshoot what might be wrong or what to do?

EDIT: logging into CallPilot Manager I just noticed that the setting that used to be available for each mailbox to forward to emails via a check box is no longer available! hopefully this is a clue for someone out there to help

RE: voicemail to email not working

Welcome to the forums dimm0k

What page and what is the name of setting are you referring to in Callpilot Manager?
We cannot see what you can so please be very specific when posting.

If your missing a box then will assume it's more likely a software or user/admin input issue.

Follow my steps in order until you might see where something is not inputted correctly...

To enable voice mail to email on Callpilot 100/150/BCM:

-Go to Configuration/SystemProperties and fill out all the SMPT message forwarding details at the bottom
-Go to the Class Of Service, choose your C.O.S. number that the mailbox is in and "Enable Message Forwarding"
-Go to the users Mailbox Manager/MessageForwarding and "Enable Message Forwarding"
---Fill in the email address
---And the rest of the options

Test and please always update your posts/threads no matter what, with resolution (when possible) so those whom help and others with same issue are not left hanging.
Thanks
cc









________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: voicemail to email not working

(OP)
@curlycord thank you for your reply. I was able to confirm your first step and its settings are input correctly. I'm stuck on the second step as I cannot find anything with regard to Class Of Service while in Callpilot Manager. The version number described in "System Properties" is Voice Mail Version: 43.03.24.22 and I know for a fact that my own mailbox should be forwarding my voicemail messages to me as an email. I've attached a screenshot of what I see. It may have been a while since I've actually given anyone access to this feature of "vmail to email" that I am recalling incorrectly of what the option should say, but I would guess at this point with relation to the info you've provided that the "Class of Service" of 2 does in fact mean "vmail to email"? You'll also note that in the screenshot that there is no mention of an email to use for the forwarding.

while digging around I was able to pull up the Event Log and below is a snippet of what may be the cause or possible multiple cause of what has gone wrong

CODE -->

ALARM REPORT                                        Date: 2019/12/10

Date       Time     Error Message
----       ----     -------------
...
2019-12-10T00:07:54.348 [INFO ] {STLog} (0) - Daily statistics ..
2019-12-10T00:07:54.349 [INFO ] {STLog} (0) - One call FOD 0 Two Call FOD 0 FOV 0 FAX Print 0
2019-12-10T00:07:54.349 [INFO ] {STLog} (0) - Incoming AMIS 0 Outgoing AMIS 0 VPorts Busy 0  FPorts Busy 0
2019-12-10T00:07:54.349 [INFO ] {STLog} (0) - F980 Sess 0 F981 Sess 5 F982 Sess 0 F983 Sess 0 F985 Sess 0
2019-12-10T00:07:54.349 [INFO ] {STLog} (0) - F986 Sess 0 F987 Sess 0 F988 Sess 0 F989 Sess 0 F930 Sess 0
2019-12-10T00:07:54.349 [INFO ] {STLog} (0) - Call Ans 17 AA/CCR 14 OPN 0
2019-12-10T00:07:54.349 [INFO ] {STLog} (0) - Ext Trans 0 Ctx Trans 0 Broadcast Msgs 0 Group List Msgs 0
2019-12-10T00:07:54.349 [INFO ] {STLog} (0) - SMTP Receive 0 SMTP Send 0 NVM Manager 0 Call Screening 0
2019-12-10T00:07:54.349 [INFO ] {STLog} (0) - Dsktp Logins 0 Dsktp Open Msgs 0 Text Bodies 0
2019-12-10T00:28:38.519 [INFO ] {STLog} (0) - SMTP: osConnectToSecureServer() failed rc=7(0x7)
2019-12-10T00:28:38.519 [INFO ] {STLog} (0) - SMTP: osReadFromSecureSocket failed rc=14478(0x388e)
2019-12-10T00:31:47.518 [INFO ] {STLog} (0) - SMTP: osTCPConnect() failed rc=7(0x7)
2019-12-10T00:31:47.518 [INFO ] {STLog} (0) - SMTP: SmtpSendMail SMTPConnectToServer failed rc=7(0x7) 

RE: voicemail to email not working

Perhaps you can edit that log, way too long and repetitive...edit button is to the right but for a limited time only.

When in the Manager did you go through the list to look for it?
Click on Mailbox Administration and it's the last link.

In the case of your screen shot above that mailbox is in Class Of Service 2.
However the screenshot is showing your mailbox under Mailbox Administration/Change, I did not direct you to go there as there is nothing there to see that is related to the issue.

FYI..even C.O.S. numbers are for the Alternate Language such as Spanish in the states or French in Canada.

________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: voicemail to email not working

(OP)
@curlycord sorry, I've edited the log to contain a small snippet of the log. As for C.O.S. that you were referring to, I found it after you mentioned it's in Mailbox Administration. I expanded all of the sections EXCEPT that for some reason. I've attached a screenshot of this section to show that it is in fact enabled so things should be working for phones with C.O.S. set to 2.



please disregard the previous comment's screenshot of the Mailbox. I included it since it was to show that that Mailbox was set differently in terms of the COS for ones that should have message forwarding set. now this leads me back to my log file of it not being able to connect to the SMTP server... I know there's nothing wrong with the SMTP server as I am able to connect it to my mail client on the desktop.

RE: voicemail to email not working

2019-12-10T00:28:38.519 [INFO ] {STLog} (0) - SMTP: osConnectToSecureServer() failed rc=7(0x7)

Well this leads me to a simple question, does your SMTP server see the BCM on your network? Can you ping the BCM from the server?

Marv ccna

RE: voicemail to email not working

Thanks for editing.

Still need to find where youy saying the Box is missing so my last questions still unanswered would be:
-Go to the users Mailbox Manager/MessageForwarding and "Enable Message Forwarding"
---Fill in the email address
---And the rest of the options

I was not paying attention to the alarms because you said the "Enable Message Forwarding" box is missing.
If you can confirm the box is in the Mailbox manager then I would look into what Marv is showing, even check the BCM's alarm list too.

________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: voicemail to email not working

(OP)
@allworxguy the SMTP server is actually an outside third party server. this has not changed since this was first installed (prior to me working here) and I do have the credentials so I am able to confirm it has not been changed. because the BCM is on our LAN it is not directly ping'able from the outside without making any changes on the firewall to do NAT. this part has also not been changed.

@curlycord sorry for not being clear. the missing box I was referring to was in the Mailbox screenshot that I first posted, which is what I see when I go to the users Mailbox Manager. here I do not see the "Enable Message Forwarding" option at all. can you confirm this is where I should see this option?

RE: voicemail to email not working

No it is not, what you are seeing is a particular mailbox's properties under Mailbox Administration.

You need to go to Mailbox Manager and not Callpilot Manager
So after the IP address enter /mailboxmanager instead of /callpilotmanager (http://xxx.xxx.xxx.xxx/mailboxmanager)
Then enter the users mailbox number and it's password.

Then you should see the box to enable "Message Forwarding" link.
Once you click that you will see "Enable Message Forwarding" box and the rest of the entries.

________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: voicemail to email not working

(OP)
@curlycord omg, there we go!! sorry, I was stuck in Callpilot Manager and thought the "Message Forwarding" link was there and not in the Mailbox Manager. anyway, to confirm the setting is there and is correctly set for my own mailbox. now that that's confirmed to be correct, what is next?

RE: voicemail to email not working

I would say go into ElementManager/Administration/Utilities/and use the Ping fetaure and ping 8.8.8.8 and your SMTP server....this will help see if the BCM can get in touch with the internet.
Maybe it's not on the network any longer? and network changes lately?

Also per Allworxguy about the alarms also check the BCM alarms too - ElementManager/Administration/General/Alarms and look for any alarms related the issue.


If you are convinced that the Callpilot settings are all correct and that you tried a reboot of the BCM then I would say you have a network issue and/or beyond.

________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: voicemail to email not working

(OP)
@curlycord looks like the BCM is not capable of contacting the Internet as it is not able to ping even 8.8.8.8. Do you happen to have a layout of what should be connected to for the BCM to get out onto the Internet? there were some tinkering around when the Verizon technician came by to replace the router and do some testing for a network related issue. unfortunately I was not around when this was happening so I'm not sure what they did!

RE: voicemail to email not working

Make sure cable is in the 2nd from the left on the BCM going into the Switch on the other end.

On a PC on the same network open/run Command Prompt (cmd)
Do: ipconfig and note the IP address, Subnet & Gateway

Check ElementManage/Configuration/IPSubsystem/LANintrefaces and check the IP address under Customer Lan
If you need to change it then change it, then reboot via Admin/Utilities/Reboot

Or you can do it via telset using F9*8 and the credentials.
IP Address, change as need then press BACK to see the Reboot option and do it.


________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: voicemail to email not working

(OP)
so the 2nd port from the left on the BCM has a cable attached with lights on connected to our switch. our PCs are on the same network with 192.168.200.xxx IP addresses. The closest I can get to what you described in Element Manager is pictured below

The IP address

Checking the IP address of my own phone, I can confirm that it is 192.168.200.52 and am able to ping the phone from the computer. This would mean they are both on the same network correct? I'm have no trouble getting to the Internet from the computer

RE: voicemail to email not working

Internal Lan would be same as Customer Lan, yours must be an older release....rls 3 maybe.
So it looks like the Internal LAN IP address on the BCM went back to default.
So change the IP address and also change the .252 at the end of the subnet to most likely .0, then go to General tab beside it and change the gateway too then reboot.





________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: voicemail to email not working

(OP)
so it looks like I've hit a snag... after making the changes and doing a reboot I'm getting the attached error message when trying to connect to Element Manager.

The phones themselves are saying server unavailable.

RE: voicemail to email not working

"The phones themselves are saying server unavailable."

I gather IP phones then....
If the phones were working on 10.10.99.1 then they are now trying to connect to 10.10.99.1.
This would mean something was changed on the network after all.

Put it back to 10.10.99.1 then and reboot.

You error is caused by you did not wait 15 minutes or so to boot up or you forgot to change the IP address on your laptop to something like 192.168.20.60

And contact your network crew to check into it.




________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: voicemail to email not working

(OP)
ahh, I was not aware that it would take 15 minutes or so to boot up! to confirm, I was supposed to change the IP to 192.168.200.1 and the .252 to .0 section correct? all the computers on the network get DHCP to an IP address in the 192.168.200.100-192.168.200.240 range while all the IP phones and the BCM are between .50 and .99. the weird thing is after I rebooted the device the IP address went back to 10.10.99.1 and also back to .252! after making these two changes I'm disconnected from ElementManager and logging back in still shows the old values! any ideas?

RE: voicemail to email not working


-Every device must have it's own IP and be in the same range (parts 1-3), only the last part (4) should be different from the rest.
-Most networks have a subnets of 255.255.255.0
-The Gateway is usually the lowest number such as .1

To sort out IP address's in regards to subnet being .0 or .252 I cannot tell you what really is correct,you need to this to answer that question:
"On a PC on the same network open/run Command Prompt (cmd)
Do: ipconfig and note the IP address, Subnet & Gateway"

ipconfig results:

Ethernet adapter Ethernet 4:

Connection-specific DNS Suffix . :
IPv6 Address. . . . . . . . . . . : 2607:fea8:2040:4ae:3cb1:fe14:4669:c22a
Temporary IPv6 Address. . . . . . : 2607:fea8:2040:4ae:cc91:22c1:59bf:8dd1
Link-local IPv6 Address . . . . . : fe80::3cb1:fe14:4669:c22a%14
IPv4 Address. . . . . . . . . . . : 192.168.1.247
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : fe80::76da:daff:febc:c06d%14
192.168.1.1

To make sure what the BCM IP was go to an IP set and press "Services" twice quickly, then press "Enter" to go to "IP Set Info", scroll down to bottom to see "EEPROM S1 IP: and see whats here.

If changing the IP address of BCM did not work then try via the phone as I stated above:
"Or you can do it via telset using F9*8 and the credentials used to normally program through the set.
Navigate to IP Address, change the three sections as need then press BACK to see the Reboot option."



________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: voicemail to email not working

(OP)
I can confirm that the subnet should be 255.255.255.0 and the static portions of the IP address are 192.168.200.xxx where the last xxx varies across the phones, printers, and computers on the network. on the phones themselves the S1 IP address matches the address of the BCM, 192.168.200.50.

RE: voicemail to email not working

How are you connecting to the BCM?
laptop direct to OAM port (far left) or from a node somewhere on the network?

Any other important update?
what is the status? IP sets now working? still stuck at the wrong IP ok 10.10.99.X??, still cannot connect? did you do try the IP change from the telephone and reboot?




________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: voicemail to email not working

(OP)
I've been connecting to the BCM directly from my computer to the BCM via the network and not the laptop method you mentioned. The IP sets are indeed working now since waiting the 15 minutes for the BCM to boot up, however in ElementManager it is still stuck on the 10.10.99.xxx IP address and not able to ping out to the Internet (8.8.8.8). if I am able to connect and ping the BCM from my computer and the phones' IPs are also set to the same network with everything working except for the voicemail to email feature, what IP are you suggesting to change from the phone? to note, the phones are the Nortel 1230 VOIP phones. unfortunately I do not have the credentials to F9*8 into them

RE: voicemail to email not working

Ok thanks

You are via Network then, not Direct.

I am only guessing:
BCM50 is maybe Rls 3?
IP sets are DHCP?
BCM has had a hick-up of sorts to default it's LAN IP
Changing the IP via telest * reboot will resolve issue:
IP 192.168.200.50
Sub 255.255.255.0
Gate 192.168.200.1 <<<----- Important so the BCM can see the world

As for F9*8 go the the main page of the BCM with your browser to the Documentation and look for Telset Administration Guide for the credentials (we cannot post passwords, emails or solicit on forums)
Perhaps the phone says something different then BEM/LanInterfaces....either way best to change it this way then after you pass the Gateway entry press BACK you get the Reboot option.

If still an issue then proceed to answer ALL 7 questions below and report all back:

-Check your Element Manager on the left side to note what IP address you are using to connect too.
-Go back into an IP set and check if it is set to DHCP
-Go into ElementManager/System/IPsubsystem/General and note the Default gateway and the Published IP address
-Go into ElementManager/System/IPsubsystem/LANinterfaces and again note the IP address and Subnet
-Go into ElementManager/DataServices/DHCPserver/General and note if DHCP server is disabled or enabled, and the IP domain name
-Go into ElementManager/DataServices/DHCPserver/AddressRange and note any range if you see one

192.168.200.XXX
255.255.255.0
???.???.???.??? <----you did not confirm the gateway, go back to run/cmd ipconfig on your PC to verify.


Normally I and others would say call a tech by now... but it's that time of year.







________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: voicemail to email not working

Do you have an update?

________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: voicemail to email not working

Still need an update please.

________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: voicemail to email not working

(OP)
@curlycord apologies for the lack of updates. not the ideal setup, but we this definitely looks like a firewall issue somewhere. we have a Nortel Contivity 1010 device (not sure what this does in terms of the overall system) that's connected to the PoE switch that the phones and Nortel BCM50 are connected to. this switch is also connected to our internal LAN so that we can ping the phones from our desktops. ultimately the Nortel Contivity 1010 was connected directly to our firewall and that prevented reaching the Internet for some reason. we've moved the Nortel Contivity 1010 to be outside of our firewall so that it can reach the Internet and vmail to email works fine. any ideas what is needed on our firewall to allow the Nortel Contivity 1010 access?

RE: voicemail to email not working

Thanks for update.

I do not know what is needed but suggest you post in an appropriate forum "networking" of sorts such as https://www.tek-tips.com/threadminder.cfm?pid=902
Describe your setup and why you are using the 1010 etc.

A search of 1010 in all forums in tek-tips here

________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close