×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Prariefyre Report Launcher

Prariefyre Report Launcher

Prariefyre Report Launcher

(OP)
Hello! I was hoping someone could help my small non profit with an issue we are having. We have an older version of Prariefyre and the report launcher is giving us problems, up until a week ago everyone was able to to view reports but for some reason everyone that could save for one machine with one domain user lost the ability one-by-one, including the server itself.

The error:
The Report Launcher object could not be created. Common causes of this problem are as follows:

You might have tried to gain access to the website via DNS/Computer name instead of an IP address, or vice versa. You can verify whether to use the DNS/computer name or the IP address by launching the Contact Center Client and using the same value that is in the enterprise server field.

the website folder /CCMWeb/applications/ReportLauncher may have been assigned incorrect execute permissions - ensure the execute permissions are set to Scrips only

We have tried everything outlined in the Troublshooting guide Mitel provided such as enabling trusted site, caspol fix, gac utility, remove/add domain users, set as admin, etc.. we are completely out of ideas. Thank you for any help you may provide!

RE: Prariefyre Report Launcher

Has the server been restarted?
Did the Windows User account password Change?

RE: Prariefyre Report Launcher

(OP)
Yes, server has been restarted many times. Windows User account password is the same.

RE: Prariefyre Report Launcher

What version of PrarieFyre?
Did you update Java recently?
I assume that you are using IE?

RE: Prariefyre Report Launcher

(OP)
5.3 Service Pack 3 (5.3.01258.1)

I don't believe Java has been updated on all the machines but I will definitely look into it. One reason why I don't believe java is the culprit is that I tried using a different Domain Login on the last remaining machine that is working (so the java version would be the same, right?) and it won't open reports. Only one domain user on that one machine.

Yes, we are using IE in compatibility mode.

*Edit wanted to thank you for the quick responses, I'll try to check in more often!

RE: Prariefyre Report Launcher

No worries I cannot always respond quickly.
At 5.3 there is a whole range of issues that can cause issues as that software release is at least 15+ years old. In fact I am surprised that any machines could get into the reports at all.
I do have a recollection of some form of windows update changing reports from working on 5.8. It had to do with IE and a change to Active X settings.
Aside from that you could try to look into the log files in the install directory - although my memory does not go far enough back to remember the name of the log file unfortunately.
Make sure that the caspol has been run on the server.

You mentioned that it was a slow propagation to all users, so if you have AD integration (which it sounds like you do) then I am thinking that there may have been a change on either a GPO, or the directories on the MiCC lost the user access credentials.
Another thing to check is that no one has been migrating users to a new OU that doesn't match the settings on the PF server.
As the troubleshooting mentions access to DLL's etc it is also possible that this is being blocked by real time scanning, firewall or antivirus.

To test proper access rights make sure to follow/try step 8 in the troubleshooting doc:
http://micc.mitel.com/kb/KnowledgebaseArticle50051...

Can't think of any other culprits on this one right now, sorry.

RE: Prariefyre Report Launcher

(OP)
I really appreciate all the information and I'm going to look into everything suggested. I'll update this post with the results. Thanks!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close