×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

SSH Keys to log CM

SSH Keys to log CM

SSH Keys to log CM

(OP)
trying to log into CM 6.3.8 using putty with SSH keys.

On CM under Administration - Server - SSH Keys I am able to copy RSA - SSH v2 key to clipboard.
On putty under Connection - SSH - Host Keys I am adding the key and saving.

When I try to connect I still am being prompted for the password
Note: under connection Data I already added the Auto-login username so I don't need to add the user

RE: SSH Keys to log CM

Those ssh keys are public keys, not private keys. They're for you to put in your terminal server or known_hosts on other things so you're not prompted to accept them manually.

I've never seen anyone log in to CM with SSH keys. I've never seen my user account in /var/home/dadmin/.ssh have anything for private keys I'd take and put anywhere else.

RE: SSH Keys to log CM

You can setup ssh keys between servers and login without password authentication for individual logins.

A great teacher, does not provide answers, but methods to teach others "How and where to find the answers"

bsh

45 years Bell, AT&T, Lucent, Avaya
Tier 3 for 35 years and counting
http://bshtele.com

RE: SSH Keys to log CM

good to know!

RE: SSH Keys to log CM

(OP)
That is what I am trying.

If I get the public key from CM (SMI) and add on putty I still am prompted for credentials.

Another attempt was: create private and public keys in CM (command line ssh-keygen).
Added key under .ssh/id_rsa and also tried under .ssh/authorized_keys/id_rsa
Added the public key on putty. Still not working

Another: got the private from CM (previously created) and loaded on putty key-gen (then I got a message that to use with putty I should save again the private with putty format (newer than avaya format).
Then I moved back the private key to CM with WinSCP. So I also dug into this but no success.

This should be easy to connect but I cannot figure it out.
If you guys are able to connect with SSH Keys please let me know.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close