×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Sunblade 150 NVRAM IDPROM Reprogramming Issues

Sunblade 150 NVRAM IDPROM Reprogramming Issues

Sunblade 150 NVRAM IDPROM Reprogramming Issues

(OP)
Just a quick question ...

We have reprogrammed the IDPROM NVRAM on older ULTRA and SB100s - probably running on OpenBoot 3.x and the mkp command always worked easily to reset the ethernet and host ID - SN

We just replaced the battery on a Sunblade 150 and am trying to reprogram the IDPROM

In the past we just ran these basic commands w/ the applicable ETH and Serial # data added.

Problem is that the mkp command returns a - mkp ?? result as it doesn't recognize the command?

Is it an OpenBoot version issue? This SB150 is running on OB 4.6 I believe

1 0 mkp
83 1 mkp
8 2 mkp
0 3 mkp
20 4 mkp
c0 5 mkp
ff 6 mkp
ee 7 mkp
0 8 mkp
0 9 mkp
0 a mkp
0 b mkp
c0 c mkp
ff d mkp
ee e mkp
0 f 0 do i idprom@ xor loop f mkp



RE: Sunblade 150 NVRAM IDPROM Reprogramming Issues

LOL I just encountered the same issue today, hope someone can help.
I was thinking about firing up one of my old sparc20 or ultra10 and reprogram a new nvram to the blade 83 ID
and then swap it into the blade. ST micro makes new chips that need to be programmed . they are less than $20
M48T58Y-70PC1 I ordered one and am waiting for it to try...

RE: Sunblade 150 NVRAM IDPROM Reprogramming Issues

(OP)
Chuck

That's what we ended up doing to get our SB150 running.

Bought some new NVRAM chips ... put them into one of our lab Ultra 5s and reprogrammed it with the correct Sn etc per instructions and then put it in the SB150.

Came right up.

RE: Sunblade 150 NVRAM IDPROM Reprogramming Issues

Ok great thanks !

RE: Sunblade 150 NVRAM IDPROM Reprogramming Issues

oh also i noticed there is a 3 volt lithium battery on the blade motherboard.
thought the battery was encased in the nvram like older suns.
any idea what this battery is for?

RE: Sunblade 150 NVRAM IDPROM Reprogramming Issues

where did you buy new chip from and part# ?
the original nvram is M48T59Y-70PC1 these are obsolete and any out there are probably old with dead battery.
I bought a new M48T58Y-70PC1 which is still in production - configured it in ultra 10 ( 80 ID )with mkp and worked fine.
Then reconfigured it for blade ( 83 ID ) and transfered chip to blade - shows banner ok and starts booting
hard drive and stops and says " can't load TOD program terminated " I assume means time of day
Boots ok with another good nvram I have
Am i missing something or will these M48T58Y not work in a blade ??

RE: Sunblade 150 NVRAM IDPROM Reprogramming Issues

@chuck57: Did you resolve this issue (with M48T58Y not working in a Blade) and if so, what did you do? I have just experienced exactly the same problem.

RE: Sunblade 150 NVRAM IDPROM Reprogramming Issues

I ended up purchasing some 59's on ebay that came from china - only like $8 , 2 of the 3 actually worked -
programmed them in ultra10 and then installed chip in blade.
There are also US vendors that sell what they claim are new ones for the blade and they are like $50
Bought one of these and it also worked

RE: Sunblade 150 NVRAM IDPROM Reprogramming Issues

I was hoping that you had found a work-around. It seems that the kernel halts when it tries to load
the driver for the TOD-chip, which would indicate that it is using some of the registers available on
the 59, but not on the 58. AFAIK Solaris is not using this functionality, but I could be wrong. Patching
the driver would be ideal, but probably not worth the effort. I tried starting the kernel i debug-mode,
but it appears to halt before it comes that far.

The problem with the 59's currently on sale is that, AFAIK, they are all refurbished.

RE: Sunblade 150 NVRAM IDPROM Reprogramming Issues

I can add that the 58 apparently works fine on an Ultra 10, presumably all non-Blade sun4u's.

RE: Sunblade 150 NVRAM IDPROM Reprogramming Issues

I am needing to replace the nvram on a sunblade 150. I noticed this thread. Any recommendations on where to get a replacement and do they work as shipped or is reprogramming necessary? If programming is necessary, how is that accomplished?
Thanks to all who respond...

RE: Sunblade 150 NVRAM IDPROM Reprogramming Issues

I can't recommend any of the suppliers as the ones I've got have all been depleted. Some supplierson net are selling them as new, but they have not been manufactured for years AFAIK. I never got a response from these suppliers and ended up buying some from e-bay and attaching a CR-2032 socket and battery externally. As for reprogramming, see e.g. https://github.com/MrSparc/idprom-repair.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close