×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Item Vendor selection failed to show correctly in IMINVLOC_Sql.vendor field

Item Vendor selection failed to show correctly in IMINVLOC_Sql.vendor field

Item Vendor selection failed to show correctly in IMINVLOC_Sql.vendor field

(OP)
thread639-1614078: Item received to wrong Vendor I went through 6 tests to attempt to change the data returned in the "Vendor" field in IMINVLOC . No matter which or how I selected a vendor, it displayed wrong. I added multiple "Item Vendor" setups, and changed the "Primary / Secondary, Approved fields, I also tried the Use /Do not use ...no matter! the system always returned the first item vendor that was setup. I even deleted the original Item Vendor Setup and it still wrongly displayed the original Vendor that was first setup historically. MAC10

RE: Item Vendor selection failed to show correctly in IMINVLOC_Sql.vendor field

Please clarify - the Item Location (IMINVLOC) is not retaining the default vendor when you change it, or when you change the Item Vendor Master (POITMVND)?

Changing the Item Vendor Master will never update the Item Location's default vendor, nor should it. You must go directly to the Item Location record and manually change it there. This field is only used by MRP to create unreleased POs.

If you want the Primary source from the Item Vendor Master to update the primary vendor in the Item Location, you'll have to write some SQL.

Macola Software Veteran and SAP Business One Consultant on Training Wheels

Check out our Macola tools:

www.gainfocus.biz/exceladdin.html

RE: Item Vendor selection failed to show correctly in IMINVLOC_Sql.vendor field

(OP)
" The purpose of the test was to get the IMINVLOC table to show the correct vendor the material was PURCHASED & RECEIVED from. I am proposing that the Iminvloc_sql. Vendor_no field always ignores the actual source of the material and defaults to the first vendor receipt of material ever used, that had an Item-vendor setup. This defaults back to the original vendor regardless who you subsequently bought material from. Even if you delete the original Item-Vendor setup.



In this test the original item-vendor was “BASF” from years ago. In the test, Different vendors were then added using item-vendor setup. A PO was cut and received for each. Then I would go back to the IMINVLOC_sql.vend_no field to see what Vendor showed up? Always the original"BASF" name. None of the first 4 PO’s with mat’l on hand is purchased from BASF.

Actual vendors:

RE: Item Vendor selection failed to show correctly in IMINVLOC_Sql.vendor field

As Don stated - the primary vendor on the location file has nothing to do with the vendor(s) setup in the item/vendor area. If you want the primary vendor to change in the location file your options are to manually change it, or write something in SQL (trigger, scheduled stored procedure) to update it for you.

Peter Shirley
http://www.erpessentials.com

RE: Item Vendor selection failed to show correctly in IMINVLOC_Sql.vendor field

(OP)
Thanks, I'll consider a stored proc. to update the vendor field according to receipt transaction.

RE: Item Vendor selection failed to show correctly in IMINVLOC_Sql.vendor field

Do you own Flexibility aka VBA for Macola? This is another possibility.

Macola Software Veteran and SAP Business One Consultant on Training Wheels

Check out our Macola tools:

www.gainfocus.biz/exceladdin.html

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close