×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

User Speedcall won't program on secondary controller

User Speedcall won't program on secondary controller

User Speedcall won't program on secondary controller

(OP)
Customer has 2 controllers. Both are MXe-III. Both are running 8.0 SP3 PR3
All users are (supposed to be) configured to the primary controller with resiliency to the secondary controller.

Back-Story - you can skip this if you need...

A few weeks ago, the primary controller restarted overnight for a scheduled reboot, but phones didn't switch to the secondary.
Researching this, we discovered that there were errors on the secondary - devices that showed as resilient, but in fact weren't configured to the secondary system.
We removed ALL resiliency and reconfigured it to ALL phones. Finally got a sync to complete successfully.

While redoing the resiliency, somehow all the button assignments for nearly all the phones got deleted. We recovered them by restoring an previous database to another controller, exported the Multiline Set Key assignment form and importing that to the live system.
99% of this worked.


Problem begins here:
We have ONE extension 7892 that is configured as a Generic SIP for a Spectralink Wi-Fi handset. This is configured as a USER Speedcall on a handful of phones. The primary shows fine. Creates an SDS Error to the secondary stating that "The Directory number is of the wrong type."
I've attempted to make this a DSS/BLF and a CDE speedcall, I get the same error.
I've attempted to program it directly to the button on the secondary controller, It propagates to the primary, but gives the same error on the secondary.

I've added 7893 to this same button - worked fine... but obviously this isn't what we need.
To get around this, I've created a system speedcall, 7992 that dials 7892 and configured the user speedcall to the button without issues.


I do have a ticket with Mitel support on this whole mess... but I figured I'd ask here if anyone has had a similar problem.

RE: User Speedcall won't program on secondary controller

Is 7892 a Generic SIP phone in the forms of your secondary controller also?
Sounds to me like your extension is one thing on the primary and a different thing on the seconday which would explain the error.
It's hard to say what to do since I haven't seen all the steps you've done, but I would search the secondary controller all over for 7892 and delete all the possibles instances of that number if possible. If one instance can't be deleted, I would try to delete the whole extension from the primary controller. Once everything is wiped from both controllers, use command DN REF LOOKUP on both to see if the extension is still somewhere. Delete that, use DN REF LOOKUP again. Once it's clean, create extension again and try the User Speedcall. If it's not clean, backup/restore from problematic controller.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close