×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

External calls to voicemail dropping after about 40 seconds while leaving a message with SIP trunks

External calls to voicemail dropping after about 40 seconds while leaving a message with SIP trunks

External calls to voicemail dropping after about 40 seconds while leaving a message with SIP trunks

(OP)
System version: 11.5.1.14900-11

Hi everyone,

We are having trouble with external calls dropping while leaving a message in unity voicemail. We have tested with internal calls and it works correctly or as designed. We are using SIP trunking to a cube and have confirmed these settings are correct in regards to rtcp and timer rtcp. Any suggestions are appreciated. https://www.tek-tips.com/threadminder.cfm?pid=851

Example -----------

router(config)#ip rtcp report interval 12000

router(config)#gateway

router(config-gateway)#timer receive-rtcp 5

This will allow 60 secs before the call will be cutoff. 12000 msec x 5 = 60000 msec / 1000 = 60 sec

router(config)#ip rtcp report interval 60000
router(config)#gateway
router(config-gateway)#timer receive-rtcp 5

This will allow 300 secs or 5 mins before the call will be cutoff. 60000 msec x 5 = 300000 msec / 1000 = 300 sec

RE: External calls to voicemail dropping after about 40 seconds while leaving a message with SIP trunks

(OP)
b1-4431-a#show run
Building configuration...


Current configuration : 7830 bytes
!
! Last configuration change at 12:38:32 PDT Fri May 24 2019 by hardyr
! NVRAM config last updated at 15:57:34 PDT Tue May 28 2019 by hardyr
!
version 15.5
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
no platform punt-keepalive disable-kernel-core
!
hostname b1-4431-a
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!
no aaa new-model
clock timezone PDT -8 0
clock summer-time PDT recurring
clock calendar-valid
!
!
!
ip name-server x.x.x.x x.x.x.x

ip domain name x
!
!
!
!
!
!
!
!
!
!
subscriber templating
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
voice service voip
ip address trusted list
ipv4 10.129.193.10 255.255.255.255
ipv4 10.129.251.101 255.255.255.255
ipv4 10.129.193.11 255.255.255.255
ipv4 10.129.193.12 255.255.255.255
dtmf-interworking rtp-nte
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
supplementary-service media-renegotiate
signaling forward unconditional
fax protocol pass-through g711ulaw
modem passthrough nse codec g711ulaw
h323
emptycapability
sip
rel1xx supported "rel100"
min-se 7200 session-expires 7200
header-passing
registrar server expires max 600 min 60
asserted-id pai
early-offer forced
midcall-signaling passthru
privacy-policy passthru
!
voice class codec 1
codec preference 1 g711ulaw
!
!
!
voice class server-group 1
ipv4 10.129.193.11 preference 1
ipv4 10.129.193.12 preference 2
ipv4 10.129.193.10 preference 3
!
voice class server-group 2
!
!
!
!
voice translation-rule 1
rule 1 /^9\(.*\)/ /+\1/
!
voice translation-rule 2
rule 1 /^9\(.*\)/ /\1/
!
!
voice translation-profile PSTN-OUT
translate called 1
!
voice translation-profile PSTN-OUT-2
translate called 2
!
!
!
!
voice-card 0/4
no watchdog
!
license udi pid xxxxxx
!
spanning-tree extend system-id
!
username xxx privilege 15 secret 5 xxxx
username xxx privilege 15 secret 5 xxxx
username xxx privilege 15 secret 5 xxxxx
!
redundancy
mode none
!
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0/0
description --- 3750 port 43 ---
ip address 10.129.193.2 255.255.255.128
negotiation auto
!
interface GigabitEthernet0/0/1
description --- WindStream ---
ip address 10.129.251.100 255.255.255.254
negotiation auto
!
interface GigabitEthernet0/0/2
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0/0/3
no ip address
shutdown
negotiation auto
!
interface Service-Engine0/4/0
no ip address
shutdown
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
shutdown
negotiation auto
!
interface Vlan1
no ip address
shutdown
!
ip forward-protocol nd
no ip http server
no ip http secure-server
ip rtcp report interval 60000
ip route 0.0.0.0 0.0.0.0 10.129.193.1
ip ssh version 2
!
!
!
!
tftp-server bootflash:running-config
!
control-plane
!
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 2000 voip
description ***Inbound from PSTN - SIP; DNIS/DID***
session protocol sipv2
incoming called-number xxx.......
voice-class codec 1
voice-class sip early-offer forced
voice-class sip bind control source-interface GigabitEthernet0/0/1
voice-class sip bind media source-interface GigabitEthernet0/0/1
dtmf-relay rtp-nte
fax-relay ecm disable
no fax-relay sg3-to-g3
fax rate disable
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 2001 voip
description ***Inbound from PSTN - SIP; DNIS/DID***
session protocol sipv2
incoming called-number xxx.......
voice-class codec 1
voice-class sip early-offer forced
voice-class sip bind control source-interface GigabitEthernet0/0/1
voice-class sip bind media source-interface GigabitEthernet0/0/1
dtmf-relay rtp-nte
fax-relay ecm disable
no fax-relay sg3-to-g3
fax rate disable
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 1000 voip
description ***Inbound from CUCM Servers; PSTN Dialing ***
session protocol sipv2
incoming called-number ^9.T
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/0
voice-class sip bind media source-interface GigabitEthernet0/0/0
dtmf-relay rtp-nte
fax-relay ecm disable
no fax-relay sg3-to-g3
fax rate disable
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 1100 voip
description *Outbound to Sub01,SUB02&PUB;DID/DNIS*
destination-pattern xxx.......
session protocol sipv2
session server-group 1
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/0
voice-class sip bind media source-interface GigabitEthernet0/0/0
dtmf-relay rtp-nte
fax-relay ecm disable
no fax-relay sg3-to-g3
fax rate disable
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 1101 voip
description *Outbound to Sub01,SUB02&PUB;DID/DNIS*
destination-pattern xxx.......
session protocol sipv2
session server-group 1
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/0
voice-class sip bind media source-interface GigabitEthernet0/0/0
dtmf-relay rtp-nte
fax-relay ecm disable
no fax-relay sg3-to-g3
fax rate disable
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 2091 voip
description ***Outbound to PSTN SIP; PSTN Dialing***
translation-profile outgoing PSTN-OUT-2
destination-pattern 9011T
session protocol sipv2
session target ipv4:10.129.251.101
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/1
voice-class sip bind media source-interface GigabitEthernet0/0/1
dtmf-relay rtp-nte
fax-relay ecm disable
no fax-relay sg3-to-g3
fax rate disable
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 2092 voip
description ***Outbound to PSTN SIP; PSTN Dialing***
translation-profile outgoing PSTN-OUT-2
destination-pattern 9911
session protocol sipv2
session target ipv4:10.129.251.101
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/1
voice-class sip bind media source-interface GigabitEthernet0/0/1
dtmf-relay rtp-nte
fax-relay ecm disable
no fax-relay sg3-to-g3
fax rate disable
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 2099 voip
description ***Outbound to PSTN SIP; PSTN Dialing***
translation-profile outgoing PSTN-OUT
destination-pattern 91[2-9].........
session protocol sipv2
session target ipv4:10.129.251.101
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0/1
voice-class sip bind media source-interface GigabitEthernet0/0/1
dtmf-relay rtp-nte
fax-relay ecm disable
no fax-relay sg3-to-g3
fax rate disable
fax protocol pass-through g711ulaw
no vad
!
!
gateway
media-inactivity-criteria all
timer receive-rtcp 5
timer receive-rtp 1200
!
sip-ua
retry invite 2
retry bye 2
retry cancel 2
timers trying 1000
timers expires 60000
timers connect 1000
timers buffer-invite 5000
reason-header override
g729-annexb override
!
!
line con 0
login local
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login local
transport input ssh
!
ntp server x.x.x.x
!
end

b1-4431-a#
b1-4431-a#
b1-4431-a#
b1-4431-a#
b1-4431-a#

RE: External calls to voicemail dropping after about 40 seconds while leaving a message with SIP trunks

Have you done a SIP debug to see what the message is when the call is dropped?

Certifications:
A+
Network+
CCENT
CCNA Voice
CCNP Voice

RE: External calls to voicemail dropping after about 40 seconds while leaving a message with SIP trunks

(OP)
No I have not but I will do that next. I am kind of new to Cisco after 20 years with Avaya.....would this be through the real time monitoring tool?

RE: External calls to voicemail dropping after about 40 seconds while leaving a message with SIP trunks

You could grab the CUCM logs from there yes. Or i would probably start at running debug ccsip messages on the router itself just to see if anything sticks out. If nothing did, then i would grab logs from CUCM and Unity and go from there.

Certifications:
A+
Network+
CCENT
CCNA Voice
CCNP Voice

RE: External calls to voicemail dropping after about 40 seconds while leaving a message with SIP trunks

(OP)
Thank you so much gnrlash4life.

RE: External calls to voicemail dropping after about 40 seconds while leaving a message with SIP trunks

(OP)
I just wanted to update you all, after running a debug it appears the our service provider is dropping the call after 60 seconds. We will now open a ticket with them and I will update this post when we get this resolved.

RE: External calls to voicemail dropping after about 40 seconds while leaving a message with SIP trunks

(OP)
After running the ccsip messages debug and confirming our ip rtcp settings.

router(config)#ip rtcp report interval 60000
router(config)#gateway
router(config-gateway)#timer receive-rtcp 5

I opened a ticket with our SIP vendor uploaded the debug traces to convince the vendor to look at their gateways. They adjusted what I believe are the rtcp settings on their end and now everything is working fine.

Thank you gnrslash4life

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close