×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

CentOS 7 and Putty

CentOS 7 and Putty

CentOS 7 and Putty

(OP)
I have something weird that's recently surfaced. I have some CentOS and RHEL servers that all of a sudden, before login, I'm seeing a weird character at the beginning of each line displayed. It's just in front of the pre-login "issue" stuff and he login prompt. As soon as I log in, everything is cool.

Since it seems to have started with multiple RHEL and CentOS systems at the exact same time, I'm thinking it's more of a Putty issue. I've checked and tried different character sets, and a couple other things found on the Interwebs.

Any ideas or suggestions would be appreciated.

RE: CentOS 7 and Putty

That does sound like a terminal emulation issue. Questions:
Have you tried Putty from different machines? Are the results different?
Have you tried a different emulator other than Putty?
Is the environment variable TERM being set upon logging in? The reason I am asking is that the pre-login stuff uses a default $TERM and you may be setting it in in the login profiles to match the one used in your Putty?
And lastly, the silly obligatory one: did you change or update Putty prior to the troubles? What changed before this started?

RE: CentOS 7 and Putty

(OP)
I discovered the cause of the weird characters being displayed. It's apparently a PuTTY thing. It's displaying that character in front of each line that's coming from PuTTY and not the server I'm trying to reach. I'm doing an SSH connection and PuTTY is prompting me for my username and password, and also displaying a message about the Pre-authentication banner message from the server.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close