×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Release 11.0.4.1 - 400 Bad Request

Release 11.0.4.1 - 400 Bad Request

Release 11.0.4.1 - 400 Bad Request

(OP)
Hello,

I'm currently experiencing an issue with upgrading IP500V2 Control Units to 11.0.4.1, where the HTTP Session terminates with a 400 Bad Request in the process of uploading the Web Management Files.

I have all TFTP and HTTP Settings set to the Manager PC on the same subnet as the IPO, and have tried each option for file upload wihout success. What I am finding is that the files that cause the error are 0KB in size. Here is a trace of the error:

2019-08-12T16:21:19 316252082mS HTTP: 192.168.10.232(63201) ~HTTPEmbeddedFileServerSessionIO
2019-08-12T16:21:19 316252083mS HTTP: Rx Src: 192.168.10.232(63201)-(80)
PUT /memorycard/system/primary/WebMgmtEE/selfadmin_help/Cloud/de/GUID-D34E8070-85A7-4267-8637-7277A9001AE4.map__a_t_t_r_.txta HTTP/1.1
Last-Modified: Wed, 06 Feb 2019 06:33:04 GMT
Content-Type: application/octet-stream
User-Agent: IPOManager/11.0
Host: 192.168.10.230
Content-Length: 0
2019-08-12T16:21:19 316252084mS HTTP: Content type doesn't match the file type: content type=application/octet-stream filename=GUID-D34E8070-85A7-4267-8637-7277A9001AE4.map__a_t_t_r_.txta
2019-08-12T16:21:19 316252084mS HTTP: 192.168.10.232(63201)-(80) HTTPServerSessionIO: stCreationCallback(7)
2019-08-12T16:21:19 316252084mS HTTP: Public IP=192.168.10.232 Private IP=Not set
2019-08-12T16:21:19 316252085mS HTTP: 192.168.10.232(63201)-(80) HTTPSession: SendErrorResponse Code: 400, Entity: Content Length Header is required to be non-zero for PUT
2019-08-12T16:21:19 316252085mS HTTP: 192.168.10.232(63201)-(80) HTTPServerSessionIO: SetState GracefulClose
2019-08-12T16:21:19 316252089mS HTTP: Tx Dest: 192.168.10.232(63201)-(80)
HTTP/1.1 400 Bad Request
Connection: close
Date: Mon, 12 Aug 2019 23:21:18 GMT
Expires: Mon, 12 Aug 2019 23:22:18 GMT
Cache-Control: private,max-age=60
Server: IPOffice/
X-Frame-Options: DENY
X-XSS-Protection: 1; mode=block
X-Content-Type-Options: nosniff
Content-Type: text/plain
Content-Length: 56


I've upgraded SE nodes without issue. Seems like an Avaya bug to me, anybody else run into the same kind of issues?

Thanks in advance for any replies.

RE: Release 11.0.4.1 - 400 Bad Request

I got the same error. The only thing that worked for me was to format and recreate the SD Card.

RE: Release 11.0.4.1 - 400 Bad Request

Please update if you find a solution

RE: Release 11.0.4.1 - 400 Bad Request

(OP)
It looks like I was able to resolve this one:

- I found that there were several files that were 0KB in size giving the syntax error, all in the WebMgmtEE directory of system/primary on the new Manager Installation:
1)Version.json which is located in the WebMgmtEE directory of the Manager installation
2)GUID-D34E8070-85A7-4267-8637-7277A9001AE4.MAP which is a self help file that is located in WebMgmtEE\selfadmin_help\Cloud\(all languages)directory
2)GUID-353430D7-191F-4115-BFB4-C329139187AA.MAP which is another file in the WebMgmtEE\selfadmin_help\Premise\(all languages) directory

I reviewed it with a few engineers and found that these were non essential files. I didn't exactly want to just delete them, so i made new files simply containing the name of the file in text (i.e Version.json was made as a text file stating "Version 11.0.4.1") and saved that as a .json file, then replaced each file in the Manager directory. After that, file management upload worked fine for both systems in the recently upgraded SCN.

Let me know if anybody else finds any alternate solutions.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close