×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

"Missing parameter values" at run time

"Missing parameter values" at run time

"Missing parameter values" at run time

(OP)
I have a report that runs without any issue when preview in CR or Visual Studio. However, when runs with C# code which provides the parameter values, it threw "Missing parameter values" exception at the following line -
report.ExportToStream(CrystalDecisions.Shared.ExportFormatType.PortableDocFormat);
(where report is ReportDocument report)

The error I got is
'repInfo.StreamFile = report.ExportToStream(CrystalDecisions.Shared.ExportFormatType.PortableDocFormat)' threw an exception of type 'CrystalDecisions.CrystalReports.Engine.ParameterFieldCurrentValueException'
Data: {System.Collections.ListDictionaryInternal}
ErrorID: MissingParameterFieldCurrentValue
HResult: -2147215870
HelpLink: null
InnerException: {"Missing parameter values."}
Message: "Missing parameter values."
PromptEngineAvailable: false
Source: "CrystalDecisions.ReportAppServer.DataSetConversion"
StackTrace: " at CrystalDecisions.ReportAppServer.ConvertDotNetToErom.ThrowDotNetException(Exception e)\r\n at CrystalDecisions.ReportSource.EromReportSourceBase.ExportToStream(ExportRequestContext reqContext)\r\n at CrystalDecisions.CrystalReports.Engine.FormatEngine.ExportToStream(ExportRequestContext reqContext)\r\n at CrystalDecisions.CrystalReports.Engine.ReportDocument.ExportToStream(ExportOptions options)\r\n at CrystalDecisions.CrystalReports.Engine.ReportDocument.ExportToStream(ExportFormatType formatType)"
TargetSite: {Boolean ThrowDotNetException(System.Exception)}

I'm pretty sure my code provided the needed values. I really appreciate if anyone can shed some lights on the problem.

Thank you
Chad

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close