×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

VMPro unable to create file in CustomPrompts folder

VMPro unable to create file in CustomPrompts folder

VMPro unable to create file in CustomPrompts folder

(OP)
Hi there.

I have an issue where I am adding a edit play list action in a VMPro flow. When doing this I am trying to create a new wav file in the customprompt folder, but I get the error that the VMPro client does not have permission to access the directory.

I am logging into the client as Administrator.

Any Ideas? I am trying to allow the client to create their own recordings via an IVR.

Thanks in advance

RE: VMPro unable to create file in CustomPrompts folder

Might be a Windows permission problem. For whatever reason VM Pro installs with the folders tied to one user. If you aren't logged in as that user it will do squirly stuff. I go in and change the permissions to 'Everyone' on those folders to unlock them when I do an install.

Dermis and feline can be divorced by manifold methods.*
*(Disclaimer for all advise given)--'Version Dependent'

RE: VMPro unable to create file in CustomPrompts folder

I believe I've seen this error before. If you're pressing the browse button and trying to insert the new name of the wav file into the explorer window of the server then it complains about permissions, but if you just type the name of the wav file into the properties of the edit play list action I think it will allow it.

IPO AIPS/ACSS/APDS Certified - Field Systems Engineer

RE: VMPro unable to create file in CustomPrompts folder

(OP)
So I have been playing a bit.

Yesterday I somehow managed to create a msg1.wav file in the CustomPrompt folder using the edit play list. However when I use file manager via the web interface I do not see this file in that directory. So using WinSCP I copied it of the server to my desktop, and then via file manager tried to upload it again. I received the error that the file was the incorrect format? This file was created by the edit play list action when calling into the system, so I dont understand how it could be the incorrect format?

Anyway, so I converted the file to the correct format and uploaded the file again via file manager. I then played the file via the VMPro Client and the correct message played. I really thought I had won with a work around, UNTIL...... I tried to re-record the message, and the message does not change, and yes I did press 3 to save.

I have logged a ticket with Avaya, keeping fingers crossed

RE: VMPro unable to create file in CustomPrompts folder

If you use the File Manager you can't store files that are recorded through VM Pro in CustomPrompts or the Wavs-root folder.
These will be deleted every time you sync with File Manager.

You need to have the recording stored in a custom folder.

File Manager is one of the most poorly thought Admin tools so far, and sadly it's the only "correct" way to do it, which is why most people just use WinSCP instead.

The most likely reason why you got an error message when you uploaded the file via WinSCP is that it had the wrong owner on the file.
The file nees to be owned by vmpro:vmpro, although it will still play just fine.

"Trying is the first step to failure..." - Homer

RE: VMPro unable to create file in CustomPrompts folder

(OP)
Hi Janni

The file that I was uploading was being uploaded via the file manager, this should inherently carry the correct permissions for the file. I agree if I uploaded via WinSCP, it would have the incorrect permissions and I would have to do a chown on them to make them available.

But the file that I tried to upload definitely gave the "Invalid WAV file format" error, and I find this strange as this was recorded by the VM Pro, not an external application such as Audacity etc.

I agree, File Manager was a great Idea, but not working too well

RE: VMPro unable to create file in CustomPrompts folder

I did have this issue when loading a backup via individual files through WinSCP.

VMPro doesn't use the Administrator user you use to upload the files.

Via WinSCP, chmod 777 on that files/ directories (preferable to use the custom directory ) and all was OK again.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close