×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Help in Windows 10

Help in Windows 10

Help in Windows 10

(OP)
I have finally upgraded my work computer to Windows 10. I just installed VFP 9.0 and it seems to be working okay except for help. The help file location is set to the location of my dv_foxhelp.chm file and it will search for help and show topics, but the Diplay button doesn't display anything. If I run the chm file outside VFP it works correctly. Is there a setting or something I need to change?

RE: Help in Windows 10

How did you go about with the setup?

Did you start setup.exe? You should run what's specified in autorun.inf on the CD. Then all prerequisites are installed.
Then it's also best NOT to install into Progam Files x86 nor Program Files, but first create a new empty folder C:\Users\Public\VFP (or however you'd like Home() to be named) and specify that path in setup.

Then also apply SP2 and finally, there is a better version of dv_foxhelp.chm here:
https://github.com/VFPX/HelpFile

Now, before you reinstall you might try to use that help file installer to fix your problem, but installing into the default location has been problematic with some features like using FFC classes in your projects because VFP actually needs to have write access to HOME(). Since Vista UAC doesn't let that write access fail but write into a VirtualStore profile folder and that causes trouble. Not the kind of trouble of not starting a CHM file, though, but that could be related as missing setup or setup without elevation also could have failed to make some help system registry< entries needed for CHM usage to work.

Since UAC also means no process you start from an account of the administrator group starts elevated, so you also only get redirected write access to Home() when VFP is installed into program files and you run Foxpro on such an account and it's no good idea to always start VFP with "run as administrator" option, that also doesn't retrofit the necessary registry entries for the help system to work.

So to summarize:
Turn UAC on, work on a normal account in Window also while installing
Create a folder aside of Program Files, as suggested C:\Users\Public\VFP
Start what autorun.inf would start, if that mechanism would work, IIRC that should be setup.hta, not setup.exe
Make all installations and when UAC asks you to log in as Administrator do so
When asked for the location enter C:\Users\Public\VFP, notice you can't pick a folder nor create one at this step, therefore you have to prepare that folder before installation and copy&paste that path.

Now VFP will run fine both when you run as Administrator and when not. When you compile projects with OLEPUBLIC classes without "run as Admin" option you will see "Access to registry denied" which is normal and just tells you VFPs compiler couldn't register the EXE or DLL you just have built, that can be done afterwards and will need to be done with a setup for an end product anyway, so it's just a comfort option you don't need to work. It's just a notice on how UAC works in restricting some access and permissions.

If you're worried about leaving the system protection the program files system folder has on any software, notice any setup allows to specify other paths. You can go into file properties and security options of VFP9.exe itself to have that write protection EXEs also have in program files, you could also use _startup and let it run a checksum calculation on vfp9.exe and other EXE and DLL files to check they are untouched.

Bye, Olaf.

Olaf Doschke Software Engineering
https://www.doschke.name

RE: Help in Windows 10

(OP)
Thanks so much! The third installation was the charm. I uninstalled and then reinstalled in a different local folder and it worked fine.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close