×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Not able to upload more than 4 mb file on opentext content server. Please help

Not able to upload more than 4 mb file on opentext content server. Please help

Not able to upload more than 4 mb file on opentext content server. Please help

(OP)
Please look on binding configuration and suggest if anything wrong

<binding name="BasicHttpBinding_ContentService" closeTimeout="00:10:00"
openTimeout="00:10:00" receiveTimeout="00:10:00" sendTimeout="00:20:00"
allowCookies="false" bypassProxyOnLocal="false" maxBufferPoolSize="20000000"
maxReceivedMessageSize="2147483647" useDefaultWebProxy="true" transferMode="Streamed" messageEncoding="Mtom">
<readerQuotas maxDepth="128"
maxStringContentLength="2147483647" maxArrayLength="2147483647"
maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" />
</binding>

Getting below errors:
The remote server returned an unexpected response: (400) Bad Request.

RE: Not able to upload more than 4 mb file on opentext content server. Please help

To upload big files you need to use Content Service if your soap server is IIS or use Big Uploads if in Linux/Unix/TomCat
https://www.tek-tips.com/viewthread.cfm?qid=167582...
that link will tell you a KB link which will tell you how to but a correct Web.Config
DocMan methods are not going to work for huge ones

Well, if I called the wrong number, why did you answer the phone?
James Thurber, New Yorker cartoon caption, June 5, 1937
Certified OT Developer,Livelink ECM Champion 2008,Livelink ECM Champion 2010
http://www.tek-tips.com/faqs.cfm?fid=2884
http://www.linkedin.com/in/appunair
http://www.livelink.in

RE: Not able to upload more than 4 mb file on opentext content server. Please help

(OP)
Thanks for quick response, we don't have knowledge base access could you please suggest binding information.


Regards
Jyotsana

RE: Not able to upload more than 4 mb file on opentext content server. Please help

Are you using Content Service in your code?. You need to try this in a TEST setting. If you change Web. Config or tomcat equivalent and it has bad info it will break.
When you source your service using Visual Studio your app.config will get set by this.I doubt if the server does not support the binding if just changing things
on app.config does anything good.

CODE --> XML

Web.Config from a server I had configured for huge uploads

<?xml version="1.0" encoding="utf-8"?>
<configuration>
	<appSettings>
		<add key="livelink.host" value="localhost" />
		<add key="livelink.port" value="2099" />
		<add key="livelink.encoding" value="UTF8" />
	</appSettings>
	<!-- IIS 6 configuration -->
	<system.web>
		<httpModules>
			<add name="LogModule" type="OpenText.Livelink.Service.Core.LogModule" />
		</httpModules>
                <!-- Appu Nair 2 GB -->
                 <httpRuntime maxRequestLength="2097151" />
               
        <authentication mode="None" />
	</system.web>
	<!-- IIS 7 configuration -->
	<system.webServer>
		<modules>
			<add name="LogModule" type="OpenText.Livelink.Service.Core.LogModule" preCondition="managedHandler" />
		</modules>
		<validation validateIntegratedModeConfiguration="false" />
                   <!-- Appu Nair 2 GB -->
                 <security> 
		 <requestFiltering>             
		 <requestLimits maxAllowedContentLength="2147483648"/>    		 
		 </requestFiltering>      
		 </security>
	</system.webServer>
	<system.diagnostics>
		<trace autoflush="true" indentsize="2">
			<listeners>
				<add name="les.services.log" type="OpenText.Livelink.Service.Core.TraceListener,OpenText.Livelink.Service.Core" initializeData="logs\les.services.log" />
			</listeners>
		</trace>
		<!-- 0=Off, 1=Error, 2=Warning, 3=Info, 4=Verbose -->
		<switches>
			<add name="TraceLevel" value="3" />
		</switches>
	</system.diagnostics>
    <system.serviceModel>
        <behaviors>
            <serviceBehaviors>
                <!-- To enable SSL meta-data retrieval, add httpsGetEnabled="true" and httpsGetUrl="" to the serviceMetadata element -->
                <behavior name="AdminServiceBehavior">
                    <serviceMetadata httpGetEnabled="true" httpGetUrl="" />
                    <serviceDebug includeExceptionDetailInFaults="true" httpHelpPageUrl="" />
                </behavior>
                <behavior name="AuthenticationBehavior">
                    <serviceMetadata httpGetEnabled="true" httpGetUrl="" />
                    <serviceDebug includeExceptionDetailInFaults="true" httpHelpPageUrl="" />
                </behavior>
                <behavior name="CollaborationBehavior">
                    <serviceMetadata httpGetEnabled="true" httpGetUrl="" />
                    <serviceDebug includeExceptionDetailInFaults="true" httpHelpPageUrl="" />
                </behavior>
                <behavior name="ConfigServiceBehavior">
                    <serviceMetadata httpGetEnabled="true" httpGetUrl="" />
                    <serviceDebug includeExceptionDetailInFaults="true" httpHelpPageUrl="" />
                </behavior>
                <behavior name="ContentServiceBehavior">
                    <serviceMetadata httpGetEnabled="true" httpGetUrl="" />
                    <serviceDebug includeExceptionDetailInFaults="true" httpHelpPageUrl="" />
                </behavior>
                <behavior name="DocumentManagementBehavior">
                    <serviceMetadata httpGetEnabled="true" httpGetUrl="" />
                    <serviceDebug includeExceptionDetailInFaults="true" httpHelpPageUrl="" />
                </behavior>
                <behavior name="IndexServiceBehavior">
                    <serviceMetadata httpGetEnabled="true" httpGetUrl="" />
                    <serviceDebug includeExceptionDetailInFaults="true" httpHelpPageUrl="" />
                </behavior>
                <behavior name="MemberServiceBehavior">
                    <serviceMetadata httpGetEnabled="true" httpGetUrl="" />
                    <serviceDebug includeExceptionDetailInFaults="true" httpHelpPageUrl="" />
                </behavior>
                <behavior name="SearchServiceBehavior">
                    <serviceMetadata httpGetEnabled="true" httpGetUrl="" />
                    <serviceDebug includeExceptionDetailInFaults="true" httpHelpPageUrl="" />
                </behavior>
                <behavior name="WorkflowServiceBehavior">
                    <serviceMetadata httpGetEnabled="true" httpGetUrl="" />
                    <serviceDebug includeExceptionDetailInFaults="true" httpHelpPageUrl="" />
                </behavior>
                <behavior name="XmlServiceBehavior">
                    <serviceMetadata httpGetEnabled="true" httpGetUrl="" />
                    <serviceDebug includeExceptionDetailInFaults="true" httpHelpPageUrl="" />
                </behavior>
            </serviceBehaviors>
        </behaviors>
        <bindings>
            <basicHttpBinding>
                <binding name="AdminServiceBinding" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="None">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="AdminServiceBinding_SSL" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="Transport">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="AuthenticationBinding" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="None">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="AuthenticationBinding_SSL" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="Transport">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="CollaborationBinding" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="None">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="CollaborationBinding_SSL" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="Transport">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="ConfigServiceBinding" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="None">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="ConfigServiceBinding_SSL" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="Transport">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                    <!-- Appu Nair 2 GB -->
                <binding name="ContentServiceBinding" maxReceivedMessageSize="2147483648" messageEncoding="Mtom" transferMode="Streamed" closeTimeout="00:01:00"
                    openTimeout="00:01:00" receiveTimeout="00:10:00" sendTimeout="00:01:00">
                	<security mode="None">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="ContentServiceBinding_SSL" maxReceivedMessageSize="2147483647" messageEncoding="Mtom" transferMode="Streamed">
                	<security mode="Transport">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
				
				    <!-- Appu Nair 2 GB -->
                <binding name="DocumentManagementBinding" maxReceivedMessageSize="2147483648" messageEncoding="Text" transferMode="Buffered" closeTimeout="00:01:00"
                    openTimeout="00:01:00" receiveTimeout="00:10:00" sendTimeout="00:01:00" >
                	<security mode="None">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="DocumentManagementBinding_SSL" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="Transport">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="IndexServiceBinding" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="None">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="IndexServiceBinding_SSL" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="Transport">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="MemberServiceBinding" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="None">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="MemberServiceBinding_SSL" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="Transport">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="SearchServiceBinding" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="None">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="SearchServiceBinding_SSL" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="Transport">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="WorkflowServiceBinding" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="None">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="WorkflowServiceBinding_SSL" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="Transport">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="XmlServiceBinding" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="None">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
                <binding name="XmlServiceBinding_SSL" maxReceivedMessageSize="1024000" messageEncoding="Text" transferMode="Buffered">
                	<security mode="Transport">
                		<transport clientCredentialType="None" />
                	</security>
                </binding>
            </basicHttpBinding>
        </bindings>
        <services>
            <!-- IIS virtual directory must be configured for SSL before enabling the SSL endpoints -->
            <service behaviorConfiguration="AdminServiceBehavior" name="OpenText.Livelink.Service.Core.AdminService_WCF">
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="AdminServiceBinding" bindingNamespace="urn:Core.service.livelink.opentext.com" contract="OpenText.Livelink.Service.Core.IAdminService_WCF" />
                <!-- SSL disabled
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="AdminServiceBinding_SSL"
                    bindingNamespace="urn:Core.service.livelink.opentext.com"
                    contract="OpenText.Livelink.Service.Core.IAdminService_WCF" />
                -->
            </service>
            <service behaviorConfiguration="AuthenticationBehavior" name="OpenText.Livelink.Service.Core.Authentication_WCF">
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="AuthenticationBinding" bindingNamespace="urn:Core.service.livelink.opentext.com" contract="OpenText.Livelink.Service.Core.IAuthentication_WCF" />
                <!-- SSL disabled
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="AuthenticationBinding_SSL"
                    bindingNamespace="urn:Core.service.livelink.opentext.com"
                    contract="OpenText.Livelink.Service.Core.IAuthentication_WCF" />
                -->
            </service>
            <service behaviorConfiguration="CollaborationBehavior" name="OpenText.Livelink.Service.Collaboration.Collaboration_WCF">
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="CollaborationBinding" bindingNamespace="urn:Collaboration.service.livelink.opentext.com" contract="OpenText.Livelink.Service.Collaboration.ICollaboration_WCF" />
                <!-- SSL disabled
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="CollaborationBinding_SSL"
                    bindingNamespace="urn:Collaboration.service.livelink.opentext.com"
                    contract="OpenText.Livelink.Service.Collaboration.ICollaboration_WCF" />
                -->
            </service>
            <service behaviorConfiguration="ConfigServiceBehavior" name="OpenText.Livelink.Service.LesConfig.ConfigService_WCF">
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="ConfigServiceBinding" bindingNamespace="urn:LesConfig.service.livelink.opentext.com" contract="OpenText.Livelink.Service.LesConfig.IConfigService_WCF" />
                <!-- SSL disabled
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="ConfigServiceBinding_SSL"
                    bindingNamespace="urn:LesConfig.service.livelink.opentext.com"
                    contract="OpenText.Livelink.Service.LesConfig.IConfigService_WCF" />
                -->
            </service>
            <service behaviorConfiguration="ContentServiceBehavior" name="OpenText.Livelink.Service.Core.ContentService_WCF">
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="ContentServiceBinding" bindingNamespace="urn:Core.service.livelink.opentext.com" contract="OpenText.Livelink.Service.Core.IContentService_WCF" />
                <!-- SSL disabled
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="ContentServiceBinding_SSL"
                    bindingNamespace="urn:Core.service.livelink.opentext.com"
                    contract="OpenText.Livelink.Service.Core.IContentService_WCF" />
                -->
            </service>
            <service behaviorConfiguration="DocumentManagementBehavior" name="OpenText.Livelink.Service.DocMan.DocumentManagement_WCF">
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="DocumentManagementBinding" bindingNamespace="urn:DocMan.service.livelink.opentext.com" contract="OpenText.Livelink.Service.DocMan.IDocumentManagement_WCF" />
                <!-- SSL disabled
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="DocumentManagementBinding_SSL"
                    bindingNamespace="urn:DocMan.service.livelink.opentext.com"
                    contract="OpenText.Livelink.Service.DocMan.IDocumentManagement_WCF" />
                -->
            </service>
            <service behaviorConfiguration="IndexServiceBehavior" name="OpenText.Livelink.Service.SearchServices.IndexService_WCF">
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="IndexServiceBinding" bindingNamespace="urn:SearchServices.service.livelink.opentext.com" contract="OpenText.Livelink.Service.SearchServices.IIndexService_WCF" />
                <!-- SSL disabled
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="IndexServiceBinding_SSL"
                    bindingNamespace="urn:SearchServices.service.livelink.opentext.com"
                    contract="OpenText.Livelink.Service.SearchServices.IIndexService_WCF" />
                -->
            </service>
            <service behaviorConfiguration="MemberServiceBehavior" name="OpenText.Livelink.Service.MemberService.MemberService_WCF">
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="MemberServiceBinding" bindingNamespace="urn:MemberService.service.livelink.opentext.com" contract="OpenText.Livelink.Service.MemberService.IMemberService_WCF" />
                <!-- SSL disabled
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="MemberServiceBinding_SSL"
                    bindingNamespace="urn:MemberService.service.livelink.opentext.com"
                    contract="OpenText.Livelink.Service.MemberService.IMemberService_WCF" />
                -->
            </service>
            <service behaviorConfiguration="SearchServiceBehavior" name="OpenText.Livelink.Service.SearchServices.SearchService_WCF">
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="SearchServiceBinding" bindingNamespace="urn:SearchServices.service.livelink.opentext.com" contract="OpenText.Livelink.Service.SearchServices.ISearchService_WCF" />
                <!-- SSL disabled
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="SearchServiceBinding_SSL"
                    bindingNamespace="urn:SearchServices.service.livelink.opentext.com"
                    contract="OpenText.Livelink.Service.SearchServices.ISearchService_WCF" />
                -->
            </service>
            <service behaviorConfiguration="WorkflowServiceBehavior" name="OpenText.Livelink.Service.WorkflowService.WorkflowService_WCF">
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="WorkflowServiceBinding" bindingNamespace="urn:WorkflowService.service.livelink.opentext.com" contract="OpenText.Livelink.Service.WorkflowService.IWorkflowService_WCF" />
                <!-- SSL disabled
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="WorkflowServiceBinding_SSL"
                    bindingNamespace="urn:WorkflowService.service.livelink.opentext.com"
                    contract="OpenText.Livelink.Service.WorkflowService.IWorkflowService_WCF" />
                -->
            </service>
            <service behaviorConfiguration="XmlServiceBehavior" name="OpenText.Livelink.Service.Core.XmlService_WCF">
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="XmlServiceBinding" bindingNamespace="urn:Core.service.livelink.opentext.com" contract="OpenText.Livelink.Service.Core.IXmlService_WCF" />
                <!-- SSL disabled
                <endpoint address="" binding="basicHttpBinding" bindingConfiguration="XmlServiceBinding_SSL"
                    bindingNamespace="urn:Core.service.livelink.opentext.com"
                    contract="OpenText.Livelink.Service.Core.IXmlService_WCF" />
                -->
            </service>
        </services>
       
    <!-- Appu Nair If you want your webservice proxies to not show its hostname or localhost -->
	<serviceHostingEnvironment> 
        	<baseAddressPrefixFilters> 
           		<add prefix="http://livelinkws-t.livelink.net/"/> 
        	</baseAddressPrefixFilters> 
    	</serviceHostingEnvironment>
    </system.serviceModel>
</configuration> 

Well, if I called the wrong number, why did you answer the phone?
James Thurber, New Yorker cartoon caption, June 5, 1937
Certified OT Developer,Livelink ECM Champion 2008,Livelink ECM Champion 2010
http://www.tek-tips.com/faqs.cfm?fid=2884
http://www.linkedin.com/in/appunair
http://www.livelink.in

RE: Not able to upload more than 4 mb file on opentext content server. Please help

(OP)
Thanks you so much :)

Its working fine.

Could you please help me to store token value in session.

Shall I store value in Session. We are using opentext content server WCF service?

RE: Not able to upload more than 4 mb file on opentext content server. Please help

I do not understand what you mean. When you issue a web services call there's a token whether its OTDS or Livelink the Token will work so long as the Livelink server can decrypt it and has not run past its time. Tokens are like cookies so if you have a cluster of servers A,B,C and D if A gave you the cookie, you cannot use it on B and so on. You can but that's making your system very less secure. Typically all you have to do is basically check if your token will reach the expiration and get a new token. If you have a program that works and sometimes get "invalid username or password specified" that just means the soap server switched you to somewhere else. You just have to be talking to the same Livelink server or get an auth from OTDS every time. Explain your real problem in a way the forum members understand and someone will help you.

Well, if I called the wrong number, why did you answer the phone?
James Thurber, New Yorker cartoon caption, June 5, 1937
Certified OT Developer,Livelink ECM Champion 2008,Livelink ECM Champion 2010
http://www.tek-tips.com/faqs.cfm?fid=2884
http://www.linkedin.com/in/appunair
http://www.livelink.in

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close