×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Equinox Mobile - status users not working

Equinox Mobile - status users not working

Equinox Mobile - status users not working

(OP)

Hi,

We have installed Equinox mobile client and on the LAN site all is working fine. (Registration/RTP/user status out of the IPO) We are not working

connecting from the WAN the registration and the RTP streaming is working but I have no user status out of the IPO.

Port 5061 and RTP 53000-54000 in the firewall is referring to the IPO.

As the config file 46xxsettings is only allowed to retrieve from the LAN port 443 is NOT set on the firewall
Ports 443 is only for Secure client configuration / Web Socket. This is not necessary to access via WAN. (as I understand)

What are we missing to get the status of the users out of the IP Office?

Thanks

RE: Equinox Mobile - status users not working

You do need to allow the 46xxsettings file to be seen from external. How else is the client to know of the public FQDN, certificate etc...


RE: Equinox Mobile - status users not working

(OP)
Hi telecomtekperson.

As I understand you well the client needs to have always connection to the 46xxsettings file. (port 443)

It is not enough to configure the app via wifi once (there is access to the 46xx file ) to have all parameters?
I thought, once configured the app had the necessary info FQDN, certificate, ....



RE: Equinox Mobile - status users not working

443 is also used for presence and directory (new MT-CTI functionality)

RE: Equinox Mobile - status users not working

@pkdev
Hi

What do you know about the MT CTI?

I have an android phone that cannot get presence or directory
It seems all devices when they connect execute :-

GET /tpkt/mtcti HTTP/1.1

I have a iPhone working OK, it executes the above, gets a 401 Unauthorised , changes to websocket with a key etc. and all seems OK

When my 'droid executes the above I get a 404 not found.

I could post the whole output from Monitor but it's quite a lot

Any pointers appreciated!

Cheers

RE: Equinox Mobile - status users not working

The phone says it';s not connected to the phone service but will still make and recieve calls :)

RE: Equinox Mobile - status users not working

This is a common issue, I see all the time.

The issue is a combination of having the proper ports forwarded and making sure you have the cert configured correctly.

I struggled with the cert issue for a long time, and I was never able to get it to work by following the deployment guide, but I was Abel to get it to work though a non standard method.

If your ports are all forwarded correctly, but you still get the red triangle saying the phone is partially connected, then you have a cert issue.

You must have a valid domain name for the IP Office for this work at all.

First go to the security section of IP Office and generate a new cert. pay particular attention here. DNS:LAN1, DNS:LAN2, DNS:PUBLICIP, URI:SIP:FQND, URI:SIP:LAN1, URI:SIP:LAN2, URI:SIP:PUBLICIP

Generate it.
Export it..
Install on all devices.

This still was not enough for me, and this next part is where I went crazy.
Just go the IP Office Webinterface using FireFox.
https://youripoffice.com:7070
When the screen comes up asking you to add an exception, don't do it just yet. Choose to view the cert.
From within there you will have the option to export the cert.
Create folder on the Desktop and export the cert.
I took the nuclear approach and exported every version of the cert that I had options for.. PEM, PEM with Chain, PKCS.etc..etc.. Then installed all of them. ( two of them failed because of wrong format ) Does not matter.

Install that on all your devices, and make sure to trust them.
Finally, Equinox start up with no red triangle, and showing presence and System directory.

So essentially, even though you do need to go through the process of creating the cert in IP Office, the one downloaded directly from the IP Office does not work on its own.. I don't know why.
You need to grab the cert from the browser. Install that one... don't just add an exception. Make sure you export it using the browser so you have it handy to send to your iPhone/Android devices as well.

For iPhone, don't forget to trust the cert after installing the profile.
Settings->General->About->CertificateTrustSettings

Hope this helps.

RE: Equinox Mobile - status users not working

Hi, thanks for your reply!

I guess there must be several different ways of doing this.
I too struggled to get the certs right and in some cases mobile devices not being happy or being funny about installing certs.
We now, for the time being as a policy decision, only use 3rd party certs from a trusted CA to avoid having to install them.

I had a total nightmare with this one.

What I wasn't told was that one of the changes I made during the day must have fixed the issue.

Client reports, next day, that Equinox said a config update was available, he installed it, and when he got home it worked. That was iPhone.
Thinking then it was an Android issue I continued to investigate only to find out later in the day that another Android device was working no problem.

So it seems the only problem is my 'droid!! Mine connects to our in-house kit fine, On the WiFi, out and about on 4G etc. but will not connect to this new install at all.
I can make and receive a call, even though it says it's not connected to the telephony service. No presence, no contacts but no red triangle either.

I even uninstalled, cleared the phone cache etc.

So, I have no idea what's wrong with it!

RE: Equinox Mobile - status users not working

I had a problem with a single phone once on the ROGERS LTE network.
Something about the way they were doing IPV6.

I believe ROGERS has fixed the problem, but other carriers might be doing the same thing.

For me, I fixed it on my iPhone by using the iPhone profile tool called Apple Configurator and I removed the IPV6 option forcing IPv4.

If you have a phone that works on your Wifi, Work Wifi, but not over your carrier network, I would investigate the IPV6 issue.


Travis

RE: Equinox Mobile - status users not working

Hi

I will check out the IPv6.

My phone is on O2 in the UK but usually works fine with our in house kit even on 4g, but not on the Customer's kit on either WiFi or 4G

I will need to wait for the customer to get back from leave to deploy all 28 Equinox clients, it will be interesting to see what happens!

RE: Equinox Mobile - status users not working

Avaya does support IPV6. The issue is the way some carriers chose to implement it.
Carriers that chose to deploy true IPV6 had no problems with Avaya Equinox.
Carriers that attempted to deploy IPV6 in IPV4 compatibility mode are the ones that messed with Avaya Equinox and some other SIP clients as well.

Travis

RE: Equinox Mobile - status users not working

You don't configure IPV6 in IPO.
IPV6 is supported on Avaya Equinox, and Avaya SBCE 7.1

Although, I wonder what would happen if I enabled IPV6 on IPO Server Edition? I mean it's just linux, and they do give you root access to it..

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close