×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

BCM450 no voice issue

BCM450 no voice issue

BCM450 no voice issue

(OP)
Hi All,
We have BCM450 R6 with SIP trunks thru Comwave.
We have two DID: one is original CLID from Comwave and the second our ported DID to Comwave.
When an incoming call comes thru CLID - all is fine, we get the voice.
If the call comes to ported DID - no sound.
Here is a response from Comwave support:
-----------------------------------------------
The issue is that for the two additional numbers when you respond to our INVITE a private IP is inserted in the contact header while with the trunk pilot a public IP is inserted in the contact header which is what is should be for the rest of the numbers.
Please check the URI settings for the other DIDs and see if you can get a public IP in the Contact header instead of a private one.
Whenever a private IP is inserted in your Contact header we respond to that IP which is non routable so it goes nowhere.

Ultimately the issue is still you sending a private IP in Contact header. This is not occurring with the Pilot number. You do send the public IP in Contact header correctly for that one.
------------------------------------------------
How can I set up external IP in contact header?
Please see the attached bad traffic captures.
Thank you.
Maxim.

RE: BCM450 no voice issue

Do you register each did as own accounts? if so did you match the same credentials?

Did you match the Target Lines with each other?

________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: BCM450 no voice issue

(OP)
Hi Curlycord,
Thank you for your response.
Do Have I to create a registration account for each DID?

Best Regards,
Maxim

RE: BCM450 no voice issue

Thanks for your web inquiry...I am off work with right hand injury at the moment.

I am not sure and why I asked , maybe "child accounts" are involved or you just need to make sure the OLI under sets as the number.
You carrier Comwav should absolutely be able to answer that question if separate users name and passwords for each DID but there are others here who have experiences with multiple SIP DID's or fluent with the SIP errors so hang tight.






________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: BCM450 no voice issue

I have two different incoming SIP trunks from Flowroute on my BCM50. Only one registered account is required. Once registered I just had to setup the target lines, received digits, dest code, route, and OLI. I do have another SIP trunk from a different provider so I had to setup a separate registration for it. One of my numbers is ported from Magic Jack and both work well.



Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952

RE: BCM450 no voice issue

(OP)
Hi curlycord,
I hope all is good with you.
The second DID is ported from BELL.
I use one account, all incoming calls to the second DID come thru this trunk
Looks like I missed something in the setting of SIPdomain: remote/local and "ITSP association method".
When I'm playing with this setting - im getting or dropping calls after 30 seconds or no sound....
Hope you feel better soon!

Best Regards,
Maxim

RE: BCM450 no voice issue

Ported in our world would means in this case either Bell handed the number over to Comwave or Bell converted a POT's line to SIP.

Bell handed the number over to Comwave- This means Comwav is supplying all your SIP trunks and Bell is out of the picture now and no longer will send you a bill.
or
Bell converted a POT's line to SIP - This means Bell is supplying the SIP line therefore a different User Name and Password would be required.

In your case it appears you just have Comwav SIP trunks correct

CLID = Caller ID
Calls comes in on a SIP (or VoIP) Trunk

You have a SIP trunk with 2 DID's, it's the same account...all you need to program are Target Lines but that is for Inbound to point to a set/s AA or other.

SIP Trunking:

ISTP - under Accounts/Advanced
I have mine at "To header local domain match"

SIP Domain - I have the IP of the carrier in both remote and local.... the same address/domain you use in the User Account settings.

Global settings - I have local domain as blank

IP Subsystem
Address Discovery is not checked
IP address it the ISP's provided address

DNS
localdomain
8.8.8.8
4.4.4.4


Very odd, you have one account with two DID's
The only difference would be programming Target Lines to point them.

Do you have same issues calling out at anytime?

Did you touch any programming under the PRIVATE tab?


I am just throwing stuff out there.







________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: BCM450 no voice issue

Yes your right, typo.

________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: BCM450 no voice issue

(OP)
Hello Curlycord,
I hope all is well with you.
I have played with the setting and got better results.
Now 95% incoming calls come with voice, but some calls have no voice issue.
Outgoing calls are good.
The incoming calls with no voice have headers with internal IP.
As well if a forward incoming call to outside to some number - the same problem, no voice.
I didn't touch the private tab.
What needs to set up there?
Sorry that I'm bussing you, but I need urgent your help.
Could you provide your service, please?
Please response me by email.

Best Regards,
Maxim

Best Regards,
Maxim

RE: BCM450 no voice issue

makskr I am not back to work yet.

You have a much better chance answering any questions here on this forum on this topic since there are many pro's here.

I agree you need to use Public settings and that's why I asked if you did because I had suspected you did which I now see you did not.

4 questions you need to answer:

-Did you match the Target Lines with each other?
-Did you verify that that it is Comwave billing both numbers and Bell is removed from the picture?

"As well if a forward incoming call to outside to some number - the same problem, no voice"
-What method are you using to forward calls?

-Did you program SIP settings from scratch or use a local vendor?

Did you read this FAQ: https://www.tek-tips.com/faqs.cfm?fid=7741
Maybe something there your missing.

Try this:
-Highlight only IP Trunks in Element Manager
-Up top go to Session/SaveRecord/SaveSelectedData
-Open file with Excel and see if it populated the settings under "Public"
-Post it here if it worked - you can edit/change it first for privacy reasons such as user name, passwords or phone numbers etc

Mine does not work on my BCM50, yields corrupted message: The file format and extension of "SIP Trunks.xml" don't match




________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: BCM450 no voice issue

(OP)
Thank you Firebird

Best Regards,
Maxim

RE: BCM450 no voice issue

(OP)
Hi Curlycord

-Did you match the Target Lines with each other?
What do you mean? I set up Pub.Received DID on one target line, that is all

-Did you verify that it is Comwave billing both numbers and Bell is removed from the picture?
Yes

"As well if a forward incoming call to outside to some number - the same problem, no voice"
-What method are you using to forward calls?
In "Active Sets" I setup number in "Fwd No Answer" and checkmark "Allow redirect" in capabilities on this extension.

-Did you program SIP settings from scratch or use a local vendor?
I created account "No template" only

Did you read this FAQ: https://www.tek-tips.com/faqs.cfm?fid=7741
Yes, many times :), line per line

Mine does not work on my BCM50, yields corrupted message: The file format and extension of "SIP Trunks.xml" don't match
Doesn't work, same error when I open the xls file and doesn't show all the information.
Maybe I have to try to "reset to default"? How properly to do it?
As well, how can I download all last pathes for the BCM450 R6?

Best Regards,
Maxim

RE: BCM450 no voice issue

The last released set of patches for the BCM 450 at V6.0 were..

BCM450 R6
==================================

PATCH ID: BCM450.R600.SU.System-022.201412-1 Category: GEN (Reboots System and apply first!)
PATCH ID: BCM450.R600.SU.Desktop-005.201406-1 Category: GEN
PATCH ID: BCM450.R600.UTPS-138-1 Category: GEN
PATCH ID: BCM450R6_FactoryImageUpgrade-1.02-0 Category: GEN

Check that you have the latest ones installed. If your system came from the factory with release 6.0 installed, then you don't require the Factory Image patch.

Try this link of BCM450_R6_0_Patches@somertel.ddns.net" target="_blank">ftp://BCM450_R6_0_Patches:BCM450_R6_0_Patches@some...

Just download the ones that are listed above and install them in the order shown with the system one first.

Firebird Scrambler

Nortel & Avaya Meridian 1 / Succession & BCM / Norstar Programmer

Website = http://somertel.myfreesites.net
linkedin

RE: BCM450 no voice issue

-Did you match the Target Lines with each other?
What do you mean? I set up Pub.Received DID on one target line, that is all

Well normally you setup a Target for each DID, in your case you have two DID's.

Here is the link fixed: BCM450 R6 Patches

You can go to the Administration/SoftwareMaanagement/SoftwareUpdateHistory
Drag the "name" column to show the whole name of the patches, take a screen shot and post it.

You may want to also screen shot everything you have done too in case we see something missed, again blur or edit as needed.

Is it all forwarded calls no audio or just some calls?

Are you in the GTA?

________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: BCM450 no voice issue

(OP)
Hi Curlycord,
Thank you so much for the updates!
One issue has been resolved after the updates.
Now we have a voice on 99% incoming calls, but we receive some calls without the voice, maybe it is not our side problem.
But for forwarded calls, we still have no voice.
Kindly find the attached screenshot with software update history.
Im in North York.

Best Regards,
Maxim

RE: BCM450 no voice issue

(OP)
HI Curlycord,
Also, could you help me please retrieve the keycodes from Avaya support website?
We bought the phone system together with office :) and Im trying to set up the system
But looks like the previous owner reset the system to default settings and as well all the keycodes disappeared.
Now looks like now we have basic licences.
Please look the attached screenshot with system id and keycodes that we have now.
Thank you!

Best Regards,
Maxim

RE: BCM450 no voice issue

Tel Resources - IP Terminal Global Settings
-G.729 - Mine is at 20, yours at 30

IP Trunks - Public - Accounts - Advanced
I have checked:
Enable Media Relay
Support 100rel
Allow Refer
Support Replaces

ITSP association method:
I have To Header local domain match
You have To Called number Contact Match

IP Trunks - Public - Accounts - Users Accounts
From my posts above:
"Do you register each did as own accounts?"
"I am not sure and why I asked , maybe "child accounts" are involved"
Seems you have a child account after all.....for your second DID will assume.
I am not saying this is wrong but as others have mentioned in this Thread (and others) all you may need to do is program a second Target Line with the received digits being the second DID.
You can test by Modifying the child account and uncheck Registration then setup the 2nd Target Line
As for Message Handling in the Account I have only PAI CLID Override entered.

IP Trunks - Media Parameters
You have selected: G.11 -uLaw
I have all 3 selected

I have Enable Voice Activity Detection checked where you do not.
I cannot recall what his fixed but possibly no audio when using MeetMe which is a form of conferencing

Lines - Target Lines
In Pub Received you have a 1 in front of your phone number, not an issue but not needed. - You also have Public Received number Length at 11 in Dialing Plan, were you told to make it 11?
Seems you have setup 3 DIDs but you said you had 2 in first post.

IP Trunks - Private - URI Map
You asked in the image "what needs programming?", my answer would be nothing as you do not need to setup "Private"

I have only mentioned differences and they are not necessarily fixes, each setup of a carrier can be different and being that BCM is outdated the carriers do not have the setup guides.

There are some SIP guys on Tek-Tips whom have yet to chime in in might say the Network could be the issue as well.
It took me 6 weeks to get mine right on the BCM and 2 minutes on the Android App.

Your patches look almost up to snuff.

I will send you an email on Keycode issue soon as I can.


________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: BCM450 no voice issue

(OP)
Hi
If I turn on Support 100rel - a calls drop after 30sec
If I change the ITSP association method: - the same, incoming calls drop
Comwave told me that I have to use Received number Length at 11.
Comwave required the registration.
Probably the 3rd DID is for fax line and we don't use it.
I already tested many configurations based on Avaya' SIP configuration documents and all the time I get or no voice issue or dropping calls.
I have tried to negotiate with Comwave and they all the time told me that all the problem on my side, so Im lost...
Thank you.

Best Regards,
Maxim

RE: BCM450 no voice issue

This issue was resolved.

Will update the FAQ's SIP settings page to include Comwave settings that work soon as possible.


________________________________________


=----(((((((((()----=
www.curlycord.com
Toronto, Canada

Add me to LinkedIN

RE: BCM450 no voice issue

(OP)
Hi Curlcord
Thank you so much for your professional level job which was done!

Best Regards,
Maxim

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close