Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here





I've been fighting with a SIP trunk setup with a regular BCM50 and although I've got it up and working, it presents calls from the SIP provider that seem to ring in "la la land" and don't show up on the phones, hence missed calls. I'm going to go back and put some port forwarding rules in place to see if that eliminates the missed calls problems. In the meantime, I thought I'd do testing here with a BCM50E which I also have to install somewhere with some SIP trunks again. It seems I've gone from slightly working to not being able to register here on the BCM50E which I really can't see what's changed. I used to be able to make outgoing calls but not receive any calls or even have an indication of calls on the BCM Monitor. I just did a cold restart, reinstall on the voicemail and reset the router in the BCM to no change on me trying to get it registered. Is there some kind of different process on this BCM or are you to use the router port rather than the usual ports used on the regular BCMs?


I got the registration re-established and can make outgoing calls, but incoming calls result in a busy signal. They don't show up on the BCM Monitor, but they do show on the SIP carrier CDR. The carrier claims in the invite he sees "trying" and "unauthorized" for the incoming call records. I've gone over the settings and redone the accounts a few times. I reset the router again and wondered if the settings in the router have any bearing on the SIP trunks or if I have to have my LAN connection plugged somewhere else on the router rather than the usual port 1 beside the OAM port? A target line has been established on a working set but fails to receive incoming calls? Stumped here for now??


Hello Curlycord!

I've tried your settings and I have a similar installation elsewhere currently on a regular BCM50 which is working for both incoming and outgoing, but I'm missing some of the incoming calls in that they don't get into the system. I've experimented today (and yesterday for a good part of the day) trying to get the other BCM50E that I have here to work, but it only seems to work on outgoing and won't receive any incoming calls. I just a fast busy when trying to call it and it doesn't even show an attempt on BCM Monitor. This is on MS's service, since you asked. I did look back on other previous call records and did find out that they too had missed calls (at least on Bell service). I've reset the BCM50E voicemail, router, platform and still to no avail.


If it's just no inbound then sounds like an issue with the Target Line.
Fast Busy means no place for the call to go because the the phone system has not yet programmed an allowance for it.

You may also need to program the OLI with the phone number and or some settings on the account..."modify" the credentials (little popup window)

Who is MS?
Shortform for what?

Toronto, Canada

Add me to LinkedIN


Target line is in place and programmed. Right now I'm just putting up a 450 with the exact same programming that is in place in both the regular BCM50 onsite, the BCM450 which is also onsite replacing the 50 when these problems became evident, and the BCM50E which I can't get to receive any phone calls. The 450 is up and working perfectly with the same programming as all the other switches, yet they continue to have their issues. i.e. missing incoming calls and not being able to receive any incoming calls here where I just put up the 450. I'm going to place a bunch of incoming calls to it now to see if it gets all of them or misses some. It's voip.ms


In your SIP account settings on the advanced tab try enabling NAT pinhole maintenance. My incoming SIP calls would failover to my cell phone quite often until I did this on my own system. I chose the OPTIONS query with an interval of 30 seconds. Let us know if that makes any difference.

Brian Cox
Georgia Telephone


I don't get it. I'm fighting with this now for about a week and I've put different systems in place and in testing here, I have a 450 that works perfect/mint every call, but the BCM50E will not accept an incoming call. Programming for all systems is the same and parameters are in place for target line and appearance on set, which rings no problem on the 450, but not on the 50E??

Thanks curlycord!

And thanks exsmogger, for the setting suggestion. I'm waiting to test that if needed as, 2 things, one-it works here no problem and two-it seems to have diminished a bit from missing incoming calls on site so I'm wondering if the carrier is doing something (although they haven't said they did) or something else. I did check with Cisco yesterday and they said the the model of router that's currently in place has SIP ALG enabled and there's no way to disable it? So, I was contemplating going out and buying a different model like a RV340 as suggested by them. I'm holding off for now as the last occurrence of failed incoming was at 9:42 this morning?


Strangely enough, it's R6 and I can place phone calls no problem, but no incoming in spite of trying different target lines & numbers and with the exact same programming, if the 50E is taken offline and the 450 put in place, it works perfect! It just seems to be something really stupid in the BCM50E. I've had no problems with the regular 50's. I just didn't know if there's something stupid in the router section of the 50E that would have some kind of influence or if they really are just two separate items in the same box?


After much pain and anguish, I think I may have got my SIP trunks working cleanly. In the process, I replaced the BCM50 with BCM450, I put the Bell modem in bridge mode, I put in a Cisco RV110, then I put in a Cisco RV340 and still no resolution. Still missing incoming calls. Had Cisco tech support go through the router settings and we put in port forwarding for both the registration and the audio ports. Still no resolution. Last night I stripped out most options on the BCM for SIP trunking, enabled NAT compensation, and then in the router on the port that the BCM was plugged into, I removed EEE and flow control. This morning??-no missed calls. I'm waiting for today to see if it finally is clear. Then I'm going to try and break it to see what it is that resolved the situation since I changed 3 things. Let's see if I'm lucky and today's calls are processed perfectly.


Oh, I agree with that! I've seen the traffic and was commenting on that this morning with an associate. I intend on turning that off tonight and as I said, breaking the traffic to see what particular aspect caused the incoming problems.


Hey. Since I've seem to have eradicated this problem. I see the occasional call go astray, but could be a hangup on the callers part. I'm down to about 1% on a 800 calls a day account. I'm just wondering about whether anybody has any comments about media gateways? By default on both the BCM50 and BCM450 it seem the default minimum is 2 and when 2 calls are in play, and you look on BCM Monitor RTP session, it show active 2 on 2 for the media gateways. I'm wondering if I should increase the minimum. I'm going to place an active 3rd call while monitoring to see what it shows as to whether it's only a resource minimum and it would take additional media gateways on subsequent simultaneous calls?


Well media gateways seem to adjust as calls come in so 3 for 3 etc. Ports were previously forwarded as suggested when myself and a Cisco support tech tried to rectify the situation. So now, I'd like to turn off port 5060 (the registration port). I don't know why but when I turn it off, I don't get any calls through at all?? Strikes me strange as previously it used to present calls no problem, but now in an effort to shut down the hacker traffic, it won't receive any calls? I don't know if I have to reboot the router or shut down the registration and re-register the SIP account to get it to allow traffic? I tried this here on another platform but allowing or disallowing port 5060 forwarding makes no difference aside from the hackers. Same BCM programming in place on both platforms?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close