×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Crystal Reports - Report blank after entering 2 parameters and tables not showing all data

Crystal Reports - Report blank after entering 2 parameters and tables not showing all data

Crystal Reports - Report blank after entering 2 parameters and tables not showing all data

(OP)
I have a Crystal Report in which I have (2) dynamic parameters created:

ItemID (this is a string using list of values = static)
Serial Number (this is a string using list of values = static)

The user will enter and Item# and it's corresponding serial number, which will then display a bar code label.
After entering the data, the label form comes back as a blank report. (no data)
I verified the data being entered is within the tables and it's valid data.

Additionally, I noticed when clicking "Browse Data" on both of the above fields, I'm only seeing a portion of the data and not all records.

Also, I have to "login" to the SQL database from within Crystal in order to query the tables.
Is there some information on how to automatically log into the database by default? I've attached information regarding the properties of the connection.

I would very much appreciate some assistance.
Thanks in advance!

MD

RE: Crystal Reports - Report blank after entering 2 parameters and tables not showing all data

If you are setting these up as dynamic cascading parameters, the issue if probably that the combination of values generated by the two parameters exceeds 1000. Please see these threads: thread766-1659034: cascading parameters missing some contacts or thread767-1563656: Trouble with dynamic cascading parametet-Crystal Reports.

I think you should create a separate post for your second question.

-LB

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close