×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

close to desperation Postfix/Dovecot everything BUT sending mail works.

close to desperation Postfix/Dovecot everything BUT sending mail works.

close to desperation Postfix/Dovecot everything BUT sending mail works.

(OP)
Hi Guys,

Even though I'm new here. I do have some time under my belt with Linux, Mailservers and such.

But I'm completely stuck
And I feel kind of daft for coming to ask but I seem to be the only one having this problem.

My postconf -n:

CODE -->

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
compatibility_level = 2
default_transport = smtp
home_mailbox = Maildir/
inet_interfaces = all
inet_protocols = all
mailbox_size_limit = 0
mydestination = formule1.demon.nl, localhost.demon.nl, localhost, armintangelder.nl, stormtangelder, stenntangelder
myhostname = formule1.demon.nl
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 192.168.10.0/24
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
smtpd_tls_cert_file = /etc/ssl/certs/server.crt
smtpd_tls_key_file = /etc/ssl/private/server.key
smtpd_tls_protocols = !SSLv2, !SSLv3
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
virtual_alias_domains = nxtgenracing.co.uk
virtual_alias_maps = hash:/etc/postfix/virtual 

My dovecot -n:

CODE -->

# 2.2.27 (c0f36b0): /etc/dovecot/dovecot.conf
# Pigeonhole version 0.4.16 (fed8554)
# OS: Linux 4.13.0-37-generic x86_64 Ubuntu 17.10 
auth_mechanisms = plain login
login_greeting = Dovecot ready.
mail_location = maildir:~/Maildir
namespace inbox {
  inbox = yes
  location = 
  mailbox Drafts {
    special_use = \Drafts
  }
  mailbox Junk {
    special_use = \Junk
  }
  mailbox Sent {
    special_use = \Sent
  }
  mailbox "Sent Messages" {
    special_use = \Sent
  }
  mailbox Trash {
    special_use = \Trash
  }
  prefix = 
}
passdb {
  driver = pam
}
protocols = imap
ssl_cert = </etc/ssl/certs/server.crt
ssl_key =  # hidden, use -P to show it
userdb {
  driver = passwd
} 

I did not do to much work in my master.cf nor my main.cf
But if needed just shout.

I've been at it for days, googled my hind side off.

Problem is...

I receive mail, I can see everything, I can connect, I can read. But sending gives me just one error:

Connection to the server failed or was dropped. error code: -3253 (Outlook client on mac!)

EDIT: And my previous mail server worked like a charm but was on OSX. My ISP is not blocking any ports!

Nothing in mail.log, mail.err, syslog or anything in any log about something not working..

Help is very much appreciated.

Regards,

Armin
--
Now beam down my clothes Scotty.. very funny!

RE: close to desperation Postfix/Dovecot everything BUT sending mail works.

(OP)
Okay,

And then it HIT me.... My processes where still Chrooted... changed it solved it...

Sorry... But as stated.. I probably was at it to long... To see my obvious mistake.

Master.cf is changed.

thanks
Armin

--
Very funny Scotty, now beam down my clothes

Regards,

Armin

--
Very funny Scotty, now beam down my clothes...

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close