×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

No wireless receiver detected on your computer message after plugging in a USB3

No wireless receiver detected on your computer message after plugging in a USB3

No wireless receiver detected on your computer message after plugging in a USB3

(OP)
I have 2 Windows 10 computers that are sharing the same exact problem. I purchased a USB3 Scandisk for backup and when I plugged it into the computer for the first time, my wireless mouse stopped working. This was on my Desktop computer. So thinking it was an anomaly, stupid me, I plugged it into my Dell Laptop and the wireless mouse stopped working on it as well. I spent a day doing everything I could think of including uninstalling the drivers. All my research so far has come to this; "no wireless receiver detected on your computer".
I went to Staples to talk to the IT professional there and he showed me a stack of computers with the same problem. They didn't know how to fix this issue.
The 2 mice I am using are both Logitech M215 and M325 models.
Does anyone know of this and can tell me how to fix it. PLEASE

Update; the Staples IT guy says $159 for each computer and they have a fix. I won't be buying any more computers from them.
I still need help if anyone knows what to do.

Dave
drjorde@gmail.com

DrJorde
Webmaster
http://drdave1.tripod.com

RE: No wireless receiver detected on your computer message after plugging in a USB3

Sounds very like you have been hit with the Win 10 kb4074588 update glitch/bug. Read the 'Known issues' section which seems to describe the exact problem you are having with USB devices...

RE: No wireless receiver detected on your computer message after plugging in a USB3

(OP)
Thanks Rick I will check it out.

DrJorde
Webmaster
http://drdave1.tripod.com

RE: No wireless receiver detected on your computer message after plugging in a USB3

(OP)
I had to go to Windows Support Level 2 to get it fixed. The level 1 staff spent 2 hours to no avail before sending me to the next level. They fixed it less than 10 minutes and it happened so fast I didn't ralize it was fixed forefront they asked if there was anything else they could do for me.
The same exact thing happened on my wife's Toshiba Laptop. After two separate calls hanging up on me (My Magic Jack times out, who knew) I decided to try to do a reset and that fixed it. So all 3 W10 computers are now working and I also have a thumbdrive that will allow me to return my Desktop back to W7 if I choose.
Thanks everyone.
Dave

DrJorde
Webmaster
http://drdave1.tripod.com

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close