×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

No audio on SIP Trunks on incoming calls
3

No audio on SIP Trunks on incoming calls

No audio on SIP Trunks on incoming calls

(OP)
Hi everyone, I have an ip 500v2 ver. 9.1.5 with Sip trunks (with Nexvortex) for outgoing and incoming calls. No DID's just calls come in on sip trunk and are routed to a hunt group, rings a couple of phones then auto attendant picks up after 4 or 5 rings. Outgoing calls work great but no audio on incoming calls once answered. Below is what nexvortex says is happening:

The request line URI for my initial invite to you:
U 2018/01/02 22:22:55.403401 nVproxy:5060 -> 66.23.190.100:5060INVITE sip:14794647776@174.71.152.35 SIP/2.0

Your 20OK, contact header back to me showing the private IP:
Contact:
And your connection part of the SDP portion:
Contact: sip:14794647776@192.168.90.251:5060;transport=udp

They say in c= header they see my ip office ip address is why no audio. They need to see my wan ip in that header. How do I get this wan ip to show up in the c= header instead of my phone system ip address? Thanks
Note: I am using a Cisco RV320 Router.

RE: No audio on SIP Trunks on incoming calls

Network Topology

| ACSS SME |

RE: No audio on SIP Trunks on incoming calls

Is the SIP transport tab set to use that LAN, if not then having network topology populated will make no difference.

You could try

Changing Open Internet to Unknown
Binding Refresh to 60
UDP to 5060
TCP to 5060
TLS to 5061

| ACSS SME |

RE: No audio on SIP Trunks on incoming calls

Poor provider...

RE: No audio on SIP Trunks on incoming calls

You can't have Open Internet in Network Topology as then it will not use the Public IP.

You need to set it to for example Static Port Block.

"Trying is the first step to failure..." - Homer

RE: No audio on SIP Trunks on incoming calls

(OP)
Thanks everyone for your replies. I will be back over on site tomorrow sometime and will change my topology settings. I will let you know if that was a fix. Thanks again

RE: No audio on SIP Trunks on incoming calls

Try STUN as well...

RE: No audio on SIP Trunks on incoming calls

(OP)
Well, I and a local computer tech worked on this for a couple of hours of no avail. Tried several different settings in the Network Topology of no avail. Don't have a stun server to use and to run stun. The IT guy is going to bring over a different router than this cisco. Might have to use wireshark to trace SIP connections. I am trying to come up with a managed switch with port mirroring capabilities or an old hub that broadcast to all ports for testing SIP traffic from phone system to router. If anyone has anymore thoughts on this, please feel free to reply. Thanks

RE: No audio on SIP Trunks on incoming calls

Have you set the SIP trunk to use Network Topology as well?

"Trying is the first step to failure..." - Homer

RE: No audio on SIP Trunks on incoming calls

(OP)
It is set to none. Do I need to to set it to LAN1 even tho I do not have a stun ip address?

RE: No audio on SIP Trunks on incoming calls

2
Yes, as I posted 2 days ago without doing this the network topology tab is pointless.

| ACSS SME |

RE: No audio on SIP Trunks on incoming calls

(OP)
Ok thanks Pepp77. I will try that first thing this morning.

RE: No audio on SIP Trunks on incoming calls

(OP)
Thank to everyone. That was it. Enabled the Transport tab to use the Network Topology and all is working great. Thanks again to all my tech hero's. Restored my faith in a Cisco RV320 Routers. It was my bad in programming the sip tabs in the ip office.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close