×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

SIP TRUNKING REGISTRATION DROPOUT

SIP TRUNKING REGISTRATION DROPOUT

SIP TRUNKING REGISTRATION DROPOUT

(OP)
I've managed to go through both examples and notes in the Forum here to set up voip trunks on a BCM450 6.0. Registration does come up on power up with the BCM, and remains online. The minute a single phone call whether to their echo test or simply dialed out and hung up is placed, within 2 minutes the registration on the hosting site shows "No registration found". In the BCM, it shows as still connected to the server??
If I reboot/restart, the BCM does come back up with registration in place with the Voip service.

Any ideas as to whether I just have some simple setting missing or checked incorrectly?

RE: SIP TRUNKING REGISTRATION DROPOUT

What SIP service are you using as there are many different prototols used these days and I've found that some BCM systems will require different settings to be used on a trial and error basis.

Against your SIP trunks, is the prime DN set?.

Firebird Scrambler

Nortel & Avaya Meridian 1 / Succession & BCM / Norstar Programmer

Website = http://somertel.com
linkedin

RE: SIP TRUNKING REGISTRATION DROPOUT

(OP)
It's Voip.ms that's being deployed.
Prime set is 221 as usual by default.
Tried putting the BCM in the DMZ this morning to see if that would make a difference incase it's a port blockage problem, but still no difference?
The connection to the Voip server drops out approximately 2 minutes after making any kind of call and if left for a while, does come back on it's own, only to drop off again if another call is made?

RE: SIP TRUNKING REGISTRATION DROPOUT

I use Flowroute for my SIP trunks and they have worked almost flawlessly for nearly 3 years. In your account settings under SIP registration, what is the expiry period set to? Mine is 1800.

I'd also suggest installing the latest system and desktop patches if they haven't been already.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952

RE: SIP TRUNKING REGISTRATION DROPOUT

Did you see my FAQ on SIP lines and providers?....here is user setup:

Voip.MS:
Parent Account
User Credentials:
SIP user name = the 6 digit SIP ID
Auth name = the 6 digit SIP ID
Auth Password = ?????????
Registration = Checked/Yes
Expiry = 3600

Sounds like it maybe a Network issue....maybe your Cable modem if CGN3


________________________________________

Add me to LinkedIN


=----(((((((((()----=
www.curlycord.com
Toronto, CAN

RE: SIP TRUNKING REGISTRATION DROPOUT

Curlycord, my expiry was originally set to 3600. I used to get almost daily transient alarms saying my SIP registration was lost and then recovered within a minute or two. Some of the ITSP templates I've seen have expiry set to 1800, so I changed mine to see what would happen. I now seem to get fewer of these momentary alarms.

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952

RE: SIP TRUNKING REGISTRATION DROPOUT

(OP)
I don't have any issues getting registered on the Voip. I get registered and if I don't do anything, I remain registered with no problem. Where I have the issue is when I make any phone call whether it's to an echo test or dtmf test or a regular phone call (which does go through), I lose my connection to the voip server after about 2 minutes and it stays disconnected unless I reboot the BCM or if I wait long enough (1/2 hour or so), it will reconnect on it's own? Been trying different settings in keep alive or NAT pinhole maintenance to no avail so far? I'm trying to see about putting it up on another BCM to see if I get any different symptoms.

RE: SIP TRUNKING REGISTRATION DROPOUT

ex: I think my FAQ states what had worked for me at that time but Voip.ms shows it is actually suggested to use 120 (2 minutes).

Instead of rebooting BCM try going into User Accounts / Modify and un check register, Ok it then turn it back on again.
Have you tried other SIP accounts? this will tell if BCM/Network or SIP account.

Also what are the alarms stating? nothing I presume?

________________________________________

Add me to LinkedIN


=----(((((((((()----=
www.curlycord.com
Toronto, CAN

RE: SIP TRUNKING REGISTRATION DROPOUT

(OP)
Thanks!! Curlycord!!

The idea of turning off the registration and turning it back on did speed up the testing process. It was suggested to me to try using zoiper phone to see if it would register and work properly behind this router/firewall and it did. So, I'll continue playing around with settings and see if I get anywhere. At least the testing will be faster by being able to re-register by turning off the register checkbox.

Thanks!

RE: SIP TRUNKING REGISTRATION DROPOUT

I mam not telling you what you should use I was only stating why I had it at 3600 (because it had worked for me back then) and only mentioned what they suggested to use....if no issues then do not bother changing it.

________________________________________

Add me to LinkedIN


=----(((((((((()----=
www.curlycord.com
Toronto, CAN

RE: SIP TRUNKING REGISTRATION DROPOUT

Ahh ok cool.
Ive yet to try that on my other accounts that are giving me grief.

________________________________________

Add me to LinkedIN


=----(((((((((()----=
www.curlycord.com
Toronto, CAN

RE: SIP TRUNKING REGISTRATION DROPOUT

UniqueName4Me,

After falling in love with the Norstar, I recently wandered into the BCM world. I too am using a BCM50 R6, and I am also using Voip.MS. While I have learned that there are some things about the BCM that aren't incredibly intuitive, registration should be simple. I came from the Asterisk world and was using the IAX protocol to trunk with VoipMS, I can't recall ever losing connection in all those years. Traversing a Firewall/NAT with SIP is totally new to me, and boy did I scratch my head for DAYS trying to figure out why VoipMS wasn't working properly.

My issue wasn't exactly the same as yours, rather, I could make outgoing calls with voice both ways just fine, but Incoming calls just didn't work no matter what. BCM Monitor would show for a brief second that there was an incoming call, but it never seemed to make it all the way through to the BCM. In addition, I was getting Alarm 51104 very frequently, and then it would recover with Alarm 51105. I stumbled upon most of the solution by complete accident, and I believe that VoipMS is to blame here.

Go to Voip.MS and login to your account, if you're registering with a sub account from the main account, that's the one we want to tweak. Get to the "Edit Account" screen, and in that page you will see two options under "Device Type"
A: Asterisk, IP PBX, Gateway or VoIP Switch
B: ATA Device, IP Phone or Softphone

When I set up my Sub-Account, I selected Option A, because, well, A BCM is an IP PBX. Wrong option apparently.
Something about the way that VoipMS has set their system configured does not play nicely with my BCM in that mode. Selecting option B solved almost all of my problems immediately. I still am getting alarm 51104/51105 every single day, almost always at exactly 1AM on the tampa.voip.ms server, but the BCM always recovers almost immediately. I have yet to figure out why this is happening unfortunately, but hopefully this information will help you iron out some of the kinks.

Best,
B.

RE: SIP TRUNKING REGISTRATION DROPOUT

LXLS,

I have a dynamic IP address on my DSL connection, so every time the router or the DSL connection hiccups I momentarily lose registration and then my BCM50 recovers almost immediately. It always brings in an alarm, but I just live with it at this point as there isn't much I can do that I haven't already tried aside from paying their exorbitant price for a static IP address.

You reminded me that my previous BCM50 would lose the LAN1 connection every evening at about the same time and then recover within the minute. I never figured that one out. I replaced the BCM50 and that problem disappeared.

Thanks for the info on VOIP.Ms

Brian Cox
Georgia Telephone
http://Georgia-Telephone.com
http://www.linkedin.com/in/briancox1952

RE: SIP TRUNKING REGISTRATION DROPOUT

(OP)
Thanks to all, I have my SIP trunks working well on the system except for a couple of wrinkles I have to work out.

1. When you place a call into the SIP trunk, if you abandon (hang up) before the call is answered, the call continues to ring on the set for about 25 seconds. I have tested this by both hanging up immediately after initiating the call and later waiting until the 25 seconds has almost expired. The 25 seconds seems to be a constant, irrespective of when you hang up. This presents dead calls to the subscriber, which can be frustrating.

2. Not directly related to SIP trunks but forgive me for trying to get around an issue I'm having with Target lines. When the phone number presented starts with a 9 or a 2, it tells me it is not a valid Pub. Received number? I removed 9 from my routing code for the SIP pool, but could not fix the problem with the 2? Should I have to remove the 9 to stop the conflict and where is the problem with the 2? As an example if it was 279, I tried renumbering the DN to another DN like 200, but that didn't correct the problem?

RE: SIP TRUNKING REGISTRATION DROPOUT

(OP)
As a follow-up, I did find another Target Line with the 2NX as the public or private rec'd number so when I deleted those entries, I was able to put in the 2NX without any issue. So, that resolves part of the 2nd problem, but I'd still like to know if I need to pick another digit other than 9 for my route access or am I mistaking something here?

Problem number 1 still exists.

RE: SIP TRUNKING REGISTRATION DROPOUT

1. Try SIPTrunking/GlobalSettings/RTPScope timeout of 0 seconds.

2. Some setup the Routing Table under SIP Trunking incorrectly such as 1 2 3 4 5 6 7 8 9
This can interfere with other area's since your tying up the digits there.

Use this from my FAQ:
DialingPlan/Routing/DestCode is 9 and RoutingTable/DestinationDigits is 9
Both have "Absorb" settings, in my example I have DialingPlan/Routing/DestCode/9/Absorb = 0 and SIPtrunking/Public/Accounts/Advanced/carrier.sip.com/Outbound Absorb Characters = 1

or in my case I use 2 digit access codes(which helps avoids these issues too):

DialingPlan/Routing/DestCode is 9X and RoutingTable/DestinationDigits is 9X
Both have "Absorb" settings, in my example I have DialingPlan/Routing/DestCode/9X/Absorb = 0 and SIPtrunking/Public/Accounts/Advanced/carrier.sip.com/Outbound Absorb Characters = 2

________________________________________

Add me to LinkedIN


=----(((((((((()----=
www.curlycord.com
Toronto, CAN

RE: SIP TRUNKING REGISTRATION DROPOUT

So here is my setup for Voip.MS...I have fixed all my 4 accounts.
Echo test OK after 3 minutes and both still registered.


IP Sub Syetem/General/
Public Network:
No STUN server
Discovered and Provisioned IP are the my Public IP from the carrier

DNS:
localdmonain
8.8.8.8
4.4.4.4

IP Trunks/SIP Trunking
Global Settings:
No local Domain
Port 5060
RTP Scope - None
Fallback - Disabled
Palyload - 101

Media Parameters:
Voice Activity Direction - Enabled
Jitter - Auto
Sizes - both at 20
Fax - G711
Rest - disabled

IP Trunks/SIP Trunking/Public
Settings
Port 5060
Both IP's are again my Public IP

Accounts:
Basic
Local toronto.voip.ms
Proxy toronto.voip.ms
Registrar toronto.voip.ms
Both ports 5060

Advanced
Support 100rel - Enabled (rest in list are not)
Signal Method - None
Signal Interval - 20
Session Timer - Disbaled
Active Call Limit - 0
ITSP association method - From header Domain Match

User Account
User and Auth names - phone number
CLID Override, PAI CLID, Contact - all are the phone number
Expiry 3600
Note that I have not played with User Account Settings so you may not need some of those entries.

Cable Modem
Bridged Mode

Router
SIP ALG - Disabled










________________________________________

Add me to LinkedIN


=----(((((((((()----=
www.curlycord.com
Toronto, CAN

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close