×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Mysql Insert Into not inserting

Mysql Insert Into not inserting

Mysql Insert Into not inserting

(OP)
I am trying to insert a record into my table and although errors are turned on the code executes but there is no record inserted. I have tried a couple different iterations of code, below is the current. There are only 3 fields I am trying to insert as it is stripped down from 10 fields to these 3. I am beginning to believe that the issue may be with mysql.

CODE --> php

$str ="Insert Into clients (username, password, email)
                            Values (:username, :password, :email)";
                
        $uname=$_POST["uname"];
        $password = $_POST["pword"];
        $hash = password_hash($password, PASSWORD_DEFAULT);
        $email=$_POST["email"];
        
        $stmt = $conn->prepare($str); 	     
        $stmt->execute(array('username'=> $uname, 'password'=>$hash, 'email'=>$_POST["email"])); 

RE: Mysql Insert Into not inserting

Hi

Extremely interesting that your code works for me. I expected to fail because of unspecified parameters. Anyway, first I would try to fix the parameter names :

CODE --> PHP ( fragment )

$stmt->execute(array(':username'=> $uname, ':password'=>$hash, ':email'=>$email)); 

BTW, sure there is no transaction started before the code you quoted ?

Feherke.
feherke.github.io

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close