Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Strange issue with Robocopy

Strange issue with Robocopy

Strange issue with Robocopy


We're experiencing a really strange issue with robocopy.

It doesn't move all the file that are in the source directory. It only moves only certain files without any logic about which files are choosen...

The files are generated from SAP on the SAP server. They are put in a folder that is exported via NFS. This exported folder is mounted on a Windows 2012 R2 server (drive letter Z:\).

We use Robocopy to move the files from Z:\Folder\subfolder to D:\winfolder\winsubfolder.

No fancy option is used. The commande is just "robocopy Z:\Folder\subfolder D:\winfolder\winsubfolder FILES* /MOV".

Last time we tried that, it only moved 10 files out of 42, some of those were there for more than 24 hours...

We already tried different things ("dir Z:\Folder\subfolder > nul" before launching the robocopy command, the "/fft" option, "/is" option...) but nothing worked...

We really don't understand what's going on...

It works fine with the command "move".

Any idea?


RE: Strange issue with Robocopy

Is it possible the files are locked or in use? That seems the most likely issue.

"But thanks be to God, which giveth us the victory through our Lord Jesus Christ." 1 Corinthians 15:57

RE: Strange issue with Robocopy

Hi, the files are not locked nore are they in use. That's the tricky part of it.
All the files are already there. "move" sees them all and move them nicely. Robocopy won't even see them all, only a few... And there's no logic to which files are moved or not... We've tried several times with different results.

RE: Strange issue with Robocopy

If you try the command again, do soem of the files that didn't get moved move? Or does it just consistently not move some files?

Try adding a '/l' (ell) to the command line. That will list the files that match the criteria. Also maybe a '/x' to also list files that are not selected. That may help figure out why they aren't being selected.

You should look at some of the "fancy options", specifically related to logging. They may be able to give you more information on what's happening.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close