Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


PE to CE running IPv6

PE to CE running IPv6

PE to CE running IPv6

Hi all

Let's see if I can get an answer to this before I solve it myself :)

SCENARIO: PE --> CE (Provider equipment --> Customer equipment)
PE + CE routers running IPv6 and IS-IS as the IGP.

PROBLEM: Lo0 is running IPv6 only on both systems (Dual-Stacking will be utilised later and that's not a problem). Because IPv6 is being utilised and not IPv4 normal BGP configuration cannot be completed as there is no router-id (I could manually put one in but it will only accept an IPv4 format). So, it appears my only option would be to run MP-BGP.

Having completed some investigation on the Cisco site and following their examples, I still get the error of "BGP-4-NORTRID: BGP could not pick a router-id. Please configure manually."

Normally with IPv4 the RID would be dynamic from the lo0 interface but it only accepts 32bits and not 128 bits.

Here is a snippet of the config I placed on both routers:

interface Loopback0
no ip address
ipv6 address xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx/128
ipv6 router isis area2

interface FastEthernet0/0
no ip address
duplex full
ipv6 address xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx/48
ipv6 router isis area2

router isis area2
net 49.xxxx.xxxx.xxxx.xxxx.00

router bgp 64600
bgp log-neighbor-changes
neighbor xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx remote-as 64512
neighbor xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx update-source FastEthernet0/0 - this is the CE interface to the PE

address-family ipv6
neighbor xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx activate
neighbor xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx route-map nh6 out

ipv6 prefix-list ninegroup seq 5 permit xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx/48 le 128
ipv6 prefix-list ninegroup seq 10 deny ::/0
route-map nh6 permit 10
match ipv6 address prefix-list ninegroup
set ipv6 next-hop xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx

So, as far as I can see this should work and accept the IPv6 lo0 RID, but it is not.

Anyone else come across this?

RE: PE to CE running IPv6

Okay, apologies, that was a bit quick solving it myself.......

I decided to use an alternative method, which has worked. It's just easier to manually set an RID ... so, I did and it is all up and running. I can live with that.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close