×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

eMG-80 - SIP (No Voice)

eMG-80 - SIP (No Voice)

eMG-80 - SIP (No Voice)

(OP)
Good day everyone!!

I am having a problem with SIP in eMG80 system, inbound and outbound calls are already functioning, the only problem is there is no voice, only noise.
What could this problem be? Thank you!

Best regards,
RR

RE: eMG-80 - SIP (No Voice)

Hi

You will probably find you haven't opened up the audio channels.

5588
5060
6254
7000-7335
6000-6048
8000-8048
9000-9048
10000-10239

All UDP ports.

Ok, Press Trans *#..... TRANS/PGM..... the transfer key?.......sigh!

RE: eMG-80 - SIP (No Voice)

If it is sip trunks and they are registering you don't need any ports open. The router will do it itself as the connection is originated from the internal network. Lack of speech is usually a routing issue. Check the firewall address and board based data,also ensure there is no alg enabled in the router.

RE: eMG-80 - SIP (No Voice)

(OP)
Hello eats and cody!!

Thank you guys for the response, I will try them today, and give an update!

regards
RR

RE: eMG-80 - SIP (No Voice)

(OP)
I opened up the ports but somehow it still has no voice, about the routing issue I double checked, and i guess the configuration is right.
about the ALG, it is not enabled.

Thank you again!

RE: eMG-80 - SIP (No Voice)

(OP)
Good day!!

It is working now, I put the public IP of the firewall and opened up the ports, and it worked!

Thank you guys for your help!!

Best regards,
RR

RE: eMG-80 - SIP (No Voice)

(OP)
Hello guys!

I encountered another problem, 70% of the inbound calls do not go through. is that maybe a FW problem?

best regards,
RR

RE: eMG-80 - SIP (No Voice)

What version is the eMG? How is the sip delivered, are you registering via the internet or is it a dedicated circuit from the supplier?

RE: eMG-80 - SIP (No Voice)

Do you have enough IPCL licenses for the SIP Trunks?

Ok, Press Trans *#..... TRANS/PGM..... the transfer key?.......sigh!

RE: eMG-80 - SIP (No Voice)

(OP)
Thank you for the fast response, the version of the eMG is 2.1.42, it is registering via the internet.

About the licenses, yes I have enough licenses.

Only the Outbound calls work all the time, I checked the ports and they are okay.

Thank you!

RE: eMG-80 - SIP (No Voice)

Shorten up the registraion timer in pgm133. It may be that the system looks like it is offline to incoming calls. I have had this where a router dropped the nat rule too quickly.

RE: eMG-80 - SIP (No Voice)

(OP)
Thanks! I did it but I still have the same problem. I'm now looking through all the settings again.

RE: eMG-80 - SIP (No Voice)

You could turn on the sip traces and watch what happens when the calls fail. See if they even get presented to the system. Do you have a sip phone you can log on in place of the emg to see if it still happens. That might help narrow it down.

RE: eMG-80 - SIP (No Voice)

(OP)
Inbound calls are not being presented in the system, there are no SIP packets when I test Inbound calls, that does mean I have a routing problem?
Thank you!

RE: eMG-80 - SIP (No Voice)

If you are using registration then you shouldn't need any config in your router. What type of router are you using? If you have ports forwarded try disabling them.

RE: eMG-80 - SIP (No Voice)

(OP)
I use "Provision" as UID Register, I am also using pfsense, I will try disabling the ports and see if it works.

5588
5060
5061
6254
7000-7335
6000-6048
8000-8048
9000-9048
10000-10239
these are the ports that I forwarded.

Thank you!

RE: eMG-80 - SIP (No Voice)

(OP)
I disabled the ports forwarded, but still no luck.

RE: eMG-80 - SIP (No Voice)

What happens to the 70% of calls? What do you receive from the network? error, busy or silence?

SIP ALG off on the router
Keep Alive needs turning on maybe
Does it happen if no one is on the phone? ie, no one on a line and a call can call in ok? 2nd call doesn't get through or is it just random?

Trace is the way forward. How many SIP Trunks have you got? Can you definitely have more than 2 concurrent calls? Our provider gives us 2 SIP Trunks as standard and I have to increase them to what the customer requested on the install, sometimes Ive forgotten and wondered at the end of the day why the phones are quiet!

A pattern will emerge once you narrow down the possibilities and we can help more.

Eats

Ok, Press Trans *#..... TRANS/PGM..... the transfer key?.......sigh!

RE: eMG-80 - SIP (No Voice)

"I use "Provision" as UID Register..."

You have to use "Register" in order for the system to register to the SIP provider.

PFSense usually breaks the registry for SIP. You can add a Manual Outbound NAT rule to solve this issue. Look at this example: https://support.flowroute.com/customer/en/portal/articles/1852969-configure-pfsense-firewall As an alternative, you can have your SIP provider use IP Authentication, just make sure you forward those ports back.

www.jacksonvilletelephone.com
Jacksonville Florida Telephone Systems

RE: eMG-80 - SIP (No Voice)

(OP)
What happens to the 70% of calls? What do you receive from the network? error, busy or silence?
They are not going through the PBX, on my telephone screen it says "ISDN Line Released Register on Timer"

SIP ALG off on the router
SIP ALG is disabled.

Keep Alive needs turning on maybe
Keep Alive is also turned on

Does it happen if no one is on the phone? ie, no one on a line and a call can call in ok? 2nd call doesn't get through or is it just random?
Yes, it is random actually, sometimes it goes through, but more percentage of the calls don't go through, it happens even if Lines are not in use.

Trace is the way forward. How many SIP Trunks have you got? Can you definitely have more than 2 concurrent calls? Our provider gives us 2 SIP Trunks as standard and I have to increase them to what the customer requested on the install, sometimes Ive forgotten and wondered at the end of the day why the phones are quiet!
I have done a packet trace, in the FW Side I cannot see any SIP Packets, it seems that it is blocking the packets, but I already allowed all traffic to go through because it is only in lab. Our provider gave us 2 SIP Trunks too.


A pattern will emerge once you narrow down the possibilities and we can help more.

Thank you very much for the response!!

RR

RE: eMG-80 - SIP (No Voice)

(OP)
Hello nfcphoneman!

I will ask the provider about that if it does not work today, thanks!

I have already tried Manual Outbound NAT Rule, but no luck.

Thank you for the response!

RR

RE: eMG-80 - SIP (No Voice)

(OP)
Hello Guys!!

It is now working both ways, it was a routing problem from the firewall. I deleted all the rules and began from the scratch.
Thank you for your support!!

Best regards,
RR

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close