Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


docmd.setproperty not working

docmd.setproperty not working

docmd.setproperty not working

I am sure I must be doing something silly...I am just trying to set the value of a control in my subform to false (the code is embedded into my main form behind a button).

I have tried numerous different syntax.... putting into square brackets, round brackets, referencing the subform directly, full stops instead of exclamation marks...even using a macro. When I search on line there is a lot of conflicting info on referencing subforms.

With this code below I get error 438 "object doesn't support this property or method" whereas before I was getting the error message that it didn't recognise the object at all but I'm out of options on what to try now...any help appreciated thanks

DoCmd.SetProperty Forms!FrmProcessEmails!SubAdult.available, acPropertyValue, 0

RE: docmd.setproperty not working

I'm not sure why you are using setproperty. Try:

CODE --> vba

Me.SubAdult.Form.available = 0 

This assumes the subform control name is SubAdult and the control name is Available. Don't confuse the subform control name and the source object.

Vevey, Switzerland
Hook'D on Access
MS Access MVP 2001-2016

RE: docmd.setproperty not working

That's correct, the subform control name is "SubAdult" and the control name within that subform is "available". Can you see any reason why this doesn't work please? I'm at the end of my tether with it...

RE: docmd.setproperty not working

And ive even changed the subform name to be the same as the source object as I was worried about that, so they are both now SubAdult. But still get this error.

RE: docmd.setproperty not working

I just tried Me.SubAdult.Form.available = 0 and it works! thank you thank you thank you!!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close