×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

A myriad of Windows 10 File Explorer issues on the same PC
2

A myriad of Windows 10 File Explorer issues on the same PC

A myriad of Windows 10 File Explorer issues on the same PC

(OP)
Hello

I've been having rather a lot of problems with my dad's PC of late. Some of these are covered in detail by blog posts on a myriad of other sites, some of which I have tried and have not helped here. Any assistance in either pointers for further diagnosis or ideas would be welcome.

Symptoms:
- "Class not registered" alert when clicking the taskbar icons for Edge or MS Store or double clicking a .JPG graphic file in Windows explorer.
- Windows+I and Windows+X key combinations don't work (however Windows+R, Windows+L and Windows+E do)
- Start menu doesn't work. Cortana is there but hasn't been used.
- Seemingly random BSODs on system startup
- Right click the desktop, properties and choosing Personalise gives "This file does not have a program associated with it for performing this action."

What have I tried (making reference to various articles over the last few weeks):
- iCloud is not and has never been installed on this computer
- sfc /scannow in normal mode found errors but couldn't fix. When run in safe mode it reported no errors at all.
- DISM /online /cleanup-image /RestoreHealth found no errors
- The Microsoft start menu troubleshooter from http://aka.ms/diag_StartMenu tells me that Microsoft.Windows.ShellExperienceHost and Microsoft.Windows.Cortana need to be installed properly. However, it doesn't tell me how to do this.
- creating a new user account and logging in as that user doesn't fix any of the problems. These are therefore not a corrupt user profile issue.

Its a standard Windows Home PC, now around 9 years old (originally supplied with Vista, upgraded to windows 7 shortly after it came out then upgraded again to windows 10 during the free upgrade period). Its been running smoothly on Windows 10 for months then this happens.

Has anybody got any ideas, short of wiping the machine and starting afresh?

John

RE: A myriad of Windows 10 File Explorer issues on the same PC

Run MEMTEST86+ from something like the Ultimate Boot CD. Run it a couple of hours.
Run manufacturer's hard drive diagnostic test from Ultimate Boot CD.

Do a clean boot - To perform a clean boot in Windows 10:
Press the "Windows + R" key to open a Run box.
Type msconfig and click OK.
On the General tab, click Selective startup.
Clear the Load startup items check box.
Click the Services tab.
Select the Hide all Microsoft services check box (at the bottom).
Click Disable all.

Reboot the computer and see if things are better. If not better, see last line below
If things are better, you should re-enable HALF the services like from the top to the middle of the list. REBOOT
If the problem comes back then you know the problem service is in the list you disabled
Start enabling one at time and rebooting. Seeing if the problem happens again. Then you have your culprit.
If re-enabling the first half doesn't cause the problem. Start re-enabling from the middle to the bottom.
It's a pain the rear, but I have found the problem child by doing this.

Other than total reload - refresh or reset

"Living tomorrow is everyone's sorrow.
Modern man's daydreams have turned into nightmares."

RE: A myriad of Windows 10 File Explorer issues on the same PC

(OP)
Thanks Goombawaho.

A clean boot with all non MS services disabled still gives these errors, but interestingly AVG Free started itself which I put down to an entry in the Registry Run keys triggering a start of the antivirus service.

Uninstalled AVG free, rebooted, tried again and got the same, so my guess is the Windows explorer issues relate to the installation having got corrupted somewhere. Reinstalled AVG Free.

About to start UBCD tests and will report back.

John

RE: A myriad of Windows 10 File Explorer issues on the same PC

Did all these issues start after an enforced update?

The reason I ask is I too had similar issues with File Explorer following and update earlier in the year.
Running the update again, cleared most of the issues except that selecting 'ThisPC' sometimes caused File Explorer to lock up.

I ran various repair tools but no problems were detected.

Since installing update 1703 all the faults, which apparently didn't exist have managed to fix themselves.

Keith
www.studiosoft.co.uk

RE: A myriad of Windows 10 File Explorer issues on the same PC

(OP)
Further information:

Memtest86+ didn't find any issues. No specific tool on UBCD for Samsung hard drives, but CrystalDiskInfo 7.0.5 in Windows gave it a clean bill of health.
Windows key + S also doesn't work.

I've also tried the reinstall of all apps via an elevated Powershell command prompt that is documented on a number of forum posts:

CODE

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} 

It appears to have made no difference.

audiopro - I'll check to see which build its running the next time i have it switched on and see if I can update to 1703 if its not already on there.

John

RE: A myriad of Windows 10 File Explorer issues on the same PC

(OP)
Update:
Something has made a difference, but I can't put it down to the Powershell script. MMC snapins such as computer management and event viewer, which did work when I started doing this, now don't. Weird.

audiopro -
Build is Windows 10 Home x64 build 1607 (14393.1358). Fortunately my PC is the same version so I can use that to copy problematic files reported by sfc /scannow, so I guess that will be next.

John

RE: A myriad of Windows 10 File Explorer issues on the same PC

(OP)
Latest update:
A review of the system and application logs found some indicating disk errors and a recommendation to run chkdsk /f. I did that, including a restart to fix locked files. A fair number of those were under C:\Windows\WinSxS which explains to my mind why dism followed by sfc /scannow couldn't fix them. Will try and rerun dism to reload those files then rerun sfc and report back.
Not sure if this explains the MMC snapins issue.

John

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close