×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Cross tab not joining columns

Cross tab not joining columns

Cross tab not joining columns

(OP)
I am very new to crystal reports and am trying to create what I think should be a fairly simple report. I am using version 11.5. I have 3 fields that I have inserted into a cross tab. It is creating two separate tables instead of one. Here is what I'm using:

loan type - row 1
term - column 1
amt packaged - summarized field

My group header is grouping by the term. The fields are pulling from a database and vary. What I am getting is:

term 1 total
loan 1 amt
loan 2 amt

term 2 total
loan 1 amt
loan 2 amt
loan 3 amt

What I need is:

term 1 term 2 total
loan 1 amt loan 1 amt
loan 2 amt loan 2 amt
loan 3 amt

What am I doing wrong here? I also attached a screenshot of what is pulling into my report. I appreciate any help!

RE: Cross tab not joining columns

Didn't look at your attachment, but from what you describe, you have put the crosstab in a term group header section. Instead, put it in the report footer and suppress the detail section and other sections, if you only want the crosstab to display.

-LB

RE: Cross tab not joining columns

(OP)
Yes I had it in a header. When I put it in the footer nothing displays. I can't hide all the other sections because they contain data. This is being inserted into a letter to a student advising them what they have been awarded in aid and loans.

RE: Cross tab not joining columns

Are you sure you placed it in the report footer? And that the report footer is not suppressed? You don't have to suppress other sections, I just thought you didn't have other data to display, and would not want a lot of blank lines.

-LB

RE: Cross tab not joining columns

(OP)
You are right, I was in a group footer not the report footer. Thank you so much! I've been pulling my hair out with this trying to figure it out. Such a simple fix! smile

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close