×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Lost repositories ...

Lost repositories ...

Lost repositories ...

(OP)
Hi everyone:

I seem to be having some issues with software updates. If I try to update via the GUI, I get this message: Unable to access software repositories

From the command prompt, I get this:

[admin@ucx50e ~]$ sudo yum update -y
Loaded plugins: fastestmirror, ucxrepo
Determining fastest mirrors
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
Eg. Invalid release/
removing mirrorlist with no valid mirrors: /var/cache/yum/addons/mirrorlist.txt
Error: Cannot find a valid baseurl for repo: addons

I'm currently running release 4. I did updates about 6 weeks ago, and everything was OK, but now, I'm getting these messages. Not sure what's up, or if there simply aren't any more updates I can get until I upgrade to r5.

Thanks for the help!

RE: Lost repositories ...

Do you have an active Software Assurance plan? Will Probably have to upgrade to RLS 5
Rls 4 was retired April 30, 2017. Don't know if it is still supported through updates.

RE: Lost repositories ...

(OP)
Thanks for the help! Yes - we're current with a support contract through September, 2017. My understanding is that R5 is a hefty update that cannot be done through updates. What's the best way to upgrade?

RE: Lost repositories ...

Upgrade instructions are on the emetro website. One of the first steps is to update the current 4.0 so you will still need to figure out why you can't access the repositories. Did anyone mess with the network in any way? Does your DNS work? Is the default gateway correct? It could also be on the emetro end (doing maintenance or something, however, updates go to many different places for them). I've encountered that error before as well but I just tried again a couple of hours later and everything worked fine.

https://www.emetrotel.com/tsd/search/node/software...

You will need to get an upgrade license before you can proceed. If you have a current support agreement, it should be no charge.

RE: Lost repositories ...

Forgot to mention that the license you will need has to be acquired AFTER the drive is re-imaged because the host ID will change and your old license file will not work.

You can buy a new R5 drive from emetro if you don't want to go through the re-imaging process but the license file issue will be still be there. Once you install the new drive and boot up the system, you will still need to request a new license.

I've done upgrades both ways and I prefer the re-imaging process. Saves you from opening up the box and messing with the interior wiring and PSTN cards (if you have a UCx50).

RE: Lost repositories ...

(OP)
Thanks telcodog. Nothing has changed as far as the UCx's configuration - at least that I know of. :) I just tried to log in and ping a host outside our network, and I received a reply, so it looks as though the UCx can get out OK. This problem has been persisting for about two weeks now. Perhaps I couldn't upgrade the core UCx stuff, but I should at least be able to upgrade SSH and Asterisk, no? Not sure why it's doing this.

I'll plan to get in touch with UCx support and get a plan together to upgrade to r5. Thanks for the help!!

RE: Lost repositories ...

(OP)
Thanks ucxguy. So it looks as though I can restore all of my extensions, their settings, the entire voice mail setup, all of my inbound and outbound calling lists, etc. right? How long should I allow for the upgrade?

RE: Lost repositories ...

To some extent, the upgrade time depends on your system and your Internet connection download speed. For example, if you have 40GB of call recordings to backup on UCx50, the backup step would take quite some time. If your download speed is slow (e.g., 1 Mbps or 2 Mbps), the imaging step would take longer (you need Internet connectivity for the USB installation, which downloads packages from online repositories). Finally, upgrading UCx20 takes significantly longer than for example UCx450 or UCx1000 because the system by itself is much slower.

If you don't have gigabytes of voicemail or call recordings, your download speed is reasonable, the initial 4.0 update of the UCx server, backup, and installation of the USB image takes roughly an hour. After that, you must request a new license from E-MetroTel, install it and finally restore the backup, configure your telephony card (if your system has one), recreate additional users (if you had some), add custom configuration files (if you have done any customization) and test if everything works as it should.

The elapsed time for the entire process includes
  • Update of your UCx 4.0 system, backup, installation of UCx 5.0 image from USB - about an hour
  • Obtaining a new license from E-MetroTel - this step could take as low as few minutes if you advised E-MetroTel before the upgrade by creating a ticket or when you do the upgrade during business hours, but it could take a number of hours if you do it after business hours without E-MetroTel expecting your license activation request
  • Restore of the 4.0 backup, configuration of a PSTN card, configuration of stuff that is not restored (users etc.) - this can take anywhere from 10 minutes (if you don't have users to create, custom files to recreate, or a large backup file to restore) to several hours (if you for example have a backup with 40GB of call recordings)
  • Verification of proper operation
For a relatively simple system - let's say UCx50 with a 4 port analog trunk card and a SIP trunk, only a few additional GUI users defined, no customizations of configuration files, backup size of 500MB or less, fast Internet download speed (20 Mbps or higher), done during business hours you would be looking at
  1. around 1 hour for the 4.0 update/backup/USB install of 5.0
  2. maybe 30 minutes to get a new license
  3. 15 minutes to restore data from the backup, configure the PSTN card and add the few additional GUI users
  4. 15 minutes to make sure all phones are properly registered on the upgraded system and to test incoming/outgoing calls using the PSTN/SIP trunks
In total, the entire upgrade would require approximately 2 hours - the downtime for users would be at least 80 minutes

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close