Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


BCM450R1 & 2050 Softphone Audio Issues

BCM450R1 & 2050 Softphone Audio Issues

BCM450R1 & 2050 Softphone Audio Issues

Hey all, trying to help a client whose Nortel BP went out of business years ago. Client has a 2050 on his laptop he uses in the office without issue but gets no audio when running over VPN. Looks like all signaling is working fine; DN registers and can make and take calls (can hear the numbers being pressed as dialing outbound) but no audio in either direction. I have an Avaya/Cisco voice background so I am comfortable with troubleshooting this kind of thing but am starting to think there may be a system setting that can help out here..?

Client uses Sonicwall NetExtender (SSL-VPN client) on his laptop (win7) and appears to have full connectivity through the Sonicwall. Client directs the 2050 to the internal IP of the BCM450. At first I was wondering if there is a setting in the BCM to force all audio to pull DSP resources from the BCM instead of audio streaming directly between the clients. In the IP Office world, there is a simple "allow direct media path" checkbox on the VoIP extension that needs to be disabled. But I continued testing and even if I call to the outside world I do not have audio either, which makes me think this is not the issue. Thought it may have been a Windows firewall issue so disabled that all together for a quick test and no change in performance.

System software version is: Not entirely sure what softphone firmware he is using but it is Nortel branded; I am using 3.04.0003 of the 2050 for testing from my office to see if I had different results to rule out the client/remote side network firewall and his laptop as culprits. Wondering if there is a known bug or issue with system software or a provisioning fix that may be able to resolve this problem.

Am I down to wireshark at this point for additional troubleshooting? If needed I can remote to my test machine and head out on site with another laptop to wireshark the system if need be but that is more intrusive than I was hoping to get. Threw a wireshark on my test machine NIC knowing things would be encrypted but I get a steady bi-directional stream of encrypted packets while on the call (what I have to assume is the RTP stream).

To add one thing to the mix, client says he had installed 4050 on test license and had audio working while remote.

Any thoughts/opinions would be appreciated, thanks!

RE: BCM450R1 & 2050 Softphone Audio Issues

I would tend to think that the problem is port related. However, you said that the BCM450 is at 1.0. Do you know the patching level as the last system patch was BCM450.R100.SU.System-016.201110-2.zip

It might be worth checking out the patch inventory first. The full listing I have is

BCM450 R1

PATCH ID: BCM450.R100.SU.System-016.201110 Category: GEN
PATCH ID: BCM450.R100.BCM-to-IPO-Migration-131 Category: LTD
PATCH ID: BCM450.R100.SU.Desktop-008.201112 Category: GEN
PATCH ID: BCM450.R100.UTPS-130 Category: GEN

Firebird Scrambler

Nortel & Avaya Meridian 1 / Succession & BCM / Norstar Programmer

Website = http://somertel.com

RE: BCM450R1 & 2050 Softphone Audio Issues

Your BCM 450 R1.0 is a little out of date. You will need to apply the System patch first. Then apply the desktop one. Finally the last patch I would install is PATCH ID: BCM450.R100.UTPS-130 Category: GEN.

Firebird Scrambler

Nortel & Avaya Meridian 1 / Succession & BCM / Norstar Programmer

Website = http://somertel.com

RE: BCM450R1 & 2050 Softphone Audio Issues

Thank you very much for your assistance, will simultaneously troubleshoot the VPN to ensure something isn't somehow restricted through the tunnel.

RE: BCM450R1 & 2050 Softphone Audio Issues

Are you an IT tech or a Telecom tech?
Have you read all the appropriate guides available for download on the BCM itself or just winging it?
Sorry to ask if the mouse is plugged in.

Most audio issue do seem to be Network related but not always....you stated that a 4050(assume 2050) did work on a test license (try and buy?).
A license has no effect on this....if it worked before then something has changed on the network? or the remote location is different? if so something on the remote end maybe?

All the correct ports are forwarded?


Add me to LinkedIN


Toronto Canada

RE: BCM450R1 & 2050 Softphone Audio Issues

I believe I answered a few of your questions in the first post but I can clarify smile

Avaya/Cisco engineer; very little Nortel knowledge. Extensive voice background, strong security/firewall background.

Here is what I know:
No ports need to be forwarded/opened on the firewall since client is using SSL VPN and not a NAT/ACL solution. Default tunnel parameters on these types of devices (especially of the era this one is) trust 100% of client traffic after authentication unless specifically told otherwise. I would either have zero connectivity; or full connectivity unless there were rules that stated otherwise (found none). That's why I decided to explore the Nortel side before investigating the network any further. Sonicwall's leave a lot to be desired in regard to detailed logging but I am not one to replace a functioning appliance until the device's lifecycle has truly run its pace.

Here is what I was told:
Client had used a different Nortel softphone at one point in time with a "trial install" (my notes from our meeting say "client stated softphone audio had worked over VPN when he had tried trial "4050" version of softphone but when trial expired he went back to 2050"). I have such little Nortel experience; I couldn't say if what he told me was dead on or ludicrous so I simply shared what he shared with me. He made it sound like the "2050" was the original softphone he was using and was licensed for; when he had audio issues remotely he had tried installing a different softphone app from Nortel and that app did not have the same audio issue. When the trial expired he went back to the 2050 and the problem returned. How accurate his recollection of events is or maybe my interpretation of them is quite a blur itself.

I agreed to fact-gather free of charge and determine whether our best starting direction would be firewall investigation or finding a legacy Nortel tech to assist with the system. The troubleshooting path I explored in my original post is what brought me here; to verify my hunch that partnering with shop that employs someone with Nortel experience was worth the client's money. I do agree that researching the upgrade path on an old BCM release would be a waste of my time (and the client's money), and I would certainly never go down a path in production that I am not familiar with or have not tested in my lab. smile

In regard to the "remote location" change - I ruled that out as the cause when I replicated the issue from my lab. I have some expensive Cisco gear with some very detailed logging and was able to ensure that the "remote side" of the network had zero effect on the transfer of data. My issues experienced were identical to his when he went off site.

My hunch at this point is a bug or mismatch of some sort; either on the Sonicwall or on the BCM. There is certainly not provisioning in the firewall that is configured to stop the flow of RTP through the SSL tunnel.

Hope this clarifies a few points smile Thanks!

RE: BCM450R1 & 2050 Softphone Audio Issues

The later Nortel / Avaya 2050 software version 3 onwards required a licence to run it although it would have a trial period for 90 days (I think).

Problems can occur if you revert the software back to Version 2, which doesn't require any keycodes.

What you need to do is to uninstall the 2050 software first. Reboot the computer and then go deep into regedit and remove all traces of Nortel / Avaya and 2050 references etc. Be careful you don't delete anything that doesn't refer to it.

Check that all references to e.g. C:\Program Files\Nortel or Avaya\2050 etc are removed. Reboot the computer and do a check again to be sure all traces have gone.

Then install the 2050 version software again (PC2050_V2_B0239.zip)and just follow the default prompts. Reboot the computer and finally, install the upgrade version (upgrade_setup_264.exe).

If you get stuck, then let me know as I once ran into wierd problems with getting one to work and it took me a while to figure out what had previously been done before I got involved.

Firebird Scrambler

Nortel & Avaya Meridian 1 / Succession & BCM / Norstar Programmer

Website = http://somertel.com

RE: BCM450R1 & 2050 Softphone Audio Issues

Yes thanks

Maybe load the older 2050 per above onto another PC or laptop that never had a previous softphone to test Firebirds theory too in case reverting does not work.


2050 version 2
Requires - IP Client

2050 version 3 and up
Requires - IP Client & 2050 User License


Add me to LinkedIN


Toronto Canada

RE: BCM450R1 & 2050 Softphone Audio Issues

I am trying to gather firmware for the Nortel tech but can't seem to find:
BCM450.R100.UTPS-130 Category: GEN.

On the Avaya site anywhere.

Once we have the system patched up we are going to explore the reg clearing route for him, but in the mean-time I am likely going to fresh-install the ver2 softphone on a fresh machine and test that way.

Thanks for all the help!

RE: BCM450R1 & 2050 Softphone Audio Issues

The attachment is the read-me file for the patch that you require. The full details are located here. However, you must already have BCM450.R100.SU.System-016.201110 or later installed!.

Software Update Name: BCM450.R100.UTPS-130

Applicable H/W Platforms: BCM450

Applicable S/W Platforms:,

Category: GEN

Installation Recommendations:
This update should be applied to all new installs of BCM450 Release 1.0.
Existing installations should have this update applied if they are experiencing
any of the issues that are corrected. There is no need to schedule specific
maintenance to apply this upgrade if there are no reported issues. In those
cases, systems should be updated at the next regular service opportunity.

Components and Versions:

utps 2.0.328.52.106

Required Updates:
- BCM450.R100.SU.System-016.201110 or later

Updates should be applied in the following order:-
- BCM450.R100.SU.System-016.201110 or later
- BCM450.R100.UTPS-130

Product Dependencies: None

Size: 22.49 MB

System Impact:
Time to apply approximately 10 minutes

Does update application force reboot: Yes

Other Impacts: None

Limitations: None

Update Removable: No

The following issues are addressed:

1.Inclusion of UNIStim 5.3 0621C8J,0623C8J,0624C8J and 0625C8J
for IP phones i2007, 1110, 1120e and 1140e respectively. Also,
062AC8J for 1210, 1220 and 1230 sets.

UNIStim Software Release 5.3 provides minor feature enhancements.
Five customer reported cases have been closed and numerous quality
improvements have been delivered with this UNIStim 5.3 software release.
Visit http://support.avaya.com/css/P8/documents/10015283...=
D2GMTgvRQ2QJjrfkNG5YTnJ4kSxqKJvL9RnN8hRY32SYhGJws8Vr!170487718 for the
detailed bulletin.

This update includes the content of the following superseded updates:

1. A Bluetooth headset can loose connectivity with its paired IP set.
The only way to make it work is to unpair the device, turn off
Bluetooth on the phone and exit. Then go back in and turn on
Bluetooth and repeat the pairing sequence.

Inclusion of new UNIStim4.2 firmware solves this issue.
0623C7M,0624C7M and 0625C7M for IP phones 1110, 1120e and 1140e respectively.
062AC7M for Ip phones 1210, 1220 and 1230.

1.Inclusion of UNIStim 4.1 firmware release for IP sets

1.Unable to add the 4th KEM to i2004 sets
When 4th KEM is added to i2004 phase 2 sets, the IP set resets.
This was caused by CoreTel engine sending the messages at a faster rate
than UTPS was able to buffer the messages and send them to the IP set.
The transmit buffer size in UTPS is increased to address the issue.

2.i2004 set goes back to default DSCP value for signaling after being restarted
The Unistim terminals are updated with the new DSCP values at every
boot up to address the issue.


1.i2007 volume fluctuates during calls when using headset 0621C4V
The issue is with Echo cancellation within the firmware, as it should not lower
the volume but cut down background noise.

Inclusion of UNIStim3.3 firmware for IP set solves the issue.
0604DCL for Phase II IP Phones (2001, 2002 & 2004).
0621C6P for IP Phone 2007.
0623C6R, 0624C6R, 0625C6R for IP Phone 1110e, 1120e and 1140e respectively.
062AC6R for 1210,1220 and 1230


1. Inclusion of the UNIStim Firmware Release 3.2 for IP Phones:
0604DCJ for Phase II IP Phones (2001, 2002 & 2004).
0621C6M for IP Phone 2007.
0623C6O, 0624C6O, 0625C6O for IP Phone 1110, 1120E and 1140E respectively.
062AC6O for IP Phone 1210, 1220, and 1230.

2. IP 2004 set with 2 KEMS attached is not registering and keep resetting
The UNIStim3.2 firmware (0604DCJ) fixes the problem with multiple
KEMs booting up. This firmware is included in this update.

3. Anomaly with headsets on 1120e IP Phone
This problem is experienced with the headsets connected to a 1120e IP Phone.
Incoming calls ring on both headset and the phone itself. Also, if the user is on a
call and a second call comes in the ring tone is heard in the headset as well as
the set, instead of just the set.
The UNIStim3.2 firmware (0624C6O) fixes the problem which is included in
this update.


1. No speech path after using Hot Desking
This problem is seen when the user tries to invoke/cancel HotDesking when the
IPSet involved in this scenario is in Call Alerting state. The fix for this
issue is to disallow HotDesking when the IPSets are in 'Call Alerting' state.


1. The last "L" of the "NEWCALL" softkey is shifted to the next key.
Support has been added so that all the softkey labels which are displayed
on 1110, 1120, 1140 IPSets are in lower case except for the first character.


It's best to contact me off line if you require any more assistance.

Firebird Scrambler

Nortel & Avaya Meridian 1 / Succession & BCM / Norstar Programmer

Website = http://somertel.com

RE: BCM450R1 & 2050 Softphone Audio Issues

Just wanted to provide an update - patches did help some small bugs the customer had seen but not this audio issue.

I ended up putting a 5506-X (Cisco) in place of the Sonicwall and the problem was immediately cleared. Dell/Sonicwall support could not find any issue with the TZ400 (except that it was a Sonicwall).

Not sure why the Netextender/TZ combo was passing SIP traffic and not RTP while on the SSL VPN connection but various patches they had requested did not solve the issue. Cisco's Anyconnect variant worked like a charm.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close