Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


IVR Recording not playing - does not exist in any format

IVR Recording not playing - does not exist in any format

IVR Recording not playing - does not exist in any format


Could someone please give me assistance with this issue.

I am running Asterisk 13 and have setup an IVR, the extensions.conf call flow seems to work fine up until the point of playing my pre-recorded audio file. The below error(s) are seen in the Asterisk console no matter what settings I change:

"file" does not exist in any format
(format (ulaw)): No such file or directory

Goto (digitalreceptionist,s,1)
-- Executing [s@digitalreceptionist:1] Answer("SIP/sipgate-00000122", "") in new stack
-- Executing [s@digitalreceptionist:2] BackGround("SIP/sipgate-00000122", "/var/lib/asterisk/sounds/en/MyAsteriskIVR.aup:ulaw") in new stack
[Dec 31 13:07:05] WARNING[19151][C-000000ab]: file.c:774 ast_openstream_full: File /var/lib/asterisk/sounds/en/MyAsteriskIVR.aup:ulaw does not exist in any format
[Dec 31 13:07:05] WARNING[19151][C-000000ab]: file.c:1247 ast_streamfile: Unable to open /var/lib/asterisk/sounds/en/MyAsteriskIVR.aup:ulaw (format (ulaw)): No such file or directory
[Dec 31 13:07:05] WARNING[19151][C-000000ab]: pbx_builtins.c:1100 pbx_builtin_background: ast_streamfile failed on SIP/sipgate-00000122 for /var/lib/asterisk/sounds/en/MyAsteriskIVR.aup:ulaw
-- Executing [s@digitalreceptionist:3] WaitExten("SIP/sipgate-00000122", "5") in new stack
== Spawn extension (digitalreceptionist, s, 3) exited non-zero on 'SIP/sipgate-00000122'

The directories are fine, as is the file - I have tried ulaw/gsm/.wav and .aup (audacity) as well as following the below guides to get the file correct.

I have also looked at many other forum posts which outline issues similar to this - these include reasons being:

* What user and group mode you are set as (root or asterisk)

* What folder link you have in asterisk.conf

* What format the file and location is entered in extensions.conf

I did read one such thread that said that the user and group "asterisk" needs to be present, is there a way to tell if this is the case also (in asterisk.conf) you can turn these values "on".
However none of these seem to have worked for me - any assistance would be appreciated.

Thanks in advance.

RE: IVR Recording not playing - does not exist in any format

The procedure is quite simple.

You created an IVR/Digital Receptionist (Main Menu)
Announcement - Select your menu
Direct the call to the created IVR.

How did you record the file?. Or did you upload from another source?

I have the same setup working just fine on my home network running Elastix

RE: IVR Recording not playing - does not exist in any format


Thanks for coming back to me.

The file has been uploaded in a few ways - both by this online file formatting tool:

And by the guidelines outlined here:

I think there is two issues related here - one related to the file itself and one related to the file location/privileges.
If you can provide more information on how you have set this up and potentially the IVR setup fragment from extensions.conf it would be appreciated.


RE: IVR Recording not playing - does not exist in any format

In your dialplan, you must specify the file name without any extension - for example MyAsteriskIVR. The Background application invokes a function that searches for the file in the sound file directory (/var/lib/asterisk/sounds) using extensions of all registered formats (sln, wav, WAV, gsm, etc.).

You could export your Audacity recording into an Asterisk compatible wave file by selecting the "Save as type" = "WAV Microsoft signed 16bit PCM" and the file name MyAsteriskIVR.wav. Put that wave file into /var/lib/asterisk/sounds and change your dialplan to
exten => s,n,Background(MyAsteriskIVR)
Alternatively - if you want to use language specific files - put the file into /var/lib/asterisk/sound/en and use
exten => s,n,Background(MyAsteriskIVR,,${CHANNEL(language)})

RE: IVR Recording not playing - does not exist in any format

Thanks for coming back with your response, I have tried out your suggestions but with no success, it has made a slight change to the error messages I now see.
Although I get similar results I now also see this starting RIFF result:

format_wav.c:164 check_header: Does not begin with RIFF
file.c:472 fn_wrapper: Unable to open format wav
Unable to open MyAsteriskIVR (format (ulaw)): No such file or directory

Looking at the file itself running the "file" command - I can see the RIFF present (or this is what I am lead to believe:
MyAsteriskIVR.wav: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit, mono 8000 Hz

The other potential problem I can see is the "format (ulaw)" in the log - ulaw is allowed in my sip.conf file - I need to understand if this is causing a problem also.

Thanks for your continued support with this.

RE: IVR Recording not playing - does not exist in any format

The problem is your wave file - it appears you did not export it in the correct format. Did you use the Audacity Export option and selected the format that I suggested?

You could test your dialplan with a built-in Asterisk prompt instead. For example, change the argument your pass to Background from MyAsteriskIVR to dir-intro and retest.

RE: IVR Recording not playing - does not exist in any format


Yes, I have retested, although both files with the "file" command present the same credentials if you don't export as you have said it does not work - its working now however - thanks for your help!

RE: IVR Recording not playing - does not exist in any format

I had issues with Audacity saving in the proper format.

I ended up saving them as MP3 files, and then converting THOSE into the proper format using Poikosoft's EZ Audio Converter (which allowed me to select 16 bit, 8000, mono... Audacity didn't have that option).

Just my $.02

"What the captain doesn't realize is that we've secretly replaced his Dilithium Crystals with new Folger's Crystals."


Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close