Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

TagHelpers version numbers

TagHelpers version numbers

TagHelpers version numbers

Ive been trying to develop a site in .net core MVC but have been getting a problem with TagHelpers and wonder if anyone might be able to suggest a solution

My site builds ok, but when I run it the web page displays the error

Cannot resolve TagHelper containing assembly 'Microsoft.AspNet.Mvc.TagHelpers'.
Error: Could not load file or assembly 'Microsoft.AspNet.Mvc.TagHelpers, Culture=neutral, PublicKeyToken=null'. The system cannot find the file specified.

1.@addTagHelper "*, Microsoft.AspNet.Mvc.TagHelpers"

In the _ViewImports.cshtml page

I have checked and I have the NuGet package installed and TagHelpers declared in the program.json, as below. I have tried changing the TagHelpers to v1.0.0-rc2 which is what intelligence shows, but doing so produces and incompatable with the Mvc assembly then, changing that, causes others and so on and so on.

I have tried

1.@addTagHelper *, Microsoft.AspNet.Mvc.TagHelpers

(ie no brackets) in the _ViewImports.cshtml page anfd that doesnt help

The project.json contains:

"dependencies": {
"Microsoft.AspNetCore.Diagnostics": "1.0.0",
"Microsoft.AspNetCore.Mvc": "1.0.0",
"Microsoft.AspNetCore.Server.IISIntegration": "1.0.0",
"Microsoft.AspNetCore.Server.Kestrel": "1.0.0",
"Microsoft.AspNetCore.StaticFiles": "1.0.0",
"Microsoft.EntityFrameworkCore": "1.0.0",
"Microsoft.EntityFrameworkCore.Design": {
"type": "build",
"version": "1.0.0-preview2-final"
"Microsoft.EntityFrameworkCore.SqlServer": "1.0.0",
"Microsoft.EntityFrameworkCore.Tools": {
"type": "build"
"Microsoft.Extensions.Configuration.FileExtensions": "1.0.0",
"Microsoft.Extensions.Configuration.Json": "1.0.0",
"Microsoft.Extensions.Logging.Console": "1.0.0",
"Microsoft.NETCore.App": {
"version": "1.0.0",
"type": "platform"

"tools": {
"Microsoft.AspNetCore.Server.IISIntegration.Tools": {
"imports": "portable-net45+win8",
"version": "1.0.0"
"Microsoft.EntityFrameworkCore.Tools": {
"imports": "portable-net45+win8",
"version": "1.0.0"


"frameworks": {
"netcoreapp1.0": {
"imports": [

If anyone can help I'd really appreciate it

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close