Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

nortel 2004 asterisk

nortel 2004 asterisk

nortel 2004 asterisk

Hi all
Looking for help with using a Unistim Nortel i2004 black with Asterisk (Ver. 11.21.0) Elastix and FreePbx. I have been able to register the phone OK to the system and make or receive calls. The system is on a virtual server and not on same Lan as phone. The issue is with the audio which from reading other posts seems to be a common problem. When making calls I have audio both ways however when the phone received an incoming call the caller can hear me but I am unable to hear them. For a short while after receiving a call I am unable to hear audio when making a call but again the person I am calling can hear me. This soon corrects back to no audio when receiving. Have tried changing rtp port, the rtp method eg 0,1,2,3 etc with no success. Have also tried other versions of asterisk and freepbx on its own eg version 1.8 etc but no different. I have attached both the unistim.conf file and a log after a call was received on the extension. Any help appreciated, thanks

Link to asterisk log http://pastebin.com/Jns8ZacU

RE: nortel 2004 asterisk

Most Audio issues are network related settings.

Check what ports are required by your PBX and open those ports as well input the port/s on the set itself.

Example port 7000 is required on BCM so on the set under Hostname select port 7000, on the router forward port 7000 to the PBX

We take the time to try to answer your questions for free, please return the favor and take the time to answer back and include any resolution you found elsewhere, thanks.


Toronto Canada

RE: nortel 2004 asterisk

Hi - did you ever get this resolved? I've been trying for ages to get unistim to work.

I'd really appreciate to know how you got this far - I'm a bit of a newbie with asterisk thou

It's not getting any smarter out there. You have to come to terms with stupidity, and make it work for you.

RE: nortel 2004 asterisk

You must set the public IP address in the configuration file. Uncomment the line
and set the value to the public address of your server (it should be the same address that you use when configuring S1/S2 values on remote Nortel IP phones).

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close