×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Cannot get php to parse

Cannot get php to parse

Cannot get php to parse

(OP)
Hi have wampserver installed and says apache is fine on a test and php modules are loaded etc, iis is using port 80 so I'm using 8080 for apache but I just get the php code in the browser and nothing is interpreted, ive searched on here hi and low and cant find an answer so I have to post this.. please help.

thanks in advance.

RE: Cannot get php to parse

If you have both Apache and IIS running there may well be some conflict between to two.

I'm not a number, I'm a free man

RE: Cannot get php to parse

(OP)
Well ive uninstalled wampserver and I believe my working directory with and php is now apache24/htdocs not inetpub/wwwroot area

RE: Cannot get php to parse

Quote (gandalf458)

If you have both Apache and IIS running there may well be some conflict between to two.
If they are on different ports there will not be any 'conflicts'


Quote:

but I just get the php code in the browser and nothing is interpreted

Which means that the IIS does not have the appropriate modules installed or configured for passing PHP code to the interpreter.

http://www.iis.net/learn/application-frameworks/sc...

Chris.

Indifference will be the downfall of mankind, but who cares?
Time flies like an arrow, however, fruit flies like a banana.
Webmaster Forum

RE: Cannot get php to parse

xampp easily works in parallel to IIS with changed port. Wamp should do, too.
You changed the apache config (httpd.conf) from Listen 80 to Listen 8080? Don't forget to restart apache

All these conf and ini files are read at startup, they are not live config! That's also valid for php.ini
Also, do you call your php scripts correctly? Are you using URI http://localhost:8080/your.php?
Do you put your php files into webroot?

Sorry, if you're not that new to this and don't make these mistakes, but all of this has to be done to make it work.

Bye, Olaf.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close