×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

SOAP request not returning response

SOAP request not returning response

SOAP request not returning response

(OP)
Hi trying to get this to work? The request below works in SOAPui but it just returns a response that is similiar if you opened the WDSL http://boohoo.live.venda.com/VendaProducts.wsdl in your browser?

strURL = "http://boohoo.live.venda.com/VendaProducts.wsdl"
strResponse = "<soap:Envelope xmlns:soap=""http://schemas.xmlsoap.org/soap/envelope/"" xmlns:soapenc=""http://schemas.xmlsoap.org/soap/encoding/"" xmlns:tns=""urn:VendaProducts"" xmlns:types=""urn:VendaProducts/encodedTypes"" xmlns:xsi=""http://www.w3.org/2001/XMLSchema-instance"" xmlns:xsd=""http://www.w3.org/2001/XMLSchema"">"& _
" <soap:Body soap:encodingStyle=""http://schemas.xmlsoap.org/soap/encoding/"">" & _
" <tns:VendaRetrieveProduct>" & _
" <email xsi:type=""xsd:string"">steve.roberts@boohoo.com</email>"& _
" <password xsi:type=""xsd:string"">somepassword</password>"& _
" <bsref xsi:type=""xsd:string"">boohoo</bsref>"& _
" <skuElements href=""#id1"" />"& _
" </tns:VendaRetrieveProduct>"& _
" <soapenc:Array id=""id1"" soapenc:arrayType=""tns:queryElement[1]"">"& _
" <Item href=""#id2""/>"& _
" </soapenc:Array>"& _
" <tns:queryElement id=""id2"" xsi:type=""tns:queryElement"">"& _
" <sku xsi:type=""xsd:string"">mzz82609</sku>"& _
" </tns:queryElement>"& _
" </soap:Body>"& _
" </soap:Envelope>"


dim http
set http=createObject("MSXML2.ServerXMLHTTP")
http.open "Get",strUrl,false
http.setRequestHeader "Content-Type","text/xml"

http.send strResponse

If http.Status = 200 Then
WScript.Echo "OK"
WScript.Echo http.responseText
else
WScript.Echo "ERRCODE : " & http.status
End If

RE: SOAP request not returning response

Not sure if I fully understand your requirement. I ran your code and just as expected, I was able to get the textual content of the WSDL.

RE: SOAP request not returning response

(OP)
Hi what is should return is all the attributes for product code MZZ82609. I spotted the end point is wrong it should be https://www.boohoo.com/soap/rpcenc/1 but this just returns a 500 error

I can get the same request to work in SOAPUI and also http://soapclient.com/soapmsg.html with SOAPAction as urn:VendaProducts#VendaRetrieveProduct how can I get this to work in VBS?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close