×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Ssh-keygen (Saving the key failed:)

Ssh-keygen (Saving the key failed:)

Ssh-keygen (Saving the key failed:)

(OP)
Hi guys,

Anyone encountered the following error.

1.) all keys and passphrases worked on aix 7.1.2
2.) upgraded to aix 7.1.3sp5
3.) none of the keys / passphrases work anymore.
4.) when generating new keys without passphrase everything is ok.
5.) when generating keys with passphrase and ssh-keygen fails.
6.) did check all file and directory permissions.
7.) same error with rsa,dsa and ecdsa keys


Generating public/private dsa key pair.
Enter file in which to save the key (//.ssh/id_dsa):
Enter passphrase (empty for no passphrase):
Enter same passphrase again:
Saving the key failed: //.ssh/id_dsa.

Any ideas?
Regards

RE: Ssh-keygen (Saving the key failed:)

hmmm, but maybe only password was too short? - maybe it was the reason? can you try set stronger/longer password? I didn;t check it before and now I already have installed updates from:

https://www-304.ibm.com/webapp/set2/flrt/doc?page=...

and problem is gone but I'm not sure what password length I was setting before the update when I reproduced "problem".

RE: Ssh-keygen (Saving the key failed:)

I noticed "//.ssh/id_dsa" as the suggested and accepted path. If you are not root then you cannot write to /. Let alone the incorrect // which AIX may or may not be able to ignore. I would suggest:
1. If you are running this as root, then please check that /.ssh/ directory exists and has 0700 permissions mask.
2. Checking your environment as "//" suggests that $HOME may be absent.
3. Trying to enter a direct path to the file, e.g. /home/myname/.ssh/id_dsa

The length of the passphrase has nothing to do with this.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close