Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

unix permission

unix permission

unix permission

Well, this question is rather about unix permission then scripting. I couldn't find an appropriate place to post.
Anyway, I have a question regarding unix permission. I have a file. While the owner of the file issued chmod 777 to the file. Supposedly other users should be able to write and execute the file. However, when other user login to the unix system, the file shows an * in the end and the user was not able to execute or do anything with the file. Only when login as the file owner that the file won't have an * in the end. How can I change the permission so that other user will also be able to write and execute the file? Gurus, please advise. Thank you very much.

RE: unix permission

Thanks Chris for the quick reply. I have tried this and it is still not working though.

RE: unix permission

it shows '*' where?

RE: unix permission

I have found out that when I change the permission for the file to 644, then the * will be gone. If I do 777, then there will be * in the end of file for example:
-rwxrwxrwx 1 appdb31 dba 8236 Sep 29 13:08 NewOverLoadGraph.jpg*

RE: unix permission

The asterisk isn't part of the file name. It's due to using a '-F' parameter to show executable files. You may have an alias for 'ls' that's adding it for you. But the asterisk is not part of the file name.

Each person that needs to access the file will also need to have at least execute access to the directories in the path to the file too.

RE: unix permission

OK, the * means that the file while being marked with the execute bit cannot be executed by the login user. There may be several reasons:
- the file was copied from another system and cannot run in this one
- the directory is an NFS or CIFS mount and the user cannot run it, which is pretty much a variation of the condition from the above

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close