×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Cannot access NFS share mounted on Linux client

Cannot access NFS share mounted on Linux client

Cannot access NFS share mounted on Linux client

(OP)
I am trying to mount a Windows Server 2012 NFS shared folder on a RHEL 6.5 client. It looks like I can mount the folder, but I cannot access it. When I try to access the mounted folder I get an “Input/output error”. Any suggestions?

When I run “rpcinfo /p” on the Windows Server I get:
program version protocol port
--------------------------------------------------
100000 2 udp 111 portmapper
100000 3 udp 111 portmapper
100000 4 udp 111 portmapper
100000 2 tcp 111 portmapper
100000 3 tcp 111 portmapper
100000 4 tcp 111 portmapper
100003 2 tcp 2049 nfs
100003 3 tcp 2049 nfs
100003 2 udp 2049 nfs
100003 3 udp 2049 nfs
100003 4 tcp 2049 nfs
100005 1 tcp 2049 mountd
100005 2 tcp 2049 mountd
100005 3 tcp 2049 mountd
100005 1 udp 2049 mountd
100005 2 udp 2049 mountd
100005 3 udp 2049 mountd
100021 1 tcp 2049 nlockmgr
100021 2 tcp 2049 nlockmgr
100021 3 tcp 2049 nlockmgr
100021 4 tcp 2049 nlockmgr
100021 1 udp 2049 nlockmgr
100021 2 udp 2049 nlockmgr
100021 3 udp 2049 nlockmgr
100021 4 udp 2049 nlockmgr
100024 1 tcp 2049 status
100024 1 udp 2049 status

From the Linux client:
[root@localhost /]# showmount -e 128.101.1.1
Export list for 128.101.1.1:
/Linux (everyone)

[root@localhost /]# mount 128.101.1.1:/Linux /mnt/Linux
[root@localhost /]# cd /mnt/Linux/
bash: cd: /mnt/Linux/: Input/output error

[root@localhost /]# ll /mnt/
total 40
drwx------ 2 4294967294 4294967294 12288 Aug 23 12:45 Linux

I have also tried using the following to mount the share, and I get the same error.
mount -t nfs -o proto=tcp,port=2049 128.101.1.1:/Linux /mnt/Linux

RE: Cannot access NFS share mounted on Linux client

Is the SMB/Samba server running?

RE: Cannot access NFS share mounted on Linux client

(OP)
I do not think so. Here is a list of all services installed and status.

Status Name DisplayName
------ ---- -----------
Running ADWS Active Directory Web Services
Stopped AeLookupSvc Application Experience
Stopped ALG Application Layer Gateway Service
Running AppHostSvc Application Host Helper Service
Stopped AppIDSvc Application Identity
Running Appinfo Application Information
Running AppMgmt Application Management
Stopped AppReadiness App Readiness
Stopped AppXSvc AppX Deployment Service (AppXSVC)
Stopped AudioEndpointBu... Windows Audio Endpoint Builder
Stopped Audiosrv Windows Audio
Running BFE Base Filtering Engine
Stopped BITS Background Intelligent Transfer Ser...
Running BrokerInfrastru... Background Tasks Infrastructure Ser...
Stopped Browser Computer Browser
Running CertPropSvc Certificate Propagation
Stopped COMSysApp COM+ System Application
Running CryptSvc Cryptographic Services
Running DcomLaunch DCOM Server Process Launcher
Stopped defragsvc Optimize drives
Stopped DeviceAssociati... Device Association Service
Stopped DeviceInstall Device Install Service
Running Dfs DFS Namespace
Running DFSR DFS Replication
Running Dhcp DHCP Client
Running DHCPServer DHCP Server
Running DNS DNS Server
Running Dnscache DNS Client
Stopped dot3svc Wired AutoConfig
Running DPS Diagnostic Policy Service
Running DsmSvc Device Setup Manager
Stopped DsRoleSvc DS Role Server
Stopped Eaphost Extensible Authentication Protocol
Stopped EFS Encrypting File System (EFS)
Running EventLog Windows Event Log
Running EventSystem COM+ Event System
Stopped fdPHost Function Discovery Provider Host
Stopped FDResPub Function Discovery Resource Publica...
Running FontCache Windows Font Cache Service
Running ftpsvc Microsoft FTP Service
Running gpsvc Group Policy Client
Running hidserv Human Interface Device Service
Stopped hkmsvc Health Key and Certificate Management
Stopped IEEtwCollectorS... Internet Explorer ETW Collector Ser...
Running IKEEXT IKE and AuthIP IPsec Keying Modules
Running iphlpsvc IP Helper
Running IsmServ Intersite Messaging
Running Kdc Kerberos Key Distribution Center
Stopped KdsSvc Microsoft Key Distribution Service
Stopped KeyIso CNG Key Isolation
Stopped KPSSVC KDC Proxy Server service (KPS)
Stopped KtmRm KtmRm for Distributed Transaction C...
Running LanmanServer Server
Running LanmanWorkstation Workstation
Stopped lltdsvc Link-Layer Topology Discovery Mapper
Running lmhosts TCP/IP NetBIOS Helper
Running LSM Local Session Manager
Stopped MMCSS Multimedia Class Scheduler
Running MpsSvc Windows Firewall
Running MSDTC Distributed Transaction Coordinator
Stopped MSiSCSI Microsoft iSCSI Initiator Service
Stopped msiserver Windows Installer
Stopped napagent Network Access Protection Agent
Stopped NcaSvc Network Connectivity Assistant
Running Netlogon Netlogon
Running Netman Network Connections
Running netprofm Network List Service
Stopped NetTcpPortSharing Net.Tcp Port Sharing Service
Running NfsService Server for NFS
Running NlaSvc Network Location Awareness
Running nsi Network Store Interface Service
Running NTDS Active Directory Domain Services
Stopped NtFrs File Replication
Stopped PerfHost Performance Counter DLL Host
Stopped pla Performance Logs & Alerts
Running PlugPlay Plug and Play
Running PolicyAgent IPsec Policy Agent
Running Power Power
Stopped PrintNotify Printer Extensions and Notifications
Running ProfSvc User Profile Service
Stopped RasAuto Remote Access Auto Connection Manager
Stopped RasMan Remote Access Connection Manager
Stopped RemoteAccess Routing and Remote Access
Stopped RemoteRegistry Remote Registry
Running RpcEptMapper RPC Endpoint Mapper
Stopped RpcLocator Remote Procedure Call (RPC) Locator
Running RpcSs Remote Procedure Call (RPC)
Stopped RSoPProv Resultant Set of Policy Provider
Stopped sacsvr Special Administration Console Helper
Running SamSs Security Accounts Manager
Stopped SCardSvr Smart Card
Stopped ScDeviceEnum Smart Card Device Enumeration Service
Running Schedule Task Scheduler
Stopped SCPolicySvc Smart Card Removal Policy
Stopped seclogon Secondary Logon
Running SENS System Event Notification Service
Running SessionEnv Remote Desktop Configuration
Stopped SharedAccess Internet Connection Sharing (ICS)
Running ShellHWDetection Shell Hardware Detection
Stopped smphost Microsoft Storage Spaces SMP
Stopped SNMPTRAP SNMP Trap
Running Spooler Print Spooler
Stopped sppsvc Software Protection
Stopped SSDPSRV SSDP Discovery
Stopped SstpSvc Secure Socket Tunneling Protocol Se...
Stopped svsvc Spot Verifier
Stopped swprv Microsoft Software Shadow Copy Prov...
Stopped SysMain Superfetch
Running SystemEventsBroker System Events Broker
Stopped TapiSrv Telephony
Running TermService Remote Desktop Services
Running Themes Themes
Stopped THREADORDER Thread Ordering Server
Stopped TieringEngineSe... Storage Tiers Management
Stopped TrkWks Distributed Link Tracking Client
Stopped TrustedInstaller Windows Modules Installer
Running UALSVC User Access Logging Service
Stopped UI0Detect Interactive Services Detection
Running UmRdpService Remote Desktop Services UserMode Po...
Stopped upnphost UPnP Device Host
Stopped VaultSvc Credential Manager
Running vds Virtual Disk
Stopped vmicguestinterface Hyper-V Guest Service Interface
Stopped vmicheartbeat Hyper-V Heartbeat Service
Stopped vmickvpexchange Hyper-V Data Exchange Service
Stopped vmicrdv Hyper-V Remote Desktop Virtualizati...
Stopped vmicshutdown Hyper-V Guest Shutdown Service
Stopped vmictimesync Hyper-V Time Synchronization Service
Stopped vmicvss Hyper-V Volume Shadow Copy Requestor
Stopped VSS Volume Shadow Copy
Running W32Time Windows Time
Stopped w3logsvc W3C Logging Service
Running W3SVC World Wide Web Publishing Service
Running WAS Windows Process Activation Service
Running Wcmsvc Windows Connection Manager
Stopped WcsPlugInService Windows Color System
Stopped WdiServiceHost Diagnostic Service Host
Stopped WdiSystemHost Diagnostic System Host
Running WDSServer Windows Deployment Services Server
Stopped Wecsvc Windows Event Collector
Stopped WEPHOSTSVC Windows Encryption Provider Host Se...
Stopped wercplsupport Problem Reports and Solutions Contr...
Stopped WerSvc Windows Error Reporting Service
Stopped WinHttpAutoProx... WinHTTP Web Proxy Auto-Discovery Se...
Running Winmgmt Windows Management Instrumentation
Running WinRM Windows Remote Management (WS-Manag...
Stopped wmiApSrv WMI Performance Adapter
Stopped WPDBusEnum Portable Device Enumerator Service
Stopped WSService Windows Store Service (WSService)
Stopped wuauserv Windows Update
Stopped wudfsvc Windows Driver Foundation - User-mo...


RE: Cannot access NFS share mounted on Linux client

(OP)
Ah, figured it out. I needed to add the user permissions on the Windows side. Since I want test systems to have access to this folder, I set R/W for the "anonymous loggon" group. Now I can view the directory.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close